PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > General Forums > General Discussion

General Discussion General use discussion forum for PhotoPost products.

Reply
 
Thread Tools Rating: Thread Rating: 6 votes, 5.00 average. Display Modes
Old November 8th, 2010, 10:09 AM   #1
Inchovochka
Junior Member
Verified Customer
 
Join Date: Jun 2010
Posts: 7
Avatars not shown and smth with character encoding

Hello, Chuck.
I have Photo Post Pro 7.03 installed at arvixe hosting. GREAT product by the way. The gallery is integrated with SMF 1.1.11. The integration works well. Still avatars are not shown in the gallery. They are shown only if the avatars are external. But not if they are uploaded to the forum.

Another thing is that Russian letters are not in a proper encoding. The site has two languages with English as default using utf-8. So I installed the gallery in English bu need to use Russian as well. Weird thing is that russian in comments is OK, but titles and descriptions it looks like a set of random characters.

What are the ways to fix this?
Here is a link to the gallery Scrapmuss gallery - My Photo Gallery
and forum Scrap&Chat - Index
Inchovochka is offline   Reply With Quote
Old November 8th, 2010, 01:19 PM   #2
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,029
You can not use two languages at the same time as language is a global configuration in our product. The gallery is either english or russian not both. You selected english so lets begin there.

I will tell you one thing though your using english which means your loading the character set as english

Code:
Content visible to verified customers only.
Thats not going to display russian in any manner. You would need to possibly edit your english.php file in the languages subdirectory of the product and on the contentmeta line change the charset to utf-8 that should get your russian displaying correct when using english as long as the russian is encoded in utf-8. The other more popular encoding for russian as noted by the russian language included in our product is windows-1251.

As far as avatars you would need to give me explicit examples so I can take a look at what you mean.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old November 8th, 2010, 10:09 PM   #3
Inchovochka
Junior Member
Verified Customer
 
Join Date: Jun 2010
Posts: 7
No problems with languages now. Thank you very much.
Now avatars. There are 3 options in SMF: server-stored pictures, URL to an external pictures and uploaded by users. Server-stored pics and external avatars are shown without any problems. But if I upload my avatar to the forum I can't see it in the gallery. May be this issue has nothing to do with PhotoPost and I have to deal with the forum instead? The thing is that avatars are supposed to be uploaded to attachments directory but it remains empty. And image location looks like this http/scrapmuss.ru/forum/index.php?action=dlattach;attach=17;type=avatar

Here is an example: Inchovochka's avatar is external and located in picasa web album. Admin's avatar is uploaded to the forum. You can see both of them in the forum
Code:
Content visible to verified customers only.
In the gallery here Princess - My Photo Gallery only Inchovochka's avatar is shown.
Inchovochka is offline   Reply With Quote
Old November 8th, 2010, 10:15 PM   #4
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,029
well I will look at this tomorow when I have time too late today off to bed
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old November 9th, 2010, 05:49 AM   #5
Inchovochka
Junior Member
Verified Customer
 
Join Date: Jun 2010
Posts: 7
no rush thank you
Inchovochka is offline   Reply With Quote
Old November 13th, 2010, 09:56 AM   #6
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,029
well I would need site info like ftp database etc to respond more but this is what I see in photopost

Code:
Content visible to verified customers only.
Now in the forum it is this

Code:
Content visible to verified customers only.
without knowing what the query we issue is returning in regards to profile results its hard to comment.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old November 16th, 2010, 10:40 AM   #7
Inchovochka
Junior Member
Verified Customer
 
Join Date: Jun 2010
Posts: 7
Am I the only one having this kind of problem? I did not suppose it would be so difficult.
I am not sure what you are talking about. Do you need FTP log in information and database user info?
Inchovochka is offline   Reply With Quote
Old November 16th, 2010, 01:45 PM   #8
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,029
I have been awaiting the information I asked for a few days ago. Yes I need a url and admin login as well as ftp and database information.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old November 16th, 2010, 09:40 PM   #9
Inchovochka
Junior Member
Verified Customer
 
Join Date: Jun 2010
Posts: 7
I'm so sorry, Chuck. I didn't mean to offend you.
I'm just upset that I cant set up the site as easy as I expected. I'm also surprised that this problem is not that common. So that you need a specific approach to it.
Anyway I apologize if I sounded rude.
I'll send you all the information in e-mail.
Inchovochka is offline   Reply With Quote
Old November 16th, 2010, 10:00 PM   #10
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,029
Not everyone uses SMF etc so when posting an issue about a problem its standard practice to include such info that we may suggest a solution. If no one has reported any such issue like your avatar issue then we need to take a quicker look and figure out what your specific issue is.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old December 1st, 2010, 12:23 AM   #11
atnguyen
Registered User
 
Join Date: Dec 2010
Posts: 1
Thank you. I have solved problems about avatar and charactor
atnguyen is offline   Reply With Quote
Old December 1st, 2010, 07:45 AM   #12
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,029
no problem
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old January 12th, 2011, 06:08 PM   #13
Inchovochka
Junior Member
Verified Customer
 
Join Date: Jun 2010
Posts: 7
Things changed recently. My gallery is now located here A community photo gallery - My Photo Gallery

vasilisy.ru is an additional domain for scrapmuss.ru

Yes, we started all over again. And now we still have the same problem. I have sent you an e-mail with all required information at support@photopost.com on November 16 from vesnakrasna(at)hotbox.ru. Did you receive it? All login information is still the same. But forum database now have a different name scrapia _vsilisyforum.
Please let me know if you need any further information
Inchovochka is offline   Reply With Quote
Old January 12th, 2011, 06:47 PM   #14
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,029
well there is a good chance as I said months ago that we might not support all avatar types. I really cant say without seeing the site and files etc. I am sorry but no I have not seen any such email about your site. This of course is three months later.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old January 13th, 2011, 04:45 PM   #15
Inchovochka
Junior Member
Verified Customer
 
Join Date: Jun 2010
Posts: 7
I send you another e-mail today from vesnakrasna(at)hotbox.ru. Hope you will receive this one
Inchovochka is offline   Reply With Quote
Old January 13th, 2011, 06:41 PM   #16
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,029
yes we see this I will look at this when I get a chance tomorow
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:41 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.