PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > General Forums > Before You Buy

Before You Buy Have questions about PhotoPost, ReviewPost and/or PhotoPost Classifieds before you buy?

Reply
 
Thread Tools Rate Thread Display Modes
Old August 20th, 2008, 03:47 PM   #1
Rudy64
Registered User
 
Join Date: Aug 2008
Posts: 6
Broken Photopost, and upgrade questions

I've just taken over admin duties for a Photopost installation on a vBulletin forum. The forum is outdated, at 3.0.0, but we're going to be upgrading that within the next day or so.

Right now, the forum is operation (more or less), but we have both vbPortal and Photopost in various stages of disrepair. Photopost won't even run (we get an error message), and vbPortal is only barely functional.

What we're planning on doing is upgrading everything to modernize the site and get it up and running again. With that, I have a few questions.

1) Should I get Photopost running again before we upgrade to the latest version? I'm wondering if installing an upgrade would fix any file/path problems we have, while still maintaining any data (uploaded images, database entries if there are any, etc.) so nothing is erased.

2) Upgrade order--should we upgrade vBulletin, vbPortal then Photopost? I noticed some code in this older version that mentions interfacing with vbPortal, so I'm thinking that Photopost may need to be the last upgrade I do.

3) Is there any way to find our license number? In vBulletin you can retrieve that from the PHP files themselves (as I've done on other vB installs). Is there a config file, a main PHP file or even a database entry that might have this? The site owner may or may not have the matching e-mail address needed to verify this ownership. (I'm thinking it's possible that a former admin may have purchased the license, then billed it out to the site owner.) This will help us decide which Photopost license option we need to purchase.

Thanks!
Rudy64 is offline   Reply With Quote
Old August 20th, 2008, 04:07 PM   #2
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,328
1. well an upgrade would not fix a broken photopost. You might need to address your errors before continuing

2. It would not matter from a photopost perspective.

3. Well if the owner of the site does not own the photopost license then he would most likely need to purchase a license since ownership is to the person who purchased. Obviously there is no site info here so I cant look anything up
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old August 21st, 2008, 10:56 PM   #3
Rudy64
Registered User
 
Join Date: Aug 2008
Posts: 6
Quote:
Originally Posted by Chuck S View Post
Obviously there is no site info here so I cant look anything up
I wish I could have pointed you to it, but I had to put up a temporary index page for the entire site so that I could at least give regular visitors access to the forum. (The vbPortal addon is also broken, and was wreaking havoc on both the site's home page and the forum.) Plus, I was moving other files and directories around.

Right now it is located at http://www.woodworkingcrafts.com/photo ...
Rudy64 is offline   Reply With Quote
Old September 2nd, 2008, 05:50 PM   #4
Rudy64
Registered User
 
Join Date: Aug 2008
Posts: 6
Strangely enough, I upgraded vBulletin to 3.7.3, and Photopost started working a little bit. After going into the database manually and changing some configuration settings (for pathnames), along with some config files I found, I managed to get it mostly functional. But, thumbnails are not displaying.

Do we really need to update Photopost? The site owner is going to hold off on upgrading for a bit. With vB at the latest version, our forum is now more secure and running properly. And it looks like Photopost may run just fine...but not knowing the product that well, I have to poke around to figure out more about how it works, and why thumbnails aren't showing up (if they were ever enabled in the first place).
Rudy64 is offline   Reply With Quote
Old September 2nd, 2008, 06:02 PM   #5
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,328
Photopost may need to be updated depending on what version your using but it sounds to me if images do not view your paths are not correct. You might need to make sure you visit this thread and follow the suggestions to update paths

http://www.photopost.com/forum/photo...rectories.html
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old October 5th, 2008, 07:58 PM   #6
Rudy64
Registered User
 
Join Date: Aug 2008
Posts: 6
Hi Chuck,

Sorry for the delay, but we had to get the forum and vbPortal up and running first. That and updates to a related site took up a lot of my time over the past few weeks. Anyway...

I do have images displaying now, and have updated all of the paths, etc. The problem I have now is that there is no upload link, nor can you view a member's own photo gallery--you get dumped back to a main page in the gallery (Home -> Custom View in the breadcrumb). I can't find much in the settings to further change. I do seem to notice that since this is integrated with vB, it appears as though I may not stay logged in.

I found that the version of PhotoPost here is 4.8. Out of date, I know, but I'm trying to get this working before we consider trying to upgrade. If it won't integrate with vB 3.7.3, then we may have to bite the bullet and get an upgrade (if funds allow).

The gallery is here:

Woodworking Crafts Photo Gallery - Main Index - Powered by PhotoPost

I do know you probably can't support us much, but if you sign up in order to try to help us out, let me know via PM. Or, I can set up a test account for you if need be.

Thanks in advance for what you can offer.
Rudy64 is offline   Reply With Quote
Old October 6th, 2008, 04:59 AM   #7
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,328
4.8 will not integrate with vbulletin 3.7 series that is for sure it is way to old a software it will not even work with 3.5 series

If it does not authenticate your users when you login then it is definately too old. 4.82 was right around when we added vb 3.5 series support. You would want to check that your database settings where correct to connect to the proper vbulletin and see if you can authenticate the user if not then you definately need to upgrade.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old October 6th, 2008, 10:48 PM   #8
Rudy64
Registered User
 
Join Date: Aug 2008
Posts: 6
OK--looks like we'll have to upgrade PhotoPost if we want this to work.

Thanks for your help, Chuck!
Rudy64 is offline   Reply With Quote
Old October 7th, 2008, 06:43 AM   #9
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,328
Not a problem have a good one.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old October 7th, 2008, 06:50 PM   #10
Rudy64
Registered User
 
Join Date: Aug 2008
Posts: 6
One last product question: if we have version 4.8 of this, should we be getting PhotoPost Pro, or PhotoPost vB Gallery? We just want to upgrade what we have and integrate it. (IOW, we don't want to create any additional work for our members.)

Thanks!
Rudy64 is offline   Reply With Quote
Old October 7th, 2008, 06:52 PM   #11
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,328
Photopost Pro as thats what your using.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:37 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.