PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > General Forums > General Discussion

General Discussion General use discussion forum for PhotoPost products.

Reply
 
Thread Tools Rate Thread Display Modes
Old January 12th, 2008, 07:19 PM   #1
Drunes
Junior Member
Verified Customer
 
Join Date: Feb 2004
Posts: 14
Bulk load issue

Bullk loads I copy the files into my directory submit them and then receive this error ...

Warning: getimagesize(c:/Inetpub/wwwroot/photo/uploads/1/Blade1.jpg) [function.getimagesize]: failed to open stream: No such file or directory in c:\Inetpub\wwwroot\photo\image-inc.php on line 251

Warning: Division by zero in c:\Inetpub\wwwroot\photo\image-inc.php on line 298

Warning: getimagesize(c:/Inetpub/wwwroot/photo/uploads/1/Blade1.jpg) [function.getimagesize]: failed to open stream: No such file or directory in c:\Inetpub\wwwroot\photo\image-inc.php on line 95

Warning: unlink(c:/Inetpub/wwwroot/photo/uploads/1/Blade1.jpg) [function.unlink]: No such file or directory in c:\Inetpub\wwwroot\photo\image-inc.php on line 107

No such file would be correct as there is a file by that name but without the 1 at the end of the file name.

I have bulk uploaded before without any issue. I am moving files from an old domain and legacy Photopost folders.

Last edited by Drunes; January 12th, 2008 at 07:26 PM. Reason: Additional information
Drunes is offline   Reply With Quote
Old January 13th, 2008, 09:27 AM   #2
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,531
Two things on bulk uploading. Check permissions on both data directories and ensure they are set to READ WRITE EXECUTE at every level and you should be fine. Next would be sure to check and ensure if any image you get stuck on is corrupt or not.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old January 13th, 2008, 01:37 PM   #3
Drunes
Junior Member
Verified Customer
 
Join Date: Feb 2004
Posts: 14
I double checked the permission this morning and they are fine I figured they were since I have uploaded bulk before without any issues. This are all photos that were on the legacy photopost site no I am not sure. I am going to take another shot at it this morning.

Check here is what I have figured out so far. Permission on the directory are correct. If I do a bulk upload 10 at a time. After cleaning up the directory the files upload however it does not delete the files from the upload directory that it just finished and it is tring to upload them a second time and since the file is there I assume that is causing the error. Delete manually the files that have just been uploaded and the next 10 will work.

Solution:

On IIS Windows Enterprise 2005 Server read write and execute permissions need to be set to read write and modify checking to make sure delete is included. That will allow the files to be deleted. Also discovered GD2 does not support bmp files. =D

So that is the last issue to resolve and I think we have the whole thing up and running on the new site.

Regards,
Jim

Last edited by Drunes; January 13th, 2008 at 02:22 PM. Reason: Additional information
Drunes is offline   Reply With Quote
Old January 13th, 2008, 03:02 PM   #4
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,531
yes on windows the linux 777 permissions translate to READ WRITE EXECUTE and as long as permissions are correct things should work fine as you noted. You where not deleting files in the uploads directory meaning the unlink commands could not work which is why you just looped around.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Server Load mihirp General Discussion 1 February 9th, 2007 01:28 PM
Bulk Move Issue Debbie General Discussion 1 December 14th, 2006 08:30 PM


All times are GMT -5. The time now is 08:36 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.