PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > PhotoPost Support > PhotoPost Pro Support Forums > Photopost Pro Import Scripts

Photopost Pro Import Scripts Looking to upgrade to PhotoPost? We'll post any importers we develop here.

Reply
 
Thread Tools Rating: Thread Rating: 3 votes, 2.33 average. Display Modes
Old November 22nd, 2010, 06:24 PM   #161
pakpassion
Junior Member
Verified Customer
 
Join Date: Nov 2010
Posts: 18
Quote:
Originally Posted by Chuck S View Post
The importer is in the first post of this thread

You need to unzip them and upload to your photopost directory and make sure to follow the instructions in my post.
As I said in my previous post I did that and I got a blank page. I downloaded the files uploaded them to my photopost directory and then called the vbag.php file in my browser like in the screenshot below. I get a blank page. Either I'm doing something wrong or it does not work.
Attached Images
File Type: jpg vbag_blank.jpg (34.9 KB, 8 views)
pakpassion is offline   Reply With Quote
Old November 22nd, 2010, 07:31 PM   #162
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,257
Custom Import Script for VB_Gallery to Photopost

Strange I downloaded the zip file extracted the two files uploaded them to my server and as you see this is what loads.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old November 22nd, 2010, 08:25 PM   #163
pakpassion
Junior Member
Verified Customer
 
Join Date: Nov 2010
Posts: 18
I downloaded it again, deleted the other files and uploaded it again. I tried in firefox & IE still I only get a blank page.
pakpassion is offline   Reply With Quote
Old November 22nd, 2010, 09:31 PM   #164
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,257
Are you sure your uploading correctly as in ASCAII not Binary?

The files have the correct permissions. The config file is 777 and the vbag.php is 644 unless your server requires something non standard?

There is nothing complicated about the actual script here its straight forward php. If the config file is new it comes up with that screen.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old March 3rd, 2011, 04:45 PM   #165
ihstiv
Member
Verified Customer
 
Join Date: Dec 2010
Posts: 58
Quote:
Originally Posted by Chuck S View Post
reeftalk.com/vbag.php Custom Import Script for VB_Gallery to Photopost

Strange I downloaded the zip file extracted the two files uploaded them to my server and as you see this is what loads.
When I go to your reeftalk example above I get an error message - and I'm getting the same error on my server. Is this no longer compatible w/ the latest versions of vbg and pp or something?
ihstiv is offline   Reply With Quote
Old March 3rd, 2011, 05:12 PM   #166
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,257
any years old examples would not be valid

what exact error are you getting I really can not comment without knowing this
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old March 3rd, 2011, 05:19 PM   #167
ihstiv
Member
Verified Customer
 
Join Date: Dec 2010
Posts: 58
I think I found the answer reading through more threads here. It looks like vbag.php will only work if the vbgallery had it's content imported from VB3, and not VB4, like mine.. correct?
ihstiv is offline   Reply With Quote
Old May 15th, 2011, 12:26 PM   #168
Markus.B
Junior Member
Verified Customer
 
Join Date: May 2011
Location: Austria
Posts: 12
files Import Problem!

Hello pp community,

I am trying to import my existing 2.4.3 vbgallery into a new 7.1 pp pro (and would like to switch of the vbgallery after this transfer) installation with vb 3.8.3 Forum integration, so far everything went through except the files import on the very last step...

encountered a Server issue because (might be) of the large amount >75k pics to import

Quote:
OK 200

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster at xxxxx and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
after about 15 times trying to get rid of the files import i gave up...
have also tried to set php time from "30 sek" to "0", but it get always lost after about 1,2 - 1,8 GB file transfer,.... i have to import about 7,8 GB

any suggestion are very welcome, what can i tell my host provider, i do have a managed Server...(cant find anything related in my access able logs)
Or is there a known solution to edit the import script accordingly?
(for example: step1 - 500 files + step 2 - 500 files etc.)

Quote:
register_globals = off
allow_url_fopen = off
magic_quotes_gpc = off (on - no difference)

memory_limit = 64M
max_execution_time (in Sek.) = 30 ( "0" not helps)
upload_max_filesize = 10M
max_file_uploads = 20

extensions = APC on

Php = 5.2.16
Webserver = Apache (cgi-fcgi)
BR, Markus

Last edited by Markus.B; May 15th, 2011 at 02:03 PM.
Markus.B is offline   Reply With Quote
Old May 15th, 2011, 02:26 PM   #169
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,257
Your hosting provider is the one who could provide more info here. Your getting a very generic server error there and maybe more info might be in your server logs. This is a very old script so maybe something in newer php that does not like something. although the file import is a simply mysql query that runs through results and does a simple copy command from the vbgallery file to the new pp data destination. There is nothing complex there about that although large copies can take awhile.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old May 17th, 2011, 04:23 AM   #170
fotografo74
Member
Verified Customer
 
Join Date: Feb 2011
Posts: 75
Chuck, i'm trying import my vBGallery photos but i have this error when importer start:
Code:
Content visible to verified customers only.

Why?
I use vBGallery's latest version e vBulletin 4.1.3
Thanks
Antonio
fotografo74 is offline   Reply With Quote
Old May 17th, 2011, 08:02 AM   #171
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,257
well I cant say if it will work with vbgallery 3 but you can try it

Your errors tells me your not inputting the correct database information asked on the config.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old May 17th, 2011, 08:12 AM   #172
fotografo74
Member
Verified Customer
 
Join Date: Feb 2011
Posts: 75
Quote:
Originally Posted by Chuck S View Post
well I cant say if it will work with vbgallery 3 but you can try it

Your errors tells me your not inputting the correct database information asked on the config.
Where i must put the information?
The file vbag.cnf.php has only this line <? $status="new"; ?>
When i go to vbag.php in browser i have the error...not configuration.
Thanks
Antonio
fotografo74 is offline   Reply With Quote
Old May 17th, 2011, 08:31 AM   #173
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,257
well the file should be a config screen. HMM maybe an issue with newer php version this is an old script.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old May 18th, 2011, 06:08 AM   #174
fotografo74
Member
Verified Customer
 
Join Date: Feb 2011
Posts: 75
Quote:
Originally Posted by Chuck S View Post
well the file should be a config screen. HMM maybe an issue with newer php version this is an old script.
Yes....
It does exist a section for paid modifications...? I have budget 100$ for update this importer script.....
fotografo74 is offline   Reply With Quote
Old May 18th, 2011, 09:15 AM   #175
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,257
well this is a vbgallery 2 series to Pro importer just as an reminder.

The only suggestion I have is maybe the contents of your config file this with the proper info of course

Code:
Content visible to verified customers only.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old May 18th, 2011, 09:19 AM   #176
fotografo74
Member
Verified Customer
 
Join Date: Feb 2011
Posts: 75
Ok, i try this...thanks.
Antonio

EDIT But i must modify vbag.php o vbag.cnf.php files?

Last edited by fotografo74; May 18th, 2011 at 09:27 AM.
fotografo74 is offline   Reply With Quote
Old May 18th, 2011, 09:28 AM   #177
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,257
Your vbag.cnf.php file would need to be the contents like noted. Also realize as the directions state that config file must be 777 permissions when you try and run vbag.php to update the contents but maybe you did not do that which could also be the root of your evils.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old May 18th, 2011, 09:34 AM   #178
fotografo74
Member
Verified Customer
 
Join Date: Feb 2011
Posts: 75
The cnf file is 777 permissions.
I have modified this cnf file but i have the same error with vbag.php

If i point to vbag.cnf.php i have blank page.
Thanks
Antonio

Last edited by fotografo74; May 18th, 2011 at 09:45 AM.
fotografo74 is offline   Reply With Quote
Old May 18th, 2011, 10:22 AM   #179
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,257
yeah something with your server maybe look at your error logs on the server. blank page is very general you need an error to know how to proceed. Maybe get your host to turn on display errors in php.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old May 18th, 2011, 11:01 AM   #180
fotografo74
Member
Verified Customer
 
Join Date: Feb 2011
Posts: 75
Ok Chuck, but i have the blank page to vbag.cnf.php . . . . to vbag.php i have the same error.
The problem is that not connect to DB. . . .
It's not simple update this very important script?
vBGallery now is version 3 . . .
Thanks
Antonio
fotografo74 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
import script for going from vBgallery to Photopost Pro? BrentWilson Before You Buy 2 January 7th, 2006 02:58 AM


All times are GMT -5. The time now is 12:46 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.