PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > PhotoPost Support > PhotoPost Pro Support Forums > Photopost Pro Import Scripts

Photopost Pro Import Scripts Looking to upgrade to PhotoPost? We'll post any importers we develop here.

Reply
 
Thread Tools Rating: Thread Rating: 2 votes, 3.00 average. Display Modes
Old January 6th, 2009, 05:52 PM   #61
Sola
Member
 
Join Date: Aug 2002
Posts: 177
Quote:
Originally Posted by Sola View Post
To import, you obviously have to install PP first. But do you need to link PP to the VB user database (since VBG depends on that)?

Secondly, this instruction doesn't explain the INITIAL process and VERSIONS supported.
Please don't hurry to answer these questions. I figured it out.

For others' benefit:
1) Yes.
2) Just install PP (same or different DB, doesn't matter), hook up to VB to share User system, unzip the import file and run VBAG.PHP, not the other one.
Sola is offline   Reply With Quote
Old January 7th, 2009, 08:14 AM   #62
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
Yep its pretty simple the import script does all the work provided all the proper information, sorry missed your post. it happens
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old January 15th, 2009, 02:19 PM   #63
drslipp
Junior Member
 
Join Date: Apr 2008
Location: Germany
Posts: 9
A belated Thank you for the hints on my request!
drslipp is offline   Reply With Quote
Old January 15th, 2009, 06:26 PM   #64
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
Not a problem glad to help out.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old February 18th, 2009, 09:52 AM   #65
Pretty Scrappy
Junior Member
 
Join Date: Dec 2008
Posts: 21
Images not showing up

I just imported everything from vgallery, and it looks like everything moved, but all the images are saying no thumb. Do i need to move the file on the server? If so what is the best way?
Pretty Scrappy is offline   Reply With Quote
Old February 18th, 2009, 10:28 AM   #66
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
Make sure in your config file for the import you placed the proper server paths to vbgallery files and photopost data directory and images will be imported.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old February 18th, 2009, 11:41 AM   #67
Pretty Scrappy
Junior Member
 
Join Date: Dec 2008
Posts: 21
Quote:
Originally Posted by Chuck S View Post
Make sure in your config file for the import you placed the proper server paths to vbgallery files and photopost data directory and images will be imported.
you talking about the import?

I went ahead and copied the file over to the pro version, and they are showing now, but the pixels are visible.

If I deleted the file I copied, and re-run the import with it cofiged right it should bring them in right?
Pretty Scrappy is offline   Reply With Quote
Old February 18th, 2009, 12:48 PM   #68
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
If all the information is correct on the import script things will be imported correctly.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old February 18th, 2009, 01:08 PM   #69
Pretty Scrappy
Junior Member
 
Join Date: Dec 2008
Posts: 21
Quote:
Originally Posted by Chuck S View Post
If all the information is correct on the import script things will be imported correctly.
I can't seem to get it so I am going to wipe it out and try again. I will let you know how it works out
Pretty Scrappy is offline   Reply With Quote
Old February 18th, 2009, 01:23 PM   #70
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
server paths are like this

/var/www/html/vbgallery/files

/var/www/html/photopost/data

Obviously you need to use your correct server paths to vbgallery files and photopost data directories to get files copied.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old February 18th, 2009, 02:19 PM   #71
Pretty Scrappy
Junior Member
 
Join Date: Dec 2008
Posts: 21
Quote:
Originally Posted by Chuck S View Post
server paths are like this

/var/www/html/vbgallery/files

/var/www/html/photopost/data

Obviously you need to use your correct server paths to vbgallery files and photopost data directories to get files copied.
Ok i re-did everything, and i am still having this issue. I have also noticed that the few categories didn't transfer, and the users didn't transfer. It there anyway I can get you to look at this for me?
Pretty Scrappy is offline   Reply With Quote
Old February 18th, 2009, 03:10 PM   #72
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
Users dont transfer they come from vb so there is nothing to transfer.

You can post a link to your galleries sure and we can tell you what we think is wrong.

If files do not transfer its pretty specific in that your server paths your using are incorrect.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old February 18th, 2009, 04:16 PM   #73
Pretty Scrappy
Junior Member
 
Join Date: Dec 2008
Posts: 21
Quote:
Originally Posted by Chuck S View Post
Users dont transfer they come from vb so there is nothing to transfer.

You can post a link to your galleries sure and we can tell you what we think is wrong.

If files do not transfer its pretty specific in that your server paths your using are incorrect.
Main Index - My Photo Gallery

Just an fyi the vgallery is fairly new, there really isn't a lot to transfer. I think theres around 30 or so photos, maybe 5 members categories. As for the users I have that fixed. I now see 117 user so thats cool. I also have the themes working right.
Pretty Scrappy is offline   Reply With Quote
Old February 18th, 2009, 06:07 PM   #74
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
Your import script shows you that it cant find the files

Warning: copy(/home2/eyedrea2/public_html/gallery/files/8/5/85-pm_003.jpg) [function.copy]: failed to open stream: No such file or directory in /home2/eyedrea2/public_html/gallerypro/vbag.php on line 686

You have 213 files. Make sure in vbgallery admin your not using safe mode storage if so change it to normal storage and then run the import to grab the files.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old February 18th, 2009, 09:44 PM   #75
Pretty Scrappy
Junior Member
 
Join Date: Dec 2008
Posts: 21
Quote:
Originally Posted by Chuck S View Post
Your import script shows you that it cant find the files

Warning: copy(/home2/eyedrea2/public_html/gallery/files/8/5/85-pm_003.jpg) [function.copy]: failed to open stream: No such file or directory in /home2/eyedrea2/public_html/gallerypro/vbag.php on line 686

You have 213 files. Make sure in vbgallery admin your not using safe mode storage if so change it to normal storage and then run the import to grab the files.
Ok I think I have most of it. There is one thing I see right now and that is the members galleries aren't there. This is where 212 photos are, but you click on it and there isn't anything there. Any ideas?
Pretty Scrappy is offline   Reply With Quote
Old February 19th, 2009, 10:13 AM   #76
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
I beleive I posted an idea above? This has nothing to do with the import script or photopost pro.

I would have to look at your vbgallery but the issue is there. Why dont the files exist where they are suppose to. Thats why you cant import them. Thats why I asked you to make sure you where using the correct file storage implementation in the vbgallery admin maintenance. You did not respond.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old February 19th, 2009, 06:19 PM   #77
Pretty Scrappy
Junior Member
 
Join Date: Dec 2008
Posts: 21
Quote:
Originally Posted by Chuck S View Post
I beleive I posted an idea above? This has nothing to do with the import script or photopost pro.

I would have to look at your vbgallery but the issue is there. Why dont the files exist where they are suppose to. Thats why you cant import them. Thats why I asked you to make sure you where using the correct file storage implementation in the vbgallery admin maintenance. You did not respond.
Sorry about that. I did check and the storage safe mode was on. I backed up everything, and clicked and followed the steps to turn it off. Now all the photos have been moved, but there still is the issue with the members cats. You said that you would have to see the vgallery, Did you still need to?
Pretty Scrappy is offline   Reply With Quote
Old February 19th, 2009, 08:55 PM   #78
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
You have 181 photos in a personal album

All albums - Our Gallery

Everything transferred now that you changed that safe mode thing

Now as far as members galleries you might want to run the scan database tool in admin and rebuild members lastphoto field etc
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old February 19th, 2009, 09:04 PM   #79
Pretty Scrappy
Junior Member
 
Join Date: Dec 2008
Posts: 21
Quote:
Originally Posted by Chuck S View Post
You have 181 photos in a personal album

All albums - Our Gallery

Everything transferred now that you changed that safe mode thing

Now as far as members galleries you might want to run the scan database tool in admin and rebuild members lastphoto field etc
Ok I see that but I am actully talking about the other member galleries. I have attached a screen shot of what i am talking about. You can also see this by going here. Eyedreamers Forum this is the vgallery that I am trying to move
Attached Images
File Type: jpg ss1.jpg (101.5 KB, 10 views)
Pretty Scrappy is offline   Reply With Quote
Old February 19th, 2009, 09:21 PM   #80
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 74,493
Member Galleries - Our Gallery

They are all there!!
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
import script for going from vBgallery to Photopost Pro? BrentWilson Before You Buy 2 January 7th, 2006 02:58 AM


All times are GMT -5. The time now is 08:28 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.