PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > General Forums > General Discussion

General Discussion General use discussion forum for PhotoPost products.

Reply
 
Thread Tools Rate Thread Display Modes
Old April 8th, 2006, 12:25 PM   #1
jtorral
Member
Verified Customer
 
Join Date: Jan 2004
Location: Portland, Oregon
Posts: 142
file names only

for aome unknown reason, my gallery now only shows the file names of the pictures. has anyone experienced this before?

thanks

jt

www.rangefinderforum.com/photopost
jtorral is offline   Reply With Quote
Old April 8th, 2006, 01:23 PM   #2
jtorral
Member
Verified Customer
 
Join Date: Jan 2004
Location: Portland, Oregon
Posts: 142
question. does filepath in the pp_photos need to have something in it? i am running 5.3
jtorral is offline   Reply With Quote
Old April 8th, 2006, 02:00 PM   #3
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,218
You need to have the data path filled out correctly in the Admin => Global Options and then save and in Storage Options make sure it picks up the right path
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old April 8th, 2006, 07:33 PM   #4
jtorral
Member
Verified Customer
 
Join Date: Jan 2004
Location: Portland, Oregon
Posts: 142
here is the latest ...

All paths are valid. No question about it!
I have done a chmod -R 777 on the data and upload dirs
When you load the gallery, it loads the filename as described instead of the photo. However, if you right click on the file name you get the properties and it shows the valid path to the file.

here is where it gets tricky.
If you cut and paste the url from the image properties you get an apache forbiden message.

here is a sample:

http://www.rangefinderforum.com/phot...-the-creek.jpg

I go into the dirs and the file is there. Any suggestions?

Thanks,

JT
jtorral is offline   Reply With Quote
Old April 8th, 2006, 09:21 PM   #5
jtorral
Member
Verified Customer
 
Join Date: Jan 2004
Location: Portland, Oregon
Posts: 142
in case anyone has the same problem, here was my solution.

httpd.conf

Options Indexes Includes FollowSymLinks

my data dir are symbolic links.
jtorral is offline   Reply With Quote
Old April 9th, 2006, 09:44 AM   #6
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,218
So your path was incorrect.

Symbolic link is just that a symbolic link it is not the true path.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old April 10th, 2006, 10:34 AM   #7
jtorral
Member
Verified Customer
 
Join Date: Jan 2004
Location: Portland, Oregon
Posts: 142
Actually the path and symbolic link were correct and working before . The problem was that apache directive to allow symbolic links was turned off. However the real question is how did that directive get changed? I didnt do it.
jtorral is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:17 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.