PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > General Forums > General Discussion

General Discussion General use discussion forum for PhotoPost products.

Reply
 
Thread Tools Rate Thread Display Modes
Old January 12th, 2005, 01:10 PM   #1
WB
Member
Verified Customer
 
Join Date: Jan 2002
Posts: 265
Safe Mode Question

I ran across a few prior posts about running PhotoPost with Safe Mode on.

The posts seemed to say that it is possible and that the primary issue with safe mode being on is that by default it doesn't allow file uploads.

Is that the only concern or are there other tweaks that are needed?

If that's the only concern, it sounds like PhotoPost would work fine with Safe Mode on, particularly if there is no need for user uploads (for our use, our files aren't uploaded directly through PhotoPost but are already on the server and are just processed through the bulkupload interface).

Thanks.
WB is offline   Reply With Quote
Old January 12th, 2005, 03:53 PM   #2
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,012
If that being the case you would not necessarily have any issues.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is online now   Reply With Quote
Old January 13th, 2005, 02:00 PM   #3
WB
Member
Verified Customer
 
Join Date: Jan 2002
Posts: 265
omegatron:

Thanks, not sure I'm reading your response correctly though.

I'm assuming it is referring to if we didn't use user uploads but it could refer to the reference to the earlier posts (if that being the case that the posts said that....).

So just to make sure, you're saying:

No user uploads = PhotoPost running okay with Safe Mode On

correct?

Thanks.
WB is offline   Reply With Quote
Old January 13th, 2005, 03:25 PM   #4
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,012
If you use GD and are not allowing uploads from any user other than you userid 1 since when you install the program it exists you will be able to upload

The problem with safe mode is when a user uploads and the program tries to create a new upload directory so they can upload it can not as safe mode does not allow it. Since your uploads directory exists you wont have this issue.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is online now   Reply With Quote
Old January 14th, 2005, 01:12 PM   #5
WB
Member
Verified Customer
 
Join Date: Jan 2002
Posts: 265
Great, thanks for the clarification.
WB is offline   Reply With Quote
Old February 8th, 2005, 01:58 PM   #6
WB
Member
Verified Customer
 
Join Date: Jan 2002
Posts: 265
omegatron:

We've been experimenting with safe mode and everything appears to be working with the exception of the EXIF display.

We've checked the path to jhead, made sure it is accessible in the safe mode exec directory, has the proper permissions, the proper uid/gid, etc.

When we do a new galley the EXIF information is displayed for each photo but the information is incorrect (wrong filename, camera, etc.).

A rescan of the gallery will show it reprocessing but the information still comes out wrong. The error log doesn't display any php related errors.

Any thoughts as to what else we can check?

Thanks.

Last edited by WB; February 9th, 2005 at 12:20 PM.
WB is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Safe Mode Michael Blake Before You Buy 2 September 20th, 2004 05:26 AM


All times are GMT -5. The time now is 06:44 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.