PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > General Forums > General Discussion

General Discussion General use discussion forum for PhotoPost products.

Reply
 
Thread Tools Rate Thread Display Modes
Old June 21st, 2004, 03:52 PM   #1
DavidMacLean
Member
Verified Customer
 
Join Date: Dec 2002
Posts: 40
vb3 cookie userid not set unless 'remember me'?

Using: vbadvanced cmps, vb3, photopost 48, netscape 7.1

I am not reliably getting the integration between vb3 and photopost.
Sometimes my vb login is recognized by photopost, sometimes not. Paths and domains double-checked, I believe the problem is elsewhere...

Looks like photopost uses the userid cookie ('bb' may be your prefix).

After a little experimenting, it seems this cookie is only set if the user checks "remember me".

Yet vbadvanced cmps and vb3 are able to translate whatever cookies are kicking around into valid logins.

I am beginning to suspect I may need to use the sessionhash to get a record from the session table, check the userid is non-zero, and take that value as the userid.

If this were true, I'd have expected to find discussion of it here?

Anyone recognize this symptom? Am I barking up the wrong tree?

Please and thank you.
DavidMacLean is offline   Reply With Quote
Old June 21st, 2004, 05:50 PM   #2
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,538
Photopost uses the true cookie correct. There is a mod I beleive on Photopostdev.com where they modify VB login to always have the checkbox checked.

We use the userid and password to verify a user
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is online now   Reply With Quote
Old June 21st, 2004, 07:37 PM   #3
DavidMacLean
Member
Verified Customer
 
Join Date: Dec 2002
Posts: 40
Re: vb3 cookie userid not set unless 'remember me'?

Thank you for the speedy reply and confirmation.

I will check it out over at dev, but from what you are saying, my estimation is correct.

Forcing "remember me" on leaves the cookie on the PC. Public libraries, internet cafes etc. Not always desirable or secure. A tighter integration with vb3 might be something to consider for a future release.

Thanks again.
DavidMacLean is offline   Reply With Quote
Old June 21st, 2004, 08:14 PM   #4
Bryan Ex
Senior Member
Verified Customer
 
Join Date: Oct 2003
Location: Ottawa, Canada
Posts: 833
David... a fix for that was posted by another user a while back but it seems it's since been purged from the beta forum. Let me check my file notes and I'll send it to you later tonight.
Bryan Ex is offline   Reply With Quote
Old June 22nd, 2004, 08:07 AM   #5
Bryan Ex
Senior Member
Verified Customer
 
Join Date: Oct 2003
Location: Ottawa, Canada
Posts: 833
Okay David - try this out. It has completely fixed both the "Remember Me" and account activation problems with my VB3 & PhotoPost integration. Credit and thanks go to Interdit for assisting me on this one!

In the vb3.php file ( photopost/forums/vb3.php ) find the following code around line 234;

Code:
Content visible to verified customers only.
Right after that add the following;

Code:
Content visible to verified customers only.
A couple of lines down from there find;

Code:
Content visible to verified customers only.
And add below it;

Code:
Content visible to verified customers only.
Save and upload.

After these changes my users were able to access PhotoPost without the "Remember Me" box checked and they could also start browsing my site directly from the account activation window without having to log out and back in first. I had difficulty with this at first bcause I use a different cookie prefix (in my case "aso") and had to add it to the first couple of lines.

Sample with aso used as cookie prefix;

Code:
Content visible to verified customers only.
Hope that helps...
Bryan Ex is offline   Reply With Quote
Old June 22nd, 2004, 11:11 AM   #6
DavidMacLean
Member
Verified Customer
 
Join Date: Dec 2002
Posts: 40
You bet that helps, thank you.

The cookie prefix is given by $Globals['cookieprefix'], but the syntax gets tricky, I hard-coded for now just as you did.

If anyone from the photopost team is listening, also note the logout function in vb3 fails to include the cookie prefix.

Cheers
DavidMacLean is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cookie Issues with vB3 pgowder General Discussion 31 March 8th, 2005 09:43 PM


All times are GMT -5. The time now is 09:46 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.