PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > PhotoPost Support > PhotoPost Pro Support Forums > Photopost Pro Import Scripts

Photopost Pro Import Scripts Looking to upgrade to PhotoPost? We'll post any importers we develop here.

Reply
 
Thread Tools Rating: Thread Rating: 23 votes, 4.22 average. Display Modes
Old September 18th, 2009, 09:36 AM   #141
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
Well there is your issue. This importer is written to import coppermine to photopost standalone to standalone. bridges are gonna cause things to be out of whack.

Example if your coppermine does not have users in it where are we going to grab the user from? see what I mean?

Code:
Content visible to verified customers only.
we look at your coppermine photos table to see what the owner stuff is. If your users do not exist in coppermine then you can run into a serious issue then. If the users username is still there maybe you can use this script to get the right userid

http://www.photopost.com/forum/photo...vbulletin.html

That will work for any forum
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old September 18th, 2009, 01:58 PM   #142
Halfhidden
Member
 
Join Date: Sep 2009
Location: Penzance UK
Posts: 159
Just finnished running database cleanup after running userfix.
Sorry but only a marginal improvement.
Mostly the problem is the same. Users pictures belong to the wrong users. Also I noticed that the data import of the pictures only shows 4gigabytes worth of impoted pictures from Coppermine whereas the albums folder in Coppermine is in fact 8 gigabyte; that would explain why a lot of pictures are not showing up in categories.

Again comments placed beneath pictures are written by user "A" but has another users ID against it instead.
Halfhidden is offline   Reply With Quote
Old September 18th, 2009, 02:07 PM   #143
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
Please read my last post1!

Your definately not using the importer as it was designed. it was designed to import a standalone coppermine into a clean photopost install.

I mean how are we to know what users pictures belong to who if your coppermine has no users. See what I mean here. You told me your coppermine only has 3 users and thats the issue. The importer is not able to import the users so there is no way to get the user info for a user.

Now as stated you may be able to salvage some things by trying to run the other script I noted if your photopost is integrated with your SMF. That script will grab and insert a userid from smf based on the username thats on photos and comments. Now as stated that can only work if your actual photos and comments have the correct username on them. Do they?

Might help if you post a URL here.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.

Last edited by Chuck S; September 18th, 2009 at 02:14 PM.
Chuck S is offline   Reply With Quote
Old September 18th, 2009, 02:18 PM   #144
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
Also your going to have user ownership issues no matter what here. I looked at your site in our license records.

Not only did you import a coppermine into a photopost where you had no user records in coppermine you also switched smf to vbulletin.

You most definately have to run this script

http://www.photopost.com/forum/photo...vbulletin.html

Basically when you import your smf users into vbulletin using the vbulletin impex importers it will change all your userid's. Thus you need to run this other script I meantion to grab and update the users userid based on there username. Now as long as the usernames are correct on the photos and comments you should get everything sorted. As noted it all depends on the quality of data on import. I cant say how coppermine performs when its bridged with another app like SMF.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old September 18th, 2009, 02:21 PM   #145
Halfhidden
Member
 
Join Date: Sep 2009
Location: Penzance UK
Posts: 159
Quote:
Originally Posted by Chuck S View Post
Please read my last post1!

Your definately not using the importer as it was designed. it was designed to import a standalone coppermine into a clean photopost install.

I mean how are we to know what users pictures belong to if your coppermine has no users. See what I mean here. You told me your coppermine only has 3 users and thats the issue. The importer is not able to import the users so there is no way to get the user info for a user.

Now as stated you may be able to salvage some things by trying to run the other script I noted if your photopost is integrated with your SMF. That script will grab and insert a userid from smf based on the username thats on photos and comments. Now as stated that can only work if your actual photos and comments have the correct username on them. Do they?

Might help if you post a URL here.
Ok my misunderstanding. I was under the understanding that the userfix corrected the user ID's between VB and PP.
I can see what you want me to do....
Integrate Photopost with smf and run userid. Realine photopost with VB and then run database cleanup... is that right?
To answer your question yes the users and pictures are in the correct order on Coppermine... infact the coppermine gallery has no errors.
Sorry for misunderstanding... just been at this now for 30 hours and could do with a kip.
Halfhidden is offline   Reply With Quote
Old September 18th, 2009, 08:33 PM   #146
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
No the userfix will correct the issue as I said. Your photopost can be integrated with vbulletin thats fine.

All I am saying is for it to work you need to make sure the actual right usernames are on the photos so we can grab a userid because the script gets the userid from the username
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old August 8th, 2011, 03:32 AM   #147
gameover
Member
Verified Customer
 
Join Date: Nov 2007
Posts: 74
Hello,

Where can I find the script for the latest version of photopost Pro ?

Thanks
gameover is offline   Reply With Quote
Old August 8th, 2011, 08:28 AM   #148
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
This is the only script that I have ever released. It has nothing to do with what version of pro your using it is a self contained script which has nothing to do with pro code.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old August 8th, 2011, 08:34 AM   #149
gameover
Member
Verified Customer
 
Join Date: Nov 2007
Posts: 74
Well, I've read the last posts. I'm afraid because, I'm using coppermine in PHPNuke and want to convert his database into PhotoPost pro that integreted into VBulletin 4.x

It seems that impossible to do with this script, I'm ok ?
gameover is offline   Reply With Quote
Old August 8th, 2011, 03:26 PM   #150
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
can not say as I do not know how phpnuke coppermine work together. This script was written to import coppermine into photopost really standalones.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old March 7th, 2012, 04:23 PM   #151
gameover
Member
Verified Customer
 
Join Date: Nov 2007
Posts: 74
No news for me too
gameover is offline   Reply With Quote
Old March 7th, 2012, 04:44 PM   #152
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
all you can do is try it. It is an old script.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old March 7th, 2012, 04:54 PM   #153
gameover
Member
Verified Customer
 
Join Date: Nov 2007
Posts: 74
Doesn't work with coppermine within phpnuke
gameover is offline   Reply With Quote
Old March 7th, 2012, 05:09 PM   #154
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
Most likely because your user stuff is not being pulled. You would probally have to alter the importer to grab the user stuff.

If your integrating Photopost into phpnuke things might work but as I have posted before this 7 year old script was basically written to take a standalone coppermine and import into a standalone photopost.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old March 5th, 2014, 06:39 PM   #155
dlpcorp
Junior Member
Verified Customer
 
Join Date: Apr 2009
Posts: 9
not to raise a thread from the dead... but assuming that this doesnt work anymore? using it to import a basic coppermine (no integration), and it loads things completely weird. no actual files transfer, and even the settings get screwy (categories SHOW in the db... but arent shown in admin panel.... photos show up in random photos on the front page, but arent associated with any category, and dont have files, etc)

my pp album is stand alone as well. fresh install.
dlpcorp is offline   Reply With Quote
Old March 5th, 2014, 08:05 PM   #156
dlpcorp
Junior Member
Verified Customer
 
Join Date: Apr 2009
Posts: 9
also, after reading through this thread, i am not getting errors. everything says it imports fine. but, i get
- no images on disc
- no sub categories import

it imports the users correctly, numbers (like photos, views, etc), comments, titles.... basically, everything but subs and actual files.
dlpcorp is offline   Reply With Quote
Old March 5th, 2014, 08:31 PM   #157
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
If it imports things but actual files I would highly suggest your file paths are not correct because if there are photo entries in the photos table of photopost we imported from coppermine and your paths are correct and those images exist we would import them.

Hard for me to say without seeing what your doing but that would be my guess. Number one issue with stuff is usually user error with input information.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old March 8th, 2014, 03:15 PM   #158
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,523
So I have not heard back here from you have you checked your server paths etc?

Without more direct examples hard for me to comment further. If you want me to look at what your doing you would need to send urls ftp info and admin login through the contact us link in our site header.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
4images Importer Chuck S Photopost Pro Import Scripts 33 July 29th, 2013 10:20 AM
Albinator Importer Chuck S Photopost Pro Import Scripts 23 May 19th, 2006 05:25 AM
4images importer ? H@K@N Before You Buy 10 November 15th, 2005 01:22 PM
Invision Gallery Importer yorkguy Before You Buy 3 October 16th, 2005 05:02 PM


All times are GMT -5. The time now is 03:39 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.