PhotoPost Photo Gallery Sales PhotoPost Sales Toll Free Phone Number
Mon-Fri 9am-4pm EST
  PhotoPost Photo Sharing Photo Gallery    Visualize community tm
| | | | | | | | |

Go Back   PhotoPost Community > PhotoPost Support > PhotoPost Pro Support Forums > Photopost Pro Import Scripts

Photopost Pro Import Scripts Looking to upgrade to PhotoPost? We'll post any importers we develop here.

Reply
 
Thread Tools Rate Thread Display Modes
Old July 22nd, 2009, 08:51 AM   #1
Michael P
PhotoPost Developer
Verified Customer
 
Join Date: Jan 2002
Posts: 11,833
Lightbulb BETA: vBulletin Albums -> PRO Importer

This script will import your vBulletin albums as Member Albums in PhotoPost PRO. The script allows for any imported data to be removed (cleaned) and has been tested on a site with hundreds of albums, thousands of photos and comments; however, this is still a BETA product.

Download this script; unzip and place in your PhotoPost directory. Call with your browser:

http://www.yoursite.com/gallery/ppimportalbums.php

and follow the on-screen prompts. There are only two options - import and clean. If you run an import and want to start over or remove the photos/albums/comments you can select clean and start over.

Please post any issues you may have here with as much detail as possible about your setup.
Attached Files
File Type: zip ppimportalbums.zip (3.3 KB, 130 views)
__________________
Please do not PM me for support or sales questions. Thank you for your understanding.
Michael P is offline   Reply With Quote
Old August 29th, 2009, 11:56 PM   #2
TruthElixirX
Junior Member
Verified Customer
 
Join Date: Feb 2006
Posts: 17
Okay, I need some help here. I ran the import script and this is what happened:

Ran importer, no photos showed up, so I scanned the database to see if I just needed to update things and the like. The member gallery category was showing no photos were uploaded, unless you clicked around in weird ways.


So I scanned the database from the Photopost admin cp to see if that would fix it. It did fix somethings, but then the categories went all crazy. Comments from photos were showing up as categories and such. It was weird.

So I then assumed something had gone wrong with the import script, so I used the "Clear" function, but the comments still showed up as categories.

I have since disabled the gallery so that no one uploads anything to it in case I need to wipe it clean and start over (it was a fresh install that had no photos in it, just categories made up so people could start).

I'd give you login details to here:

Message - My Photo Gallery

So you can see what I am talking about if you need me to. Here is a screenshot about what I mean:

comments.jpg


I am now completely lost as to what I should do. I am running GD2 and the latest version of Photopost.
TruthElixirX is offline   Reply With Quote
Old August 30th, 2009, 10:14 AM   #3
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,329
If you turn off the category cache in global options what happens? Those to me look like category descriptions not comments. Your vbulletin albums will be imported as categories.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old August 30th, 2009, 02:02 PM   #4
TruthElixirX
Junior Member
Verified Customer
 
Join Date: Feb 2006
Posts: 17
Awesome, that fixed the problem well enough for me to open the gallery back up, so you can look at it now.

The other problem is this:

Member Galleries - My Photo Gallery

Member galleries are not showing up until they upload a new photo. If you look at the main Photopost page here:

Main Index - My Photo Gallery

It says there are 803 photos in the Member Galleries, but once clicking it only mine shows up (Chris) because I uploaded a test photo.

If I click on a thumbnail on the side from a random gallery I can navigate to the page using bread crumbs and get there like so:

chuckcarey Gallery - My Photo Gallery

So I know it is there, but the information isn't updating correctly for some reason.
TruthElixirX is offline   Reply With Quote
Old August 30th, 2009, 03:08 PM   #5
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,329
All albums - My Photo Gallery

You can go to admin => scan database and choice to rebuild the members last photo so they show in members galleries
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old August 30th, 2009, 04:38 PM   #6
TruthElixirX
Junior Member
Verified Customer
 
Join Date: Feb 2006
Posts: 17
Quote:
Originally Posted by Chuck S View Post
All albums - My Photo Gallery

You can go to admin => scan database and choice to rebuild the members last photo so they show in members galleries
All sorted out! Thanks!
TruthElixirX is offline   Reply With Quote
Old August 30th, 2009, 05:47 PM   #7
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,329
Not a problem you just needed to redo the cache and run some recounts
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old August 30th, 2009, 05:49 PM   #8
TruthElixirX
Junior Member
Verified Customer
 
Join Date: Feb 2006
Posts: 17
Quote:
Originally Posted by Chuck S View Post
Not a problem you just needed to redo the cache and run some recounts
Can I re-enable the category cache now? Or will it need to stay off permanently?
TruthElixirX is offline   Reply With Quote
Old August 30th, 2009, 06:12 PM   #9
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,329
You can try reenabling it now
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old August 30th, 2009, 06:15 PM   #10
TruthElixirX
Junior Member
Verified Customer
 
Join Date: Feb 2006
Posts: 17
When I re-enable it the comments come back.

This isn't a huge deal as it is a pretty small site and we won't need to cache anything, just letting you know though in case this import script is still under development.
TruthElixirX is offline   Reply With Quote
Old August 30th, 2009, 06:24 PM   #11
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,329
well I would suggest you visit your edit categories hit save to reload things and if you do new uploads the cache should update.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old August 30th, 2009, 07:10 PM   #12
TruthElixirX
Junior Member
Verified Customer
 
Join Date: Feb 2006
Posts: 17
That got it! Thanks!
TruthElixirX is offline   Reply With Quote
Old August 30th, 2009, 09:39 PM   #13
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,329
Not a problem glad to assist
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old November 14th, 2009, 12:27 PM   #14
cory_booth
Member
Verified Customer
 
Join Date: Feb 2009
Posts: 117
Got the following error:
Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in [path]/gallery/ppimportalbums.php on line 148

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in [path]/gallery/ppimportalbums.php on line 270

I am importing from VB4, is this compatible?
cory_booth is offline   Reply With Quote
Old November 14th, 2009, 01:46 PM   #15
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,329
No not with vb4 that I know of.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old November 15th, 2009, 08:38 PM   #16
cory_booth
Member
Verified Customer
 
Join Date: Feb 2009
Posts: 117
Yep you are right, few tables are gone and picture was renamed to picturelegacy
cory_booth is offline   Reply With Quote
Old November 16th, 2009, 09:38 AM   #17
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,329
Yes indeed your going to find not many things are going to work with vb4 without being rewritten which I believe vbulletin stated to the community at large.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old November 29th, 2009, 06:35 AM   #18
Revolver
Junior Member
Verified Customer
 
Join Date: Nov 2009
Posts: 13
Thank you very much for the importer. You will run into problems if your [control pane][user albums][Album Picture Storage Type] is set to "Pictures into the file system without direct access to thumbnails" - I had to debug errors complaining about file write permissions however there was no issue with the write, it's that ($vbulletin->options['album_dataloc'] == 'fs_directthumb') was evaluating to FALSE and it was trying to pull my images from the database when they weren't there. The resulting attempt to write a NULL blob triggers the write fail.

Solution - shift album images to the database, then reimport.

I also had to apply the helpful things above after the import - "turn off the category cache in global options" and then "admin => scan database and choice to rebuild the members last photo".

Once that's done, go to your VB [options][User Profile Options] admin and you can disable the VB profile page albums from there now you have imported into PP.
Revolver is offline   Reply With Quote
Old November 29th, 2009, 06:41 AM   #19
Chuck S
Photopost Developer
Verified Customer
 
Chuck S's Avatar
 
Join Date: Jun 2002
Location: Abingdon,MD
Posts: 75,329
Yes you do want to turn off albums in vb afterwards or members might keep uploading there.
__________________
Photopost Developer and Support Engineer

Please do not PM me for support or sales questions. Thank you for your understanding.
Chuck S is offline   Reply With Quote
Old November 29th, 2009, 07:36 PM   #20
Revolver
Junior Member
Verified Customer
 
Join Date: Nov 2009
Posts: 13
I have several "gallery" threads (created because we didn't have a gallery previously) on different topics with thousands of images in them. Is there any script available which would scour those threads, pull the images out, and post them in a PP gallery as if those users had posted them there, and update the old image attachments to be IMG links to the new gallery images? (A lot to ask! But nonetheless handy!)
Revolver is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
vBulletin 3.6 Beta 1 Zachariah General Discussion 12 June 9th, 2006 02:29 PM
for some reason i cannot get into or see the photopost pro beta forum somerfeld General Discussion 1 April 25th, 2005 07:18 AM


All times are GMT -5. The time now is 11:13 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.