PhotoPost Community

PhotoPost Community (http://www.photopost.com/forum/index.php)
-   General Discussion (http://www.photopost.com/forum/forumdisplay.php?f=68)
-   -   displaying all photos in child categories (http://www.photopost.com/forum/showthread.php?t=150004)

amymook October 28th, 2013 01:22 PM

displaying all photos in child categories
 
I have a parent category that is empty, but its child categories are full. I want to display all photos from the child categories when viewing the parent category. Currently when viewing the parent category it is empty. Can this be done and how? I do not see anything obvious in the admin options sections.

Chuck S October 28th, 2013 01:54 PM

ReefTalk Gallery - ReefTalk Gallery

do you have an example?

The featured blocks show photos from children of a parent category. That will show children photos.

If your expecting the actual photos to like your viewing the category the has the photos that is your issue. Your not going to see every last photo like your viewing the child cat. The parent category displays an category block like my example.

amymook October 28th, 2013 02:26 PM

I am not expecting every last photo to show up, just something from the subcategories, like you have in your example... i think. My gallery is currently closed for viewing, so not sure how to get you in there to see it... but I will look into the featured blocks to see if I can figure that out. if I need more help I will turn the gallery on so you can look at it, but I don't really want to do that, even if there are no direct links to it from my site yet.
thanks

amymook October 28th, 2013 02:29 PM

how do I set 'featured blocks'? not sure where to go to set those, can you point me in the right direction?

Chuck S October 28th, 2013 04:21 PM

I would need to see an example url so I know where your talking about there are various different views

http://www.reeftalk.com/gallery/g508-member-pics.html

Like I said when viewing a category you will see a list of subcategories you are not going to see photos of subcategories like your viewing photos in the parent category. My first example showed a parent category that is set to contain no thumbs and the one above is a normal category served by showgallery script.

You can display features on the showphoto and showgallery page by turning on that option in show photo options in admin.

amymook October 30th, 2013 07:57 PM

I opened the gallery up for public viewing: http://blacksmith.org/gallery/index.php
I do not see how to set a thumbnail for my subcategories, perhaps at initial setup, but I did not upload the photo at the original setup and it is not obvious where to do that.
I am confused about settings. On the index page I have it set to display random, recent and popular images with the list of categories to the left. When I go to the next level category DEMONSTRATOR ARCHIVES, the subcategories under that do not show up in any way. I either need to add an image to the category setup, to represent all in that category. And maybe then that would show up. How do you get the box titled ReefTalk Gallery, that has the subcategory with thumbnails: Reefs, Corals, Diving Pics etc? That would suffice for me. I don't know the terminology for what I am asking. I am calling the images that show up next to the subcategory names "category thumbnails", I wonder what you mean by 'featured block' I don't need every last picture in the subcategories to show up, either a few pictures (how do I select them or tell the photopost to display them) or a thumbnail representing the category... One of my subcategories: Demonstrator Archives>TOOLS does have a thumbnail related to it. Can you help me at all? I have "Display Featured Photos on this page?" in show photo options set to Yes... so how do I select Featured Photos??

amymook October 30th, 2013 08:02 PM

more info maybe: when I go to the edit the categories, thinking I need to select a thumbnail for each category maybe? there is a line in the category edit admin page "Thumbnail for Main Index:" and it says None. It is not a text box that I can change.
I am sorry that I seem so dumb about this, and I appreciate your help.

Chuck S October 30th, 2013 08:11 PM

Here are examples

http://blacksmith.org/gallery/showgallery.php?cat=501

There are no photos that show because there are none to show. The featured photo blocks can show photos for children of parent categories but its not going to continually scan down and do children of children of parents etc.

Tools - Gallery

Now at the url above if you set as I noted in Admin => Show Photo Options the option to display features on the showphoto and showgallery pages you will get a photo block that contains photos from that cat and its children.

If you do not want to use that new style sidebar category display and use the old style forum style cat list you can set that on in index options in admin. Your only going to see category avatars on index if you use the forum style display.

Chuck S October 30th, 2013 08:12 PM

Here are examples

Demonstrator Archives - Gallery

There are no photos that show because there are none to show. The featured photo blocks can show photos for children of parent categories but its not going to continually scan down and do children of children of parents etc.

http://blacksmith.org/gallery/showgallery.php?cat=502

Now at the url above if you set as I noted in Admin => Show Photo Options the option to display features on the showphoto and showgallery pages you will get a photo block that contains photos from that cat and its children.

If you do not want to use that new style sidebar category display and use the old style forum style cat list you can set that on in index options in admin. Your only going to see category avatars on index if you use the forum style display.

amymook October 30th, 2013 08:42 PM

I am getting the subsubcategories don't show up on two levels above, i.e. Demonstrator Archives - Gallery does not show anything because the subcategory under it, Tools, also has nothing under it... but another category under it, Reserve, has a couple of pics in it and they are not showing up when viewing Demonstrator Arhcives - Gallery. I did set the Show Photo Options to say yes to Display Featured Photos on this page? That is the only thing I see about display features. It is under the Show photo options, there is not a similar setting in show gallery options. The

amymook October 30th, 2013 08:48 PM

Also, why does nothing show up looking at Tools? That category has 3 subcategories that all have pictures. Though there are no photos directly in the Tools parent company, by what you say above it seems that something should show up. I looked many times for any setting having to do with featured photos and did not see it. Do I need to make an index thumb for each category? is it the index thumbs of the subcategories that show up when viewing a category that has no pics of its own, only in subcategories?

Chuck S October 30th, 2013 08:59 PM

You must not be following me here the settings i am talking about are clearly there. You can send an admin login for me to check your settings through the contact us link in our site header.

amymook November 1st, 2013 02:05 PM

were you able to look at the gallery with the login I sent you? I see that the width of the body of the gallery is now 100%, it had been 960 px, I had not updated anything so I am wondering if you changed it?? It is easy enough to change back, and I don't really think you changed it, but that has not happened before without my knowingly doing it. If you need the login again I can send it via your contact form... I would really like to be able to see something for the first child level below an empty category. I don't expect all the pictures, but even one would be better than blank.

Chuck S November 1st, 2013 02:58 PM

I sent you an email asking for ftp info and also stating you might want to update your code and see if that helps as your using an older version than what is in my examples. Not sure if that makes a difference with your specific problem but making sure your running the same code I am does help.

amymook November 3rd, 2013 11:28 AM

No info about upgrading came in the download, no documentation folder. I am wanting to upgrade from photopost pro 8.4 to 8.4.2, it is probably not a simple upload of the changed files since 8.4.1. Not sure how to proceed, any advice? And, I never got your email asking for my ftp, what do you need it for? I will send it to you but first want to see if upgrading makes a difference.
thanks for your help so far.

Chuck S November 3rd, 2013 11:44 AM

Upgrade instructions are included in the documentations folder of the downloaded code as well as a note if you want to see more specific changes that are done from version to version read the changelog.txt file. The main upgrade documentation states to upload all files from the download except config files and add any new config variables to your older configs and run the upgrade script and redo xml plugins if applicable for vb.

Basically reading the documentation from 8.4 to 8.42 you want to upload all the files except the 2 config files. You would add the new $cookie_salt variable to the config-inc.php file and set accordingly. You would then run the upgrade script and upgrade 8.4. You would then follow the instructions in the upgrade documentation to redo your vb xml plugins and install that into vbulletin.

amymook November 3rd, 2013 11:50 AM

I will follow your instructions, just re-downloaded version 8.42 again... and there was the documentation folder... not sure what happened the first time. thanks for your patience.

Chuck S November 3rd, 2013 11:55 AM

No idea documentations folder has existed in our product since day 1.

amymook November 4th, 2013 10:29 AM

made the upgrade. a few things were unclear as far as updating the database, since I was going from 8.4 to 8.42 I did not need to use upgrade.php. Now, the categories are all top level categories, but the pics definitely show, i.e. under the Tools category that had no pics of its own, only children, now there are pics that show up there. There were some style changes that I have to decide whether I will fix or not, but mostly it appears that I have a workable system. thanks as ever for your assistance... I hope to have a cool gallery to add to your clients' gallery example pages sometime soon...

Chuck S November 4th, 2013 10:41 AM

Aside from your style changes your site indeed looks to be fine.


All times are GMT -5. The time now is 11:10 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.