PhotoPost Community

PhotoPost Community (http://www.photopost.com/forum/index.php)
-   Show off your PhotoPost site! (http://www.photopost.com/forum/forumdisplay.php?f=110)
-   -   Category pages in Homepage (http://www.photopost.com/forum/showthread.php?t=149459)

jaisiyaram April 18th, 2013 03:46 AM

Category pages in Homepage
 
Hello,

we have just upgraded to the most recent version of photopost and after a small hiccup it is now displaying fine (thanks chuck! :))

There is however one question:
Previously all the categories were displayed on the homepage with their index thumbnails. Unfortunately now we only see the categories in the sidebar and they are not coming in the index page.
On the index there is currently only the 'most recent' boxes.

We are wondering whether this is a setting we missed and if so, where we can find it?

Please note that we don't want to have the 'forum style' display on the index - just the categories with their thumbnails.

We are looking forward to hear from you!
Thank you for your help!

jaisiyaram April 18th, 2013 03:52 AM

aargh, sorry, posted in wrong subforum while browsing.... :(

Chuck S April 18th, 2013 07:53 AM

Did you change your categories view. In Layout Options in Admin make sure you have set to use the forum style view and the index will show as you want. ;)

jaisiyaram April 18th, 2013 08:36 AM

views
 
When we change to forum style view, all category thumbnails come on the left and the title next to it.
Before it was showing the categories all next to each other (five or six rows) when it was not in forum view.
Did you remove that in the new version?
It just seems wrong that the homepage only displays the 'most recent' pictures and nothing of the categories except for the sidebar ... ???

Chuck S April 18th, 2013 09:16 AM

Hello

If your referring to the way old style non forum style view that was not really used correct that was removed a year and a half ago.

The choices you have are the new updated category list view or the forumstyle view which 99.9% of users use.

jaisiyaram April 20th, 2013 02:49 AM

Mmmh, I didn't know that the previous view was not available anymore. I tried finding a site (in this subforum :) ) which uses the new forum style to look but unfortunately couldn't find any.
The problem is that it just seems so empty in the middle, in between the category and the views... do you have any suggestions how we can change that?:
jaisiyaram.com/photopost/index.php

Chuck S April 20th, 2013 07:59 AM

The choice you have is category list on sidebar or the forum style category list.

You can under layout options set more photos to show on the index to fill in just a different view.

imagemaniac February 20th, 2015 12:21 PM

I have the opposite problem. I want to enable the categories on the sidebar but they will not display. I can have the categories on the main index though.

My PP is integrated with VBulletin her at www.militaryimages.net

Any ideas

Chuck S February 20th, 2015 02:16 PM

In index options have you set to use the forum style cat list to NO. You then in sidebar modules turn on the category bar on the sidebar.

imagemaniac February 22nd, 2015 05:20 AM

This worked perfectly thanks chuck

imagemaniac February 22nd, 2015 05:47 AM

While I was sorting it out I decided to re arrange all my categories effectively disposing of sub cats and moving all photos in sub cats to the top level category. I used the Bulk move tool. I have now noticed that member names are missing from member gallery list as per picture below

Code:

Content visible to verified customers only.
I have tried a rescan
Quote:

Check here to resync photo/comments usernames/update comments counts
but it comes with an error after about 14000 photos scanned

Any ideas or have i messed up big time

imagemaniac February 22nd, 2015 07:01 AM

Well I have discovered that not all the members not listed in the member galleries have suffered the loss of their username from their photos, they are just not listed ?

imagemaniac February 22nd, 2015 10:05 AM

Another question sorry to be a pain
sometime ago I scanned mt Db to detect and delete members who have not visited for over 5 years. This worked a treat but left me with a few hundred photos without usernames. Is there a way to instruct the DB via say PHPmyadmin to allocate all photos without username to a valid username?

Chuck S February 22nd, 2015 01:04 PM

The issue is you deleted the users who uploaded the photos from your vbulletin therefore the users do not exist anymore.

That us why those photos are owned by a user that has no information since you deleted them. You could theoretically issue some query in phpmyadmin to assign those photos to say you. It all depends on what your trying to do.

imagemaniac February 22nd, 2015 01:17 PM

Hi Chuck
Yes I eventually realised what was happening and that it was due to me deleting members.
I did have another issue that I believe has rectified itself that being galleries of members whos usernames still existed did not sho in the member galleries list, I rectified some of these by uploading an image as that user and then they showed up.

Anyway back to the images without usernames, as I am a complete novice with SQL queries could you point me in the direction of what the query should be?

Chuck S February 22nd, 2015 04:40 PM

well that depends on what your variables are. I can not see muchon that site but the basic structure would be this

UPDATE pp_photos SET user='SOMEUSERNAME', userid='SOMEUSERID' WHERE user=''

imagemaniac February 26th, 2015 03:46 AM

So just to make sure
I want to change a photo with no username but does have a userid (u107)

so would it look like this
UPDATE pp_photos SET user='MYUSERNAME', userid='MYUSERID' WHERE user='U107'

Thanks for your help chuck

Chuck S February 26th, 2015 09:20 AM

No your query is not sound. First off userid's do not have characters in them they are always numeric only. Then your placing a userid where the username would be.

Basically if your trying to assign all photos where the user field is empty in the pp_photos table the query is as I posted exactly meaning it would look like I posted no changes.

UPDATE pp_photos SET user='MYUSERNAME', userid='MYUSERID' WHERE user=''

imagemaniac February 26th, 2015 09:37 AM

How will it know what username and userid to replace the blank username with?
the userid appears to still be associated to the images in question.

Sorry if I sound dumb but this stuff confuses the hell out of me sometimes and I dont want to run a query that will cause me even more issues

Chuck S February 26th, 2015 11:04 AM

Replace the examples of MYUSERID and MYUSERNAME with your own ;)

Your example you where trying to put a bogus userid in the user field on the where clause. Your query would have done nothing.


All times are GMT -5. The time now is 09:36 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.