PhotoPost Community

PhotoPost Community (http://www.photopost.com/forum/index.php)
-   Photopost Pro Import Scripts (http://www.photopost.com/forum/forumdisplay.php?f=108)
-   -   BETA: vBulletin Albums -> PRO Importer (http://www.photopost.com/forum/showthread.php?t=140509)

Michael P July 22nd, 2009 09:51 AM

BETA: vBulletin Albums -> PRO Importer
 
1 Attachment(s)
This script will import your vBulletin albums as Member Albums in PhotoPost PRO. The script allows for any imported data to be removed (cleaned) and has been tested on a site with hundreds of albums, thousands of photos and comments; however, this is still a BETA product.

Download this script; unzip and place in your PhotoPost directory. Call with your browser:

http://www.yoursite.com/gallery/ppimportalbums.php

and follow the on-screen prompts. There are only two options - import and clean. If you run an import and want to start over or remove the photos/albums/comments you can select clean and start over.

Please post any issues you may have here with as much detail as possible about your setup.

TruthElixirX August 30th, 2009 12:56 AM

1 Attachment(s)
Okay, I need some help here. I ran the import script and this is what happened:

Ran importer, no photos showed up, so I scanned the database to see if I just needed to update things and the like. The member gallery category was showing no photos were uploaded, unless you clicked around in weird ways.


So I scanned the database from the Photopost admin cp to see if that would fix it. It did fix somethings, but then the categories went all crazy. Comments from photos were showing up as categories and such. It was weird.

So I then assumed something had gone wrong with the import script, so I used the "Clear" function, but the comments still showed up as categories.

I have since disabled the gallery so that no one uploads anything to it in case I need to wipe it clean and start over (it was a fresh install that had no photos in it, just categories made up so people could start).

I'd give you login details to here:

Message - My Photo Gallery

So you can see what I am talking about if you need me to. Here is a screenshot about what I mean:

Attachment 3916


I am now completely lost as to what I should do. I am running GD2 and the latest version of Photopost.

Chuck S August 30th, 2009 11:14 AM

If you turn off the category cache in global options what happens? Those to me look like category descriptions not comments. Your vbulletin albums will be imported as categories.

TruthElixirX August 30th, 2009 03:02 PM

Awesome, that fixed the problem well enough for me to open the gallery back up, so you can look at it now.

The other problem is this:

Member Galleries - My Photo Gallery

Member galleries are not showing up until they upload a new photo. If you look at the main Photopost page here:

Main Index - My Photo Gallery

It says there are 803 photos in the Member Galleries, but once clicking it only mine shows up (Chris) because I uploaded a test photo.

If I click on a thumbnail on the side from a random gallery I can navigate to the page using bread crumbs and get there like so:

chuckcarey Gallery - My Photo Gallery

So I know it is there, but the information isn't updating correctly for some reason.

Chuck S August 30th, 2009 04:08 PM

All albums - My Photo Gallery

You can go to admin => scan database and choice to rebuild the members last photo so they show in members galleries

TruthElixirX August 30th, 2009 05:38 PM

Quote:

Originally Posted by Chuck S (Post 1252003)
All albums - My Photo Gallery

You can go to admin => scan database and choice to rebuild the members last photo so they show in members galleries

All sorted out! Thanks!

Chuck S August 30th, 2009 06:47 PM

Not a problem you just needed to redo the cache and run some recounts

TruthElixirX August 30th, 2009 06:49 PM

Quote:

Originally Posted by Chuck S (Post 1252011)
Not a problem you just needed to redo the cache and run some recounts

Can I re-enable the category cache now? Or will it need to stay off permanently?

Chuck S August 30th, 2009 07:12 PM

You can try reenabling it now

TruthElixirX August 30th, 2009 07:15 PM

When I re-enable it the comments come back.

This isn't a huge deal as it is a pretty small site and we won't need to cache anything, just letting you know though in case this import script is still under development.

Chuck S August 30th, 2009 07:24 PM

well I would suggest you visit your edit categories hit save to reload things and if you do new uploads the cache should update.

TruthElixirX August 30th, 2009 08:10 PM

That got it! Thanks!

Chuck S August 30th, 2009 10:39 PM

Not a problem glad to assist

cory_booth November 14th, 2009 01:27 PM

Got the following error:
Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in [path]/gallery/ppimportalbums.php on line 148

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in [path]/gallery/ppimportalbums.php on line 270

I am importing from VB4, is this compatible?

Chuck S November 14th, 2009 02:46 PM

No not with vb4 that I know of.

cory_booth November 15th, 2009 09:38 PM

Yep you are right, few tables are gone and picture was renamed to picturelegacy

Chuck S November 16th, 2009 10:38 AM

Yes indeed your going to find not many things are going to work with vb4 without being rewritten which I believe vbulletin stated to the community at large.

Revolver November 29th, 2009 07:35 AM

Thank you very much for the importer. You will run into problems if your [control pane][user albums][Album Picture Storage Type] is set to "Pictures into the file system without direct access to thumbnails" - I had to debug errors complaining about file write permissions however there was no issue with the write, it's that ($vbulletin->options['album_dataloc'] == 'fs_directthumb') was evaluating to FALSE and it was trying to pull my images from the database when they weren't there. The resulting attempt to write a NULL blob triggers the write fail.

Solution - shift album images to the database, then reimport.

I also had to apply the helpful things above after the import - "turn off the category cache in global options" and then "admin => scan database and choice to rebuild the members last photo".

Once that's done, go to your VB [options][User Profile Options] admin and you can disable the VB profile page albums from there now you have imported into PP.

Chuck S November 29th, 2009 07:41 AM

Yes you do want to turn off albums in vb afterwards or members might keep uploading there.

Revolver November 29th, 2009 08:36 PM

I have several "gallery" threads (created because we didn't have a gallery previously) on different topics with thousands of images in them. Is there any script available which would scour those threads, pull the images out, and post them in a PP gallery as if those users had posted them there, and update the old image attachments to be IMG links to the new gallery images? (A lot to ask! But nonetheless handy!)


All times are GMT -5. The time now is 08:07 PM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.