PhotoPost Community

PhotoPost Community (http://www.photopost.com/forum/index.php)
-   Photopost Pro Import Scripts (http://www.photopost.com/forum/forumdisplay.php?f=108)
-   -   4images Importer (http://www.photopost.com/forum/showthread.php?t=114016)

Chuck S May 23rd, 2005 02:21 PM

4images Importer
 
1 Attachment(s)
Import Instructions for 4images import.

1. Upload the two files to your photopost directory and CHMOD 4images.cnf.php to 777

2. Run the importer through your web browser and fill in all required info and paths for both programs

3. The importer will cycle through in steps each process.

4. After Import cleanup work needed.

a. Under Scan Database recheck and build post number and check for children.

b. Make sure to set any usergroup and categories permissions you see fit.

c. Set your medium size threshold in Upload Options and under Scan Database rebuild your medium imags.

d. Since they do not store username in the photos and comments tables under Scan Database run a resync usernames on photos and comments so usernames will be properly displayed

abdoh2010 March 7th, 2010 01:01 PM

could you update the script please ?
it dosent work this way

Chuck S March 7th, 2010 02:45 PM

from my testing the script works fine thanks.

You can always start a support thread if you have an issue but most all issues come down to configuration issues.

Nacho Lopez July 25th, 2013 10:44 AM

Hello:
I have many problems with this script...
Many things are not working properly
I sent you support email
Can you helo me?
Thank you

Chuck S July 25th, 2013 11:25 AM

You would have to post your issues. Your talking about some 8 year old script. It was written for whatever 4 images gallery existed back in May 2005. If your trying to use it with some newer product I am sure it would not work.

The first thing I would do is verify your inputting the correct information like table prefix paths etc.

Then you can provide explicit urls and examples of your error.

There is a definately limit here on the type of support I can provide on an 8 year old use as you wish importer.

Nacho Lopez July 25th, 2013 11:43 AM

Sorry for my english Chuck...
I wonder
Is there any way to connect the 4images users with the new ones in vbulletin?
This import just move them from 4images to vbulletin and we have photopost integrated into vbulletin not as a simple script...

Chuck S July 25th, 2013 11:47 AM

Well this script is not written to import 4 images users to vbulletin that much I can tell you.

This little script is written to import 4 images to pro meaning standalone gallery to standalone gallery.

The only way your users would align is if your 4 images was integrated with vbulletin but I do not know there features like I said this is an 8 year old script.

It should work for what its intended to do which is import users categories photos and comments into photopost pro.

where is your pro install at?

Nacho Lopez July 25th, 2013 11:56 AM

This is just a demo Chuck
When everything would be working perfectly i will move to main page of the domain
photoshop-designs. com/vb4import/galeria/

Nacho Lopez July 25th, 2013 11:56 AM

Delete empty spaces please

Chuck S July 25th, 2013 12:14 PM

A community photo gallery - My Photo Gallery

Looks like the importer did its job perfectly if you ask me so not sure why your saying you have big issues with it.

You can run this script to try realigning photo and comment userid's

http://www.photopost.com/forum/photo...vbulletin.html

There are a couple configuration issues with your gallery you need to fix.

1. in global options in admin make sure your seo setting is set to NONE as your server is not compatible with spider urls. You can not attempt SEO urls until you create HTACCESS to .htaccess.

2. in storage options in admin hit revert and save twice to load the proper urls and paths as your data url is missing a slash between galeria and data which is why the large image does not show on the photo display.

Nacho Lopez July 25th, 2013 01:38 PM

We think we have done already all what you asked us to do but we it is not working
Users are diferent, seo is nor working for some urls and large image dont not show too :(

Chuck S July 25th, 2013 02:19 PM

I told your SEO might not work on your server as spider urls do not. Your server for SEO urls would need to support MOD REWRITE and the .htaccess file would need to be present.

All your images show the large and thumbnails so not sure what your trying to say.

Your only issue is users do not align and nor should they right. Remember your the one running a script to import the content into a gallery that is aligned with a forum when your talking about some gallery you had that was a standalone.

You can run the realign script I noted but that is only going to help you if the actual user exists in the forum with that exact username in the photos and comments so we can actually update the userid. Otherwise the photos and comments would be orphaned.

I clicked around and it looks like the username displayed on the photos matches the forum so not sure what your issue is.

La Rosa - My Photo Gallery

Thats userid 1 on the gallery and forum looks aligned to me

Nacho Lopez July 26th, 2013 12:36 PM

Chuck:
I'm having some problems with friendly url. I'm confident that my server supports mod_rewrite since I have it working with vbulletin but it doesn't work very well with photopost.
I suspect it's something related to special characters used in spanish language like for example á, é, í, ó, ú, ñ...
For example:
if you have a photo named otoño, then the url is changed for this: oto-f1o.html instead this one: otono.html that is like vbseo Works in vbulletin
or if the name of a category is panorámicas, the url is panor-e1micas.html instead panoramicas.html
I mean:
á should be changed for a
é for e
í for i
ó for o
ú for u
and ñ for n
How can we do it?

Chuck S July 26th, 2013 12:54 PM

Nacho you have SEO urls on and they work fine

Pequeña flor - My Photo Gallery

Nacho Lopez July 26th, 2013 12:59 PM

They work fine but the url is not SEO because url is:

http ://w ww. photoshop-designs. com/vb4import/galeria/flores/p857-peque-f1a-flor.html

And it should be this one:

http ://w ww. photoshop-designs. com/vb4import/galeria/flores/p857-pequena-flor.html

ñ is rewrite to f1 instead n

Chuck S July 26th, 2013 03:16 PM

Just because ñ is not written to n does not make it NOT SEO.

Chuck S July 26th, 2013 03:19 PM

We rewrite umlates and stuff like that but I would not know special characters for every language here.

Do you have a list of special characters for your language?

It would be easy to add them into the replacement array in pp-inc.php

Code:

Content visible to verified customers only.

Nacho Lopez July 26th, 2013 05:20 PM

This Works!
Thanks a lot Chuck!

Chuck S July 26th, 2013 08:01 PM

Like I said if you want me to include certain characters in our rewrite you would need to list them. I do not speak every language out there. ;)

Nacho Lopez July 27th, 2013 01:22 PM

You have it here, Chuck!

$str1 = array('Ä', 'ä', 'Ü', 'ü', 'Ö', 'ö', 'ß', '(', ')', '[', ']', '"', 'ñ', 'á', 'é', 'í', 'ó', 'ú', 'Ñ', 'Á', 'É', 'Í', 'Ó', 'Ú', '.', ':', '¿', '?', '¡', '!', '^', '<', '>');
$str2 = array('Ae', 'ae', 'Ue', 'ue', 'Oe', 'oe', 'ss', '', '', '', '', '', 'n', 'a', 'e', 'i', 'o', 'u', 'n', 'a', 'e', 'i', 'o', 'u', '', '', '', '', '', '', '', '', '');


All times are GMT -5. The time now is 11:25 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.