PhotoPost Community

PhotoPost Community (http://www.photopost.com/forum/index.php)
-   Photopost Pro Import Scripts (http://www.photopost.com/forum/forumdisplay.php?f=108)
-   -   Coppermine Importer (http://www.photopost.com/forum/showthread.php?t=113941)

Chuck S May 17th, 2005 06:19 PM

Coppermine Importer
 
1 Attachment(s)
Import Instructions for coppermine import. This importer was written for version 1.33 so if your importing you might need to upgrade your coppermine to the newest release before import.


1. Upload the two files to your photopost directory and CHMOD coppermine.cnf.php to 777

2. Run the importer through your web browser and fill in all required info and paths for both programs

3. The importer will cycle through in steps each process.

4. After Import cleanup work needed.

a. Under Scan Database recheck and build post number and check for children.

b. Make sure to set any usergroup and categories permissions you see fit.

c. Set your medium size threshold in Upload Options and under Scan Database rebuild your medium images.

imvitaliy December 27th, 2007 03:19 PM

My Member Photos category only contains 600 photos so there is something wrong with the import. I have reinstalled the latest version, made a clean install of photopost and ran the coppemine.php import script.
I was looking for the information that was printed on the screen when I was importing the last time. It said that it imported 26 users. But I have more then 600 users. Also it imported the correct number of comments. But when it was importing files it said that its "Importing 5162 files", but I have 19308 photos in my coppermine gallery.

Could you fix this for me? I have done this 3 times and tried changing the java thresholds but still the same problem.

I want to give you all the info that you need to import the cpg users to photopost for me because I can't do it. It's not working right.

Please PM me or email me at contact .at. y4j.org
Thanks a lot

imvitaliy January 1st, 2008 11:09 PM

I have not heard from anybody yet... Please help me with this

Chuck S January 2nd, 2008 09:47 AM

You are free to post a url here for us to see your coppermine site and then a url for photopost if you wish. You would need post the url here for us to look and respond and tell you what to do.

imvitaliy January 3rd, 2008 06:46 PM

My website is at: y4j.org
My photoPost is at y4j.org/photos/
My coppermine gallery is at: y4j.org/y4jers/pics/
My vbulletin is at: y4j.org/y4jers/forum/

My coppermine is integrated with vbulletin.

I re-installed the photoPost and ran the coppermine.php again today. I took notes on each step of the import process.

Imported:
Users 27
Usergroups 13
Categories 28
Albums 600
Photos 19309
Comments 7111
Files 10434

I don't know why there are 19309 photos on Coppemine and 19309 photos get imported to photopost but in the final step when it starts importing files it only says that it's importing 10434 files. Where do the ~9000 file get lost?

Please help me ASAP

Chuck S January 3rd, 2008 07:36 PM

I would suspect a java issue. You can email support@photopost dot com with the ftp information to your site.

tsakalos76 January 12th, 2008 12:01 PM

i got errors importing from coppermine and i dont see any images or thums nor comments and cats + why did it imported users anyway is there a support ticket so u can see whats going on?

tsakalos76 January 12th, 2008 12:39 PM

ok i managed to make the import i see the images but they arent placed into personal user albums

Chuck S January 12th, 2008 01:40 PM

what do you mean by this? An image is going to be placed into the category in coppermine that they uploaded it to. Meaning if a photo is in category 20 in coppermine it will be in cat 20 in photopost.

tsakalos76 January 12th, 2008 01:47 PM

no images are imported but they are not in any category !! can u add me in msn so i can give u ftp details etc to look ? konstantin0s@hotmail.com

Chuck S January 12th, 2008 01:50 PM

You can email support@photopost.com with any urls logins etc.

Ivo2 May 9th, 2008 10:22 AM

Hi Chuck
before I purchase a third license, I must know if the importer for coppermine 1.4.18 works. It's my granddaughters gallery and if it not worked, I think that I got troubles with my wife and my daughter :D
Thanks

Chuck S May 9th, 2008 10:26 AM

It should work that I know of no one has stated anything different.

Ivo2 May 9th, 2008 10:46 AM

1 Attachment(s)
Ok,
I'm going to purchase. It would be standalone and are their styles somewhere for photopost?

Chuck S May 9th, 2008 10:59 AM

There are several styles included in Photopost downloaded code.

Ivo2 May 9th, 2008 11:04 AM

Thanks Chuck,
I hope for me, that everything goes well.

Chuck S May 9th, 2008 11:48 AM

enjoy and have a good weekend.

Ivo2 May 9th, 2008 12:44 PM

Sorry,
I don't get any images. Categories not correct and troubles with codes
http://lara.sulic.at/pp
:(

Chuck S May 9th, 2008 12:58 PM

You must do the category work noted in the instructions above and if you get no images my suggestion is to make sure in the importer config you have set the proper server paths for both coppermine and photopost like so make sure to use your own paths

/var/www/html/coppermine/albums

/var/www/html/pp/data

Ivo2 May 9th, 2008 01:27 PM

Thanks,
my mistake was that the path to pp/data only make as /pp
But with the categories I come not clear.
In coppermine I have 2 categories ("Meine ersten Fotos" with 10 Albums and "Meine Videos" with 1 Album)
Should I create at first the 2 categories and albums in pp ?


All times are GMT -5. The time now is 03:57 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.