PDA

View Full Version : Xenforo adm-index.php issue


baloo
April 14th, 2013, 10:36 AM
Hi,
I get this error on install:


I did as told for the Xenforo install.

a) Ran the /install/install.php
b) Copied the stuff from /install/library* to Xenforo/library
c) Added the PhotoPost integration.

Problem:
1) I am running IIS7. I am not running Apache. So your ^ppurl does not work.

2) When I go to adm-index.php, I get error. I cannot login and I have no idea what to do next. :confused:

baloo
April 14th, 2013, 10:43 AM
Do you have an equivalent for ^ppurl for IIS7 ?

Chuck S
April 14th, 2013, 10:57 AM
Please re-read the instructions as this will assit you.

Your error tells me you have not set permissions on the XML files and generated an xml to install to xenforo.

You seem to have installed a clean xml from the download instead of the xml that is generated by our program. Our adm-plugin.php script the one that generates the xml replaces variables like ^ppurl etc with the proper settings etc.

The only way that would not happen is your xml files where not set to 777 per the instructions or you uploaded a clean xml that was never generated.

Most common mistake is users do not set the xml files to 777 permissions.

Chuck S
April 14th, 2013, 12:44 PM
where did you sent the email? I am not seeing anything yet? Try emailing sales at photopost dot com if you did not sent it there.

baloo
April 15th, 2013, 12:17 AM
I didn't email.

1. The thing is on a high security Windows 2012 server. The thing is different. Permissions are set to nobody by default.

2. The XML is fixed. Thank you.

So the above mentioned problems are solved.


I have a new problem.

When I go to adm-index.php it always asks me to login. Sorry if I did wrong.

The sever-setup is Windows 20012 WebServer Core (no GUI), High-security, hardened IIS8.

baloo
April 15th, 2013, 01:36 AM
Please hold. This is not a PhotoPost problem. This is something else.

We are hosting on reverse proxy via Cloudflare. The IP address is not visible to PhotoPost.

Problem:
Using cloudflare, PhotoPost cannot get the $Session['ip'] and cannot login.

Chuck S
April 15th, 2013, 10:32 AM
Yeah I actually thought I was replying to another thread when I was asking about email sorry. ;)

$Session['ip'] is not a variable in our application so not sure what that means there.