PDA

View Full Version : upgrade


2mygallery
December 4th, 2012, 01:37 PM
Just did an upgrade to 8.23 and now getting: arning: mysql_fetch_row(): supplied argument is not a valid MySQL result resource in /home/debbiesreborns/public_html/photopost/pp-inc.php on line 4618

any ideas

Thanks
Doug

Chuck S
December 4th, 2012, 01:47 PM
My suggestion would be to run any missing upgrades you did not do. Clearly by your error you did not just upgrade from 8.22 so you would need to run any required upgrades from the last version you ran to the latest.

Likewise if you where not running 8.22 then you most likely want to follow the normal upgrade procedure and upload all files except the 2 config files. You can find the documentation in the documentations folder of the downloaded code.

Our announcements cover upgrading from the last version forward.

2mygallery
December 4th, 2012, 01:53 PM
What if I just uploaded all of 8.23 except the config files would that do it?

Thanks
Doug

Chuck S
December 4th, 2012, 02:01 PM
No that would not do it. You would actually need to follow the upgrade instructions that are in the documentations folder.

You clearly are not running 8.22 but some earlier PhotoPost. Like if you where running 8.0 then you would have to also run the accompanying upgrades the 8.0-8.1 and the 8.1-8.2 ones.

Based on your one specific error you at minimum need to run both of the upgrades I meantioned because you where at the latest running 8.0 at the most on your site.

2mygallery
December 4th, 2012, 02:20 PM
Thank You

Chuck S
December 4th, 2012, 02:25 PM
Not a problem glad to help

Chuck S
December 6th, 2012, 10:43 AM
I do have one question after the fact here as I deal with this issue alot.

I spent alot of time updating information on this site. All the documentation has been updated in the software for quite a while now. Our announcements give explicit instructions file changes version to version and whether there is an upgrade to run etc.

It seems I deal with people having issues upgrading alot where they forget to run upgrades or do not upload all the files. I am trying to understand what the problem is so I can make things easier and not have this issue. What is it that you specifically were confused about?

Looking forward to any suggestions you have.