PDA

View Full Version : Session save path, uploads not showing


Saftek
October 16th, 2012, 01:12 PM
We have latest code...

We have been getting an incorrect session.save_path error on our updated installation. BUT, the uploads were working.

So we created a line in the php5.ini setting the session.save_path to /tmp... (linux box). Now uploads say they were uploaded successfully, but they don't show up.

Any ideas?

Chuck S
October 16th, 2012, 01:54 PM
If you back out your changes then uploads work fine.

I would suspect your issue has to do with the changes you made to your php not the code.

Let's get back to where things were and send us info so we can see your issue. I run php 5 so I need to see your site.

Likewise any change you make in php to point to some directory on your server you would have to make sure any directory you state EXISTS and is 777 PERMISSIONS.

Saftek
October 16th, 2012, 03:38 PM
I added --upload_tmp_dir = "/tmp"-- to my php5.ini file and its accepting uploads now.

Thanks for your help.

This product has really matured over the years. Thanks for your efforts!

Chuck S
October 16th, 2012, 03:50 PM
Your welcome let us know if you need anything else.

Chuck S
October 17th, 2012, 07:51 AM
PHP: Description of core php.ini directives - Manual (http://www.php.net/manual/en/ini.core.php)

I will link this here for those that happen across this thread so they understand proper php and server setup and the relation between the two.

To allow uploads without any type of error the tmp directory must exist on the server and be writable.