PDA

View Full Version : PP 7.0.2 bug maybe


b6gm6n
April 7th, 2012, 06:22 PM
I'm using PP to play videos and all is well... i uploaded a lot of FLV files and some MP4 files and the gallery handles them well... but in my settings i choose

Acceptable multimedia file types? - .flv,.mp4

Which was fine...
But i then didn't want my members to upload FLV videos just MP4 so i removed .flv, from that setting and it crashes the gallery... i.e none of videos would show because templates were not being loaded because of some error... i think, anyways just thought I'd mention it.

Chuck S
April 7th, 2012, 07:41 PM
can not say that setting just says what multimedia files can be uploaded. You did say you alter the code so I would suggest you upload clean files and try to replicate any issue. Our current code is 8.03

b6gm6n
April 8th, 2012, 04:21 PM
yes i did alter the code but only to accept mp4 files and load the embed_ms template which i changed to handle MP4 playing with flowplayer etc... clean files would be better to check, but as i say it was all working well... no problems, just removing that ".flv" from acceptable file-types in my admin seemed to crash my PP.

Chuck S
April 8th, 2012, 04:57 PM
Well like I said can not say as this is not something we see as an issue in the default code. I can add or remove multimedia types as needed. That has no affect on the display of any multimedia filetype. I beleive in the default application the flv file is shown as a download link since there is no associated player for that. Other than that if you remove flv from the acceptable multimedia types then all you get on upload is a message that it is not an accepted type.

b6gm6n
April 9th, 2012, 02:21 AM
right got ya...

talking of accepted file-types... because I'm using older PP code for my photopost-features... i had trouble getting thumbnails on videos... your newer features code does the job of finding the right thumb etc etc but the older one i can see you just checked for an image... if not chuck out a default video-thumbnail and that was it... but i wanted just a small feature set of videos on my front page which are all stored in a certain category but getting the thumbnails was a bitch :)

did a quick hack job on it and i'll finish it off later

$videothumb = substr_replace($photo , 'jpg', strrpos($photo , '.') +1);
which nicely got the photo i wanted in a string then replaced the extension which is the same name anyways so... cool

oh you might be able to help on this... do you know the file/javascript i have to include to run vB drop-down menus on a non-vB page? :) cheers

Chuck S
April 9th, 2012, 09:56 AM
Your using very old code at some point you want to upgrade badly.

Our present code can create thumbnails out of a video if you have a properly functioning mmjpeg install and our photo blocks show photos or video's either in the gallery or the forum without issue. The plugins for vb4 and the general overall look and feel I think is awesome in vb4.

Maybe global.php in vb.