PDA

View Full Version : Fasthosts/PhotoPost installation trouble


pigpog
September 5th, 2011, 09:58 AM
Hello,

My apologies for putting this in here - I did try to use the installation board but it wouldn't let me post. I read Chuck's sticky thread on becoming a verified customer, which I am because I own a license, but I couldn't work out how to apply this to the forum and open up posting access.

Anyway, I've been struggling to install PhotoPost for three days now and I'm rapidly losing my patience. I wrote to Chuck and he replied to say that my problem is caused by an incorrect path to the PhotoPost installation. My host (Fasthosts) was next to useless when I asked them about this and I'm getting quite cross with the whole thing.

When I run install.php and get to step 1 where it asks for the "Path to PhotoPost Installation (must be set properly for script to work)" the path I have is this: /home/fhlinux204/r/rodentswithattitude.co.uk/user/htdocs/gallery This is the default path that appears in the box.

I then fill in my database info and choose GD2 because the host doesn't support ImageMagick.

Step 2 goes okay, then at step 3 I get this error message:

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/fhlinux204/r/rodentswithattitude.co.uk/user/htdocs/gallery/install.php on line 584
I cannot connect to the PhotoPost MySQL server. [host:$host][mysql_user:$mysql_user][mysql_password:$mysql_password]. Check your config-inc.php for the correct settings and rerun.

I tried to explain to my host that I needed to verify that the /home/fhlinux204/r/ part of the path is correct, because this bit is server side and I cannot view it, but they don't seem to understand what I'm asking for.

Am I asking them the correct question?

I'm getting seriously ticked off with it now! :mad:

Many thanks for any help anyone can give me.

Chuck S
September 5th, 2011, 10:30 AM
That error just suggests that your mysql information your entering is incorrect. You also might want to read the announcement at the top of every forum on verification so you can verify yourself for support access

pigpog
September 5th, 2011, 10:49 AM
Thanks Chuck.

I'm a bit of a database newbie, so please excuse my silly questions.

The host has verified that /home/fhlinux204/r/rodentswithattitude.co.uk/user/htdocs/ is correct.

This being the case, which parts of the mysql information am I entering incorrectly?

Chuck S
September 5th, 2011, 10:58 AM
what your posting here is a server path not mysql information so that has nothing to do with your error. You must enter the correct mysql database host user password and name where asked on the install. I would not be able to tell you what is wrong with your info only your host can do that.

I seriously suggest you comply with this tutorial so that you can post in support

PhotoPost Community - Announcements in Forum : General Discussion (http://www.photopost.com/forum/general-discussion/announcements.html)

Our install does require you have some knowledge on installation procedures and hosting basics like defining databases etc. I consider our install of a medium difficulty range. We do offer professional installation service should you need to purchase that.