PDA

View Full Version : image uploaded not displayed


sabrina
June 25th, 2011, 03:38 PM
hi, not sure how to fix, i upload an image and it says successfull and i go to see if the image was uploaded and it wasnt

how to fix this? probably a permissions problem? which folder(s) should be 777?

thanks

sabrina
June 25th, 2011, 07:42 PM
photopost
images (chmod 755)
uploads (chmod 777)
help (chmod 755)
data (chmod 777)
1 (chmod 777 - including subdirectories)
2 (chmod 777 - including subdirectories)
500 (chmod 777 - including subdirectories)
languages (chmod 755) (a
stylesheets (chmod 777)
templates (chmod 777)
forums (chmod 755)

i did all the above and still its not working

Chuck S
June 25th, 2011, 08:23 PM
what size is the image your uploading? by default php on your server is probally 2mb which means you can not upload an image larger than 2mb or your server will drop it meaning there is nothing to process.

sabrina
June 25th, 2011, 10:53 PM
hi now it goes to another page after uploading, and the image looks like broken icon

and also this error at the top:

Warning: copy(/home/puregraf/public_html/graffiti-gallery/data/500/thumbs/4718.jpg) [function.copy]: failed to open stream: Permission denied in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 141

Warning: imagejpeg() [function.imagejpeg]: Unable to open '/home/puregraf/public_html/graffiti-gallery/data/500/thumbs/4718.jpg' for writing: Permission denied in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 159

Warning: imagejpeg() [function.imagejpeg]: Unable to open '/home/puregraf/public_html/graffiti-gallery/data/500/thumbs/DSC05905.JPG' for writing: Permission denied in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 159

Warning: imagepng() [function.imagepng]: Unable to open '/home/puregraf/public_html/graffiti-gallery/data/500/thumbs/sss.png' for writing: Permission denied in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 160

sabrina
June 25th, 2011, 11:35 PM
the reason i think its permissions because my support recently messed up all my permissions for my folders and domain , and the other thing i have done recently is upgrade to the latest vbulletin

other then that i havent done anything

i tried uploading small image said image too small, and i tried medium and large size, same problem


thanks

Chuck S
June 25th, 2011, 11:42 PM
Yeah your data and upload directories and every single directory beneath them needs to be 777 permissions so you must recheck this.

You just also make sure safe mode is off in php.

Your path looks fine so it has to be permissions or safe mode.

sabrina
June 26th, 2011, 07:06 PM
hi, the images are now showing after uploading on the next page that loads, but i still am getting errors, what else could be causing this? i had my support do the safe mode off is applied

also if you see this page: 'con queso'_by:doc_puerto rico - Graffiti Pictures & Graffiti Art (http://www.puregraffiti.com/graffiti-gallery/graff-art-murals/p223057--con-quesoby-doc-pue.html)
where you are supposed to type a comment, that area where you type its not letting you type anything?


Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/usr/bin/jpegtran) is not within the allowed path(s): (/home/puregraf:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 753

Warning: getimagesize(puregraf/public_html/graffiti-gallery/images/watermark.png) [function.getimagesize]: failed to open stream: No such file or directory in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 177

Warning: imagecreatefrompng(puregraf/public_html/graffiti-gallery/images/watermark.png) [function.imagecreatefrompng]: failed to open stream: No such file or directory in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 238

Warning: imagesx(): supplied argument is not a valid Image resource in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 239

Warning: imagesy(): supplied argument is not a valid Image resource in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 240

Warning: imagecopy(): supplied argument is not a valid Image resource in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 242

Warning: imagedestroy(): supplied argument is not a valid Image resource in /home/puregraf/public_html/graffiti-gallery/image-inc.php on line 246


thanks

Chuck S
June 26th, 2011, 07:52 PM
I will comment on the errors in your last post

1. In global options remove the path for jpegtran you can not use that with openbase directory set on the server so you need to clear that entry and make sure to use GD2 as your image processor.

2. In watermark options in admin the server path to your watermark is not correct that is why you get a watermark error

3. Your comment think has been discussed here we do not support the ckeditor yet in vb thats new. You can edit your showphoto template and down the bottom remove $qcom to remove the quick reply box. Your users can use the normal post comment link as the full editor still works.

sabrina
June 26th, 2011, 09:05 PM
hi thanks. i did everything you said and fixed the problems except for the watermark path is correct but its saying its not, i logged in putty to my server using root account to see path and it is under /home/puregraf/public_html/graffiti-gallery/images/
and the image exists

so im not sure why its saying it is the wrong path, any ideas?

i disabled this for now to fix the error

for the comment box, thanks for letting me know i didnt know this, and i have removed the $qcom from showphoto template, but i do not see any link on the photo page to click to post a comment?

thanks

Chuck S
June 26th, 2011, 10:26 PM
Because your watermark path is definately wrong. Look at your error ;)

You have this

puregraf/public_html/graffiti-gallery/images/watermark.png

The correct path would be this because your error also shows you your correct server path.

/home/puregraf/public_html/graffiti-gallery/images/watermark.png

The post a comment link is under photo options.

sabrina
June 27th, 2011, 12:23 AM
that is such a hard place for people to see dont you think they wont even try to find it to post a comment? how come we cant have the quick reply working :(

Chuck S
June 27th, 2011, 01:14 AM
Because you can not have a working quick reply till we have had a chance to look at the new editor and support it.

zarsteve431
July 7th, 2011, 11:29 AM
what compression method recommended when file size is 2mb more without sacrificing quality?

Chuck S
July 7th, 2011, 03:31 PM
You results will vary and settings depend on the program your using it is not like I can say since I do not use computer graphics programs. Each program has its own routines. I have always been able to set my server to the specifications I want to allow so uploading larger photos is allowed.