PDA

View Full Version : BETA: vBulletin Albums -> PRO Importer


Michael P
July 22nd, 2009, 08:51 AM
This script will import your vBulletin albums as Member Albums in PhotoPost PRO. The script allows for any imported data to be removed (cleaned) and has been tested on a site with hundreds of albums, thousands of photos and comments; however, this is still a BETA product.

Download this script; unzip and place in your PhotoPost directory. Call with your browser:

http://www.yoursite.com/gallery/ppimportalbums.php

and follow the on-screen prompts. There are only two options - import and clean. If you run an import and want to start over or remove the photos/albums/comments you can select clean and start over.

Please post any issues you may have here with as much detail as possible about your setup.

TruthElixirX
August 29th, 2009, 11:56 PM
Okay, I need some help here. I ran the import script and this is what happened:

Ran importer, no photos showed up, so I scanned the database to see if I just needed to update things and the like. The member gallery category was showing no photos were uploaded, unless you clicked around in weird ways.


So I scanned the database from the Photopost admin cp to see if that would fix it. It did fix somethings, but then the categories went all crazy. Comments from photos were showing up as categories and such. It was weird.

So I then assumed something had gone wrong with the import script, so I used the "Clear" function, but the comments still showed up as categories.

I have since disabled the gallery so that no one uploads anything to it in case I need to wipe it clean and start over (it was a fresh install that had no photos in it, just categories made up so people could start).

I'd give you login details to here:

Message - My Photo Gallery (http://www.classicboatclub.com/forums/photopost/)

So you can see what I am talking about if you need me to. Here is a screenshot about what I mean:

3916


I am now completely lost as to what I should do. I am running GD2 and the latest version of Photopost.

Chuck S
August 30th, 2009, 10:14 AM
If you turn off the category cache in global options what happens? Those to me look like category descriptions not comments. Your vbulletin albums will be imported as categories.

TruthElixirX
August 30th, 2009, 02:02 PM
Awesome, that fixed the problem well enough for me to open the gallery back up, so you can look at it now.

The other problem is this:

Member Galleries - My Photo Gallery (http://www.classicboatclub.com/forums/photopost/showmembers.php)

Member galleries are not showing up until they upload a new photo. If you look at the main Photopost page here:

Main Index - My Photo Gallery (http://www.classicboatclub.com/forums/photopost/)

It says there are 803 photos in the Member Galleries, but once clicking it only mine shows up (Chris) because I uploaded a test photo.

If I click on a thumbnail on the side from a random gallery I can navigate to the page using bread crumbs and get there like so:

chuckcarey Gallery - My Photo Gallery (http://www.classicboatclub.com/forums/photopost/showgallery.php?ppuser=6&cat=500)

So I know it is there, but the information isn't updating correctly for some reason.

Chuck S
August 30th, 2009, 03:08 PM
All albums - My Photo Gallery (http://www.classicboatclub.com/forums/photopost/misc.php?action=showalbums)

You can go to admin => scan database and choice to rebuild the members last photo so they show in members galleries

TruthElixirX
August 30th, 2009, 04:38 PM
All albums - My Photo Gallery (http://www.classicboatclub.com/forums/photopost/misc.php?action=showalbums)

You can go to admin => scan database and choice to rebuild the members last photo so they show in members galleries

All sorted out! Thanks!

Chuck S
August 30th, 2009, 05:47 PM
Not a problem you just needed to redo the cache and run some recounts

TruthElixirX
August 30th, 2009, 05:49 PM
Not a problem you just needed to redo the cache and run some recounts

Can I re-enable the category cache now? Or will it need to stay off permanently?

Chuck S
August 30th, 2009, 06:12 PM
You can try reenabling it now

TruthElixirX
August 30th, 2009, 06:15 PM
When I re-enable it the comments come back.

This isn't a huge deal as it is a pretty small site and we won't need to cache anything, just letting you know though in case this import script is still under development.

Chuck S
August 30th, 2009, 06:24 PM
well I would suggest you visit your edit categories hit save to reload things and if you do new uploads the cache should update.

TruthElixirX
August 30th, 2009, 07:10 PM
That got it! Thanks!

Chuck S
August 30th, 2009, 09:39 PM
Not a problem glad to assist

cory_booth
November 14th, 2009, 12:27 PM
Got the following error:
Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in [path]/gallery/ppimportalbums.php on line 148

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in [path]/gallery/ppimportalbums.php on line 270

I am importing from VB4, is this compatible?

Chuck S
November 14th, 2009, 01:46 PM
No not with vb4 that I know of.

cory_booth
November 15th, 2009, 08:38 PM
Yep you are right, few tables are gone and picture was renamed to picturelegacy

Chuck S
November 16th, 2009, 09:38 AM
Yes indeed your going to find not many things are going to work with vb4 without being rewritten which I believe vbulletin stated to the community at large.

Revolver
November 29th, 2009, 06:35 AM
Thank you very much for the importer. You will run into problems if your [control pane][user albums][Album Picture Storage Type] is set to "Pictures into the file system without direct access to thumbnails" - I had to debug errors complaining about file write permissions however there was no issue with the write, it's that ($vbulletin->options['album_dataloc'] == 'fs_directthumb') was evaluating to FALSE and it was trying to pull my images from the database when they weren't there. The resulting attempt to write a NULL blob triggers the write fail.

Solution - shift album images to the database, then reimport.

I also had to apply the helpful things above after the import - "turn off the category cache in global options" and then "admin => scan database and choice to rebuild the members last photo".

Once that's done, go to your VB [options][User Profile Options] admin and you can disable the VB profile page albums from there now you have imported into PP.

Chuck S
November 29th, 2009, 06:41 AM
Yes you do want to turn off albums in vb afterwards or members might keep uploading there.

Revolver
November 29th, 2009, 07:36 PM
I have several "gallery" threads (created because we didn't have a gallery previously) on different topics with thousands of images in them. Is there any script available which would scour those threads, pull the images out, and post them in a PP gallery as if those users had posted them there, and update the old image attachments to be IMG links to the new gallery images? (A lot to ask! But nonetheless handy!)

Chuck S
November 29th, 2009, 08:31 PM
No sorry there is none to my knowledge

Ricsca
March 8th, 2010, 03:53 PM
I have A community photo gallery - TartaPortal - Galleria Fotografica Tartarughe (http://www.tartaportal.it/gallery) but dont work...

Chuck S
March 8th, 2010, 05:23 PM
This beta importer is for vbulletin 3 as it notes above.

It is not written for vbulletin 4 which is an entirely different forum.

Ricsca
March 8th, 2010, 07:16 PM
exists for the 4?

Chuck S
March 8th, 2010, 07:41 PM
No there is no such script like this for vbulletin 4. Maybe in the future but right now we are working hard to make sure all our products themselves are compatible with vbulletin 4.

Ricsca
March 9th, 2010, 08:47 AM
Ok thanks.

Chuck S
March 9th, 2010, 10:10 AM
no problem glad to answer

hzzhzz
March 31st, 2010, 11:37 AM
hi there ,

i have problem :

We're sorry, but the system experienced an unrecoverable error. Please try again later.

Chuck S
March 31st, 2010, 11:40 AM
can you elaborate here? I really can't comment without more of an explanation here of your issue.

hzzhzz
April 20th, 2010, 09:12 PM
Hi there ,

when i run script i have :

Invalid SQL:
SELECT id FROM pp_photos WHERE importimageid='1';
MySQL Error : Table 'amorat_vb380.pp_photos' doesn't exist

the ( amorat_vb380 ) is the vb database name !!

and i install the photopost to another database name

so should be get like that (photopost.pp_photos)

i uncomment in : inc_features.php

// If you use the same userid/password to access both databases, you don't need to
// uncomment the mysql_connect - this is only if you require different ids to access
// the PhotoPost database.
//
//$link = mysql_connect ("localhost", "$dbuserid", "$dbuserpassword") or die('I cannot connect to the database.');
//mysql_select_db ("pp_database")or die("Could not select photopost database");

like :

$link = mysql_connect ("localhost", "$dbuserid", "$dbuserpassword") or die('I cannot connect to the database.');
mysql_select_db ("pp_database")or die("Could not select photopost database");

NOW , just copy the member name and count of images album of forum :

http://www.amorat.net/album/showmembers.php/cat/500

without images ??

Another thinks , when update ( members galleries ) i have this message :


We're sorry, but the system experienced an unrecoverable error. Please try again later.
Script:
Query: SELECT id FROM pp_categories WHERE cat=500

i think should be :

SELECT id FROM pp_categories WHERE id=500

Chuck S
April 20th, 2010, 09:39 PM
when you run the importer have you entered the proper database info?

hzzhzz
April 20th, 2010, 10:03 PM
where i entered ??

i two have option import or clear ??

Chuck S
April 20th, 2010, 10:36 PM
as long as your photopost is functional and you place this script in the photopost directory it should work. it gets its info from photopost

hzzhzz
April 20th, 2010, 10:38 PM
In data folder it's there are comes alot of folders with images ,

just in one name folder like :

1
2
3

not like :

1
--1
---2

is it ok like that , also the images not show also after update database

hzzhzz
April 20th, 2010, 10:40 PM
also folder ( 500 ) is empty ?

hzzhzz
April 20th, 2010, 10:52 PM
from database when i check in (pp_photos) all the member galleries (cat)=0 ??

Chuck S
April 21st, 2010, 08:26 AM
Might help to place a link to your actual gallery

The images are stored per category.

hzzhzz
April 21st, 2010, 11:35 AM
I delete all files of members galleries

Message - البوم شبكة امورات (http://www.amorat.net/album)

Also, i try many times in my local computer ( server ) do it , but i have the same things .

So, Could I send my site information to your Email : support@photopost.com

?????

Chuck S
April 21st, 2010, 11:38 AM
As admin what is the exact message you see?

I dont read arabic so I am just pecking around as I can.

It would appear to be you have not installed the application correctly so until that happens you can not use the importer

Please reinstall the application make sure everything is working then we can do an import.

hzzhzz
April 21st, 2010, 11:58 AM
I don't see any message error or wrong

Please reinstall the application make sure everything is working then we can do an import.

On my computer (local server ) i try many times every time i deleted then installed from new ( since yasterday ) until now the same what i have it on my website .

I dont read arabic so I am just pecking around as I can

i change it to English now for you

i need your accept to send my site information to your email : support@photopost.com

Chuck S
April 21st, 2010, 12:01 PM
what is the message I am seeing remember I dont speak arabic?

Chuck S
April 21st, 2010, 12:03 PM
you may need to send an admin login through the contact us link in the header. I need to set the gallery to english and see whats going on

peterle
August 22nd, 2010, 10:10 AM
This script will import your vBulletin albums as Member Albums in PhotoPost PRO.


Which versions of vb and pppro are needed?

Chuck S
August 22nd, 2010, 10:13 AM
This is for vbulletin 3 series and any version of Pro greater than 5.0

peterle
August 22nd, 2010, 10:22 AM
Hey, I haven't finished to say "Bob is my uncle"! Thanks for the immediate answer. :)

Chuck S
August 22nd, 2010, 10:44 AM
enjoy your weekend

Ricsca
October 21st, 2010, 06:03 PM
News for the vbulletin 4 ?

Chuck S
October 21st, 2010, 06:41 PM
There are no immediate plans to update this old beta importer from the 3 series.

derandechser
October 22nd, 2010, 08:24 PM
Hi,
is there absolutely no way to import photos from vb4 into PhotopostPro or VBGallery? If i can´t import all the old photos (5000+) my users would kill me...

Are there really no plans to solve it?

Greetings,
Peter

Chuck S
October 23rd, 2010, 07:00 AM
vbGallery litterly was just released for vbulletin 4. There has been no time for development of unsupported scriptiing to assist in things like this.

ihstiv
March 3rd, 2011, 05:15 PM
Can somebody confirm that this won't work for VB4 by first installing vbgallery, then using the vb4 > vbgallery import script, and finally using the vbag.php converter to get the member albums into photopost pro? my guess is that there is still a missing link somewhere.. thanks

Chuck S
March 3rd, 2011, 05:19 PM
This script as it notes is for vbulletin 3 series.

ihstiv
March 7th, 2011, 04:15 PM
Thanks - sorry for not gathering that myself. I'll stick w/ vbgallery for now. cheers.

Chuck S
March 7th, 2011, 05:43 PM
no problem enjoy your evening.

Ricsca
March 20th, 2011, 07:37 PM
News for the vbulletin 4 ?

Chuck S
March 20th, 2011, 08:14 PM
My reply back in October to you is the only answer I have. Photopost Pro 8 is what is being worked on. There are no plans to release this for vb4. This in itself was an unsupported beta importer.

kharris
March 31st, 2011, 11:48 AM
I've copied this from the Install forum and placed it here where I believe it belongs:
Hello Chuck,
I did provide it, but figured it out browsing your forum. My next issue is with the importer.
I used the importer and ran ppimportalbums.php, selected import, next screen said done (very quickly, but then I don't have a large number of albums). My statistics page shows no 0 albums and 0 photos. It seems that nothing imported.
I looked over the forum where the importer download is, and following that thread, ran scan database, but no change. Any ideas? Again, thank you. I'm running vb3 8.4


I went into vb and moved pics to the database. I ran clear in the importer and reran it. Admin still showed 0 galleries and 0 pics. Ran scan database, but no change. Am I missing something? Thank you.

I received the following MySQL error in my email:
An error was encountered during execution of the query:

ALTER IGNORE TABLE pph_photos ADD `importimageid` INT( 10 ) DEFAULT '0' NOT NULL

The query returned with an errorcode of:

Duplicate column name 'importimageid'

Regarding server paths, do I need a trailing /, as in /bulletinboard/photopost/data ?

Chuck S
March 31st, 2011, 12:28 PM
Files need to be on disk not database

For the importer to work you need to properly fill out all the proper database information and full accurate server paths as noted in post 1 of this thread.

If you do this you should get things imported I would believe although technically this importer was written for an older vbulletin. I have no idea if 3.84 changes anything in regards to images. The company makes no guarantee on beta software or that it would work with newer versions of vbulletin than it was written for. This beta importer was written years ago it looks like.

what errors are displayed if any?

kharris
March 31st, 2011, 12:42 PM
Files need to be on disk not database? I reviewed the earlier posts here and it was suggested to move pics from the file system to the MySQL database then run the import...
The first time I ran the importer, my albums were in the vBulletine files system. Since the importer didn't seem to do anything, I took the advice and changed the data storage to MySQL...

I understand regarding no guarantee or anything. I don't receive any errors when I actually run ppimportalbums.php. It simply says done after I run it. You suggested I try this importer, so I am. If it works, great, if not, I'll have to have my members upload all there images to this app, which I was hoping to avoid. No real worries here. Just looking for the convenience.
The error is received in my email and is the one I posted in my previous post here. I'm not sure what "Duplicate column name 'importimageid'" means. importimageid is located in the pph_photos table, but I don't exactly understand how to correct this error.
Again, thanks and I do appreciate your support. I'm amazed on how you get around to all these forums...

There are three different tables that have duplicate columns. My best bet is to probably delete the tables and reinstall. I don't have sufficient knowledge of MySQL to figure out these errors.

Chuck S
March 31st, 2011, 02:48 PM
The importer as I see it copies actual files on disk so it is not possible to use mysql storage if I look at the code. At any rate as long as the script exists in your photopost directory and your enhanced vb3 integration is on it should run. It will either work or not. This was no doubt written back in the 3.7 series of vb. I beleive there have been changes to how albums are done in 3.81-3.84

kharris
March 31st, 2011, 11:27 PM
Thanks Chuck. I followed instructions found in one of the first posts here regarding changing the data strorage type from file systems to database in vB. I don't know enough about MySQL or PHP yet to fix the existing problem indicating a duplicate column in a few of the records. I'll delete the tables etc., and start with a fresh install.

Chuck S
April 1st, 2011, 07:22 AM
Okay whichever works if you have any questions where we might have to look at things make sure to disable any custom language thing you have as we would not be able to assist since we do not read your language.

kharris
April 1st, 2011, 09:01 AM
Chuck, the last time I checked my language is English. Anyway, I'll give a hollar if I run into any difficulties after the new install. Thanks.

Chuck S
April 1st, 2011, 11:01 AM
anytime I went to the gallery it was in spanish I beleive

kharris
April 1st, 2011, 01:21 PM
Definitely confused my site with another, or it was hijacked and I haven't noticed yet:D Anyway, I've uninstalled and reinstalled with no problems.
What I'd like to know now is if there is anyone here who has used the Importer with vB 3.8.X ? I'm tempted to run the script again, but I'd really like to know if anyone else has done so and what, if any, problems there were? Thanks to all.

Ken

Chuck S
April 1st, 2011, 03:03 PM
Yeah confusing this with a vbgallery albums importer.

This script should work regardless of vbulletin version since it is a photopost pro script ran from pro unless of course the 3.84 vbulletin uses the new vb4 albums format database layout which I know changed. This importer was specifically written for the 3.7 series as this beta importer was released summer of 2009.

kharris
April 1st, 2011, 11:15 PM
Actually, that's what I thought. I checked the date of the importer, and I figured with an '09 release, it should be good. My problem on the last install was that after running the script, it took me to a blue page that said "done" in the upper left corner, with no indication of errors. When I checked my email, I had three error messages indicating a duplicate column in three of the tables. Could have just been a corruption of the tables during installation.
I uninstalled everything last night and ran the installation again with no issues. I'll run the importer again and see what happens. Again, thank you.

kharris
April 2nd, 2011, 02:09 AM
Hello Chuck,
I ran the importer with no results and again, several MySQL errors, copied below. I cleared after the run and tried again, with the same results. I did run the scan both times. FTP also shows no files imported. How do I get a username/password to you for access? Thanks.
An error was encountered during execution of the query:
ALTER IGNORE TABLE pp_photos ADD `importimageid` INT( 10 ) DEFAULT '0' NOT NULL
The query returned with an errorcode of:
Duplicate column name 'importimageid'

An error was encountered during execution of the query:
ALTER IGNORE TABLE pp_categories ADD `importcatid` INT( 10 ) DEFAULT '0' NOT NULL
The query returned with an errorcode of:
Duplicate column name 'importcatid'

An error was encountered during execution of the query:
ALTER IGNORE TABLE pp_comments ADD `importpostid` INT( 10 ) DEFAULT '0' NOT NULL
The query returned with an errorcode of:
Duplicate column name 'importpostid'

These are the same errors I received on my last install. During the previous install, I tried moving my album storage from the file system to the database and there was no difference. During this current install I ran the importer with my vB files still in the db, no luck, so I've changed the picture storage type back to the files system, still no change. Nothing seems to be happening. I would guess the above errors are the problem, but I don't know how to fix the "duplicate column name" problems.

This is some of the info found in pp_comments:
Indexes:
Keyname Type Cardinality Action Field
PRIMARY PRIMARY 0 id
photo INDEX None photo
cat INDEX None cat

Of the three tables with the error codes, this is the only one that identifies both photo and categories, which are the other two tables with duplicate column errors. Don't know if this is helpful or not.

Chuck S
April 2nd, 2011, 11:28 AM
Duplicate mysql errors are not really errors. They are simply telling you since you ran the importer already and the fields are already there. As I have stated prior there is no product support for beta software. This is an old beta importer written for 3.7 series of vbulletin.

kharris
April 7th, 2011, 12:22 AM
Hello Chuck,

So, regarding all this, is there any intent to develop an importer for vB 3.8? I don't have very many albums on my site, however, I really don't want to inconvenience members with having to reupload what they have in the current vb albums to this. Thanks Chuck.

Chuck S
April 7th, 2011, 09:05 AM
There are no plans that I am aware of. vbulletin 3 series is on its END OF LIFE as they say over at vbulletin.

kharris
April 7th, 2011, 09:16 AM
Hi Chuck,
That's true, but as you probably know, that doesn't mean that 3x is dead and going away with its users. Even this site is operating on 3.8. Right now I'm just stuck between a rock and a hard place with this ap. A lot of nice features, but pulling over the existing albums is a show stopper for now. Again, thank you!

Ken

Chuck S
April 7th, 2011, 10:54 AM
Ken no problem but yeah not much I can do here as there is no ability to do what you want. Basically when vb3 went end of life all work has been concentrated on vb4.

Same thing happened to people when vb3 came out for those vb2 users. Once a product is noted as end of life you do not see any new work on a dead product.

We will keep the vb3 integration for those users who will remain on vb3 but no new work is going to be done. Soon we will have to gear up possibly sometime for vb5.

Markus.B
May 15th, 2011, 02:28 PM
is this script working/import with the Albums from a vb 3.8.3 installation?
Anybody have tried with this vb version?
Would like to import before i upgrade to vb4.1.x

cheers markus

Chuck S
May 15th, 2011, 06:23 PM
You can try it but this importer was written for the 3.7 series of vbulletin. I do beleive they changed how albums where done in vb 3.8

kharris
May 21st, 2011, 04:48 AM
Hello Markus,
In my experience, it doesn't work with 3.8.4 and I don't know of anyone who has gotten it work.

Chuck S
May 21st, 2011, 11:22 AM
I beleive this old importer was written for the vb 3.7 series. It is quite old.

kharris
May 21st, 2011, 11:37 PM
I understood that from our previous posts. Markus indicated he uses vb 3.8.3, which like .4 doesn't work with the 3.7 script.

Chuck S
May 22nd, 2011, 07:02 AM
yeah I don't think anything past 3.81 would work as was that not when they changed how they did albums in vbulletin.

JoeWho
February 18th, 2012, 12:43 PM
Hello Chuck,

Couple of questions, will this importer work with PhotoPost PRO 5.6.2 and vBulletin 3.7.4?

I tested it on a localhost and all I get is a blue screen, no options to select. The form and the gallery are both working fine on the localhost. I just wanted to tested it before trying it on a live server.

Do I need to upgrade PhotoPost PRO 5.6.2 before running this importer?

Chuck S
February 18th, 2012, 01:03 PM
I can not say for sure it was beta to begin with so it is try it and see basically. No support or no new versions ever came out.

JoeWho
February 18th, 2012, 01:16 PM
Hi Chuck,

Is there any other way to move the files into PhotoPost PRO from vBulletin albums?

Chuck S
February 18th, 2012, 01:21 PM
Not without actually uploading them no.

Whether this importer works depends on if your vb forum version is below when ever they changed the album stuff in vb. You might need to look at there release notes.

JoeWho
February 18th, 2012, 01:53 PM
Hi Chuck,

That's disappointing, basically anybody who wants to use PhotoPost PRO is going to lose all the photos in the vBulletin albums. :(

Chuck S
February 18th, 2012, 02:23 PM
vbulletin albums is not a gallery. We do not advertise that we support conversion of vbulletin albums.

Like I said all you can do is try it. Now if your getting a blank page maybe you have a php error as this is older it might be failing on newer php versions you can turn on display_errors to on and see if it will display an error.

I can guess that maybe this in the file


if (substr($do, '',


might need to be maybe this


if (substr($do, '0',

JoeWho
February 20th, 2012, 07:26 AM
Hi Chuck,
Thank you for your help but I've run out of time I will have to work on this some other time. I spent a week working on updating the forum from vb3.7.4 to 4.1 .10, I think I have all the bugs worked out for a fairly smooth upgrade and then I realized I didn't know how I was going to move the photos, it's something I'll have to tackle when I have more time.

Chuck S
February 20th, 2012, 08:27 AM
Yes well since you moved away from vb 3.74 this whole discussion is mute since this importer is for the older vb series.

JoeWho
February 20th, 2012, 09:19 AM
No, I am still at 3.7.4, I'm not grading to 4.1.10 until I figure out how to move the files/photos. I've been running the tests on my computer, not live, localhost.

Chuck S
February 20th, 2012, 09:39 AM
Well okay gotcha.

If your having trouble running the importer on your home computer try actually install PhotoPost Pro on your live site and doing an import. The importer does not touch or delete any vb albums content and like I said my only thought if there is a conflict with some newer PHP is maybe what I posted above might help if that is your case. Can not say for sure just something for you to try.

You are bound to have alot more issues using the pre-configured package things most people install on there home computer to support PHP and Mysql. Those things are alot more strict that the PHP running on webhosts.

JoeWho
February 20th, 2012, 04:35 PM
Hi Chuck,

Thanks, good idea ... now I know that it is not going to work, don't know why it cant write the file.

unable to write thumbnail [/home/public_html/photos/data/0/thumbs/35f7405f9cc3d1d4aa7be39f0e6a5d52_876.jpg] - check permissions

Folder "data" and all sub-folders set to 777.

Anymore ideas?

I send you a link, email?
Thanks

Chuck S
February 20th, 2012, 05:13 PM
Joe I do not provide support for this old beta importer as I posted already sorry. Beta software in general does not have support and your trying to install next on a vb version that was released after this thing was created.

I can offer comments though. ;)

Now the reason you have the issue posted above is your $albid variable is 0. My suggestion would be to check your albumpicture table in vb and see what the albumid is. Apparently based on your error you have some entries with an albumid of 0. Maybe entries that where orphaned from deleted users? I can not say. I would personally delete any entries where albumid is 0.

JoeWho
February 21st, 2012, 12:08 PM
Hi Chuck,

Success, what I ended up doing was moving all the photos/albums from file storage into the database and then making a new attachment-folder for them and transfer them out of the database into a file. After that they import without any problem. I will agree with you that there was an orphaned photos from deleted users, I don't believe vBulletin deletes the albums when a account is deleted.

I know you do not provide support for this importer. I do want to thank you for your help with figuring out why it wasn't working for me.

Have a great day.

Chuck S
February 21st, 2012, 12:17 PM
That is good to hear enjoy.

olijo
November 2nd, 2013, 03:59 AM
Hi,
old thread but anybody had tested this with vB4.2 ?
Any news to update this script ?
Regards,
Olivier

Chuck S
November 2nd, 2013, 08:47 PM
To my knowledge this is a beta importer for vBulletin 3. There was never any scripts written for vBulletin 4.