PDA

View Full Version : phpbb3 integration


AstroFM
June 1st, 2009, 07:51 PM
phpbb3 integration

So I sent email asking about phpbb3 integration sales say yes so I buy photo post.

why do uses have login 2 times. once into the rest of my site and once into photo post?

for some reason I can make posts in the support forum. I can only make a post in the presales forum.

Tony

Chuck S
June 1st, 2009, 10:10 PM
We support the phpbb3 user login if you have to login twice most likely its a cookie issue. You did specify the correct phpbb3 cookie name where asked on install correct?

Here is a thread on cookies and how yours should be set

http://www.photopost.com/forum/photopost-product-faqs/136971-cookies-login-problems.html

AstroFM
June 2nd, 2009, 01:05 AM
thanks for the reply.

both are set the same. I emailed the screen shots to support.

.mydomain.name
phpbb3_d6auh
/

AstroFM
June 2nd, 2009, 07:19 AM
ok doing some more testing. it does not look like photopost using my cookie name that is set.

the top one is what what I get when I login using photopost
_u 58
_k 48afc0de0dc33148
_sid 9e1be9b3a413601634b8841af5167803

is what i get when I login anywhere else on our site.
PHPSESSID 7t5894sajphbpou563rd33mrs2
phpbb3_d6auh_u 58
phpbb3_d6auh_k
phpbb3_d6auh_sid de631654dac00611a29b9622207c7135


I checked in the database pp_settings table
varname = cookieprefix
settings = phpbb3_d6auh

I searched every file and could only cookieprefix 2 times
once in install.php and once in upgrade.php

I could not find anywhere where it the setcookie used cookieprefix


setcookie("$cName","", time() - 3600, $Globals['cookie_path'], $Globals['domain_path'] );
setcookie("$cName","", time() - 3600, $Globals['domain_path'] );
setcookie("$cName","", time() - 3600, "/");
setcookie("$cName","", time() - 3600);



how do I get Content visible to verified customers only. fixed? I entered my lic number in the user cp

Chuck S
June 2nd, 2009, 11:24 AM
You did not enter the cookie name where asked. It is not cookie prefix. It is cookie name I beleive setting 165 in the settings table

You can rerun install and correctly rerun install that will work. ;)

AstroFM
June 2nd, 2009, 06:02 PM
settings 165 Im not user SMF forum it says Only needed for users of SMF forums I did not find any where in the install directions that says PHPBB3 users enter your cookie name in the SMF cookie name.

what cookie name do I put enter?

Chuck S
June 2nd, 2009, 10:11 PM
Setting 175 its the smfcookie variable.

Thats used for the cookiename in phpbb3 smf and wowbb forum integrations and on install we ask for the cookie name on step 4 of install.