PDA

View Full Version : Uploading problem - image type not supported


georgephil
May 28th, 2009, 06:12 PM
I just moved my site to a new server and now can't seem to upload pictures. I have tried both as administrator and as a registered user with the same result. I get the error message "THAT IMAGE TYPE IS NOT SUPPORTED YET"
The permissions for the data directory and all subdirectories are set to 777. The permissions for the upload directory are set to 777.
I have tried deleting all subdirectories in the upload directory - same result.
If I look at the upload directory after trying to upload a picture, the picture is in a subdirectory of the upload directory.
The picture is a .jpg file and I have .jpg listed as an acceptable filetype in the admin uploads options.
Other than that problem everything appears to be working correctly, all of the existing photos are showing.
Any suggestions?
Thanks.

Chuck S
May 28th, 2009, 06:17 PM
http://www.photopost.com/forum/photopost-pro-how-do-i/130048-how-move-servers-change-directories.html

Have you changed your server paths to the correct new ones as noted here?

georgephil
May 28th, 2009, 06:19 PM
Yes I have. I used your guide to make the change.

Chuck S
May 28th, 2009, 06:22 PM
What is the full error message?

Basically there are very few issues that can cause this.

1. Your path is not correct in global or storage options.

2. Your data directory is not 777 permissions at every level

3. safe mode is on.

georgephil
May 28th, 2009, 06:51 PM
Problem partly solved.
I had neglected to make the change in the storage options section. Once I did that, the previous error went away, but has now been replaced by a different error message that reads as follows:

Unable to read the format of file: /home/vettepartsauctions/public_html/photopost/data/500/medium/C6_1000HP_Right_Side.jpg

This is a standard jpg file, shich shows up fine on the computer. In fact I have tried several different jpg files just in case something was wrong with the file. They all give the same error message.

George

Chuck S
May 28th, 2009, 06:54 PM
That would suggest the directories under 500 are not 777 permissions

georgephil
May 29th, 2009, 01:43 PM
Problem solved.
For some reason the directories kept reverting to their previous permission level. each time that I would change them to 777, it would work for one upload, and then stop working. When I would go back and check the permissions again, they were back to the original settings. I was able to stop this from happening by setting the "sticky" bit on each directory when setting it to 777.
After that it seems to be working.
Thank you so much for your help.
George

Chuck S
May 29th, 2009, 01:46 PM
George glad its all sorted. If you need anything else let me know. have a good weekend!