PDA

View Full Version : difference between standalone and PPvBgallery


skidpics
June 19th, 2008, 08:53 PM
I am kind of confused about the products.

The stand alone version of PP and the PhotoPost vBGallery v2.4.2

If The standalone version is integrated with Vbulletin, would it offer the same options and integration as teh PhotoPost vBGallery version or are they in all 2 total different critters?

I am looking at the PhotoPost vBGallery version, and although the integration is very nice, some options I do not see that I see in my standalone version, such as multiple categories for uploading, admin batch upload from a chosen directory, instead of 1 default user directory and the quick ratings.. they are no where to be found below or above the photo except for a drop down rate image button that takes longer than the quickrate..

Is there a comparison chart somewhere?

skidpics
June 19th, 2008, 09:36 PM
never mind. Found the comparison here: PhotoPost PHP Photo Sharing Photo Gallery: Pro vs. vBGallery (http://www.photopost.com/compare.html)

It seems like standalone has more functions, but the Vb versions looks nicer intergrated the way it is..

Chuck S
June 20th, 2008, 08:48 AM
I guess its a matter of choice really. On the front end they both integrate the same way pulling the vb header footer navbar and stylesheet. The main differences are vbGallery uses vb templates and admin section whereas Photopost has its own and more features so most of the differences are on the backend and feature stuff.

skidpics
June 20th, 2008, 09:46 AM
Since I have the vb version installed, can I go ahead and just install the stand alone version on top of what I have, and integrate it, or will that cause a problem?

skidpics
June 20th, 2008, 10:16 AM
well, I tried it and getting Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/vande11/public_html/photospider/galleries/forums/vb2.php on line 25

Chuck S
June 20th, 2008, 10:22 AM
Okay well for one you are trying to integrate with vbulletin 3 right not 2? You need to select the proper integration on install for vb 3 and the error you note comes from either not inputting the correct vb database info for vb where asked and or not inputting the correct vbulletin table prefix on step 4 of install.

Here are common mistakes when installing with vb3

http://www.photopost.com/forum/photopost-product-faqs/136878-vbulletin-installation-integration-common-issues-resolutions.html

Let me know if that helps you out.

skidpics
June 20th, 2008, 10:31 AM
got it. wrong version and wrong /forum directory was causing a problem.

Okay. so not that is done, I actually have 2 galleries running then, one pp vb and the standalone.

How do I disable to PPvb plugin?

I did take the navbar link off.

Chuck S
June 20th, 2008, 10:40 AM
You can run the vbGallery install script again and select UNINSTALL. That should be all you need to do.

skidpics
June 20th, 2008, 10:42 AM
Got it! thanks!

Where do I add the gallery link to show on the vb navbar?

Chuck S
June 20th, 2008, 10:54 AM
You can add a link in your vbulletin navbar template for your Photopost Pro Gallery.

skidpics
June 20th, 2008, 11:07 AM
Got it.

Now I just need to figure out how to include pics like the PP vB plugin and I am set with a new installed and start moving things over.. thanks for the help.

I will search the boards on how to include the images like that, if not, I will ask again.. thanks for the help again, Chuck.

I need to let my site rest and let it be. I spend too much time trying to tweak the UI for presentation purposes. I am all about the look, and getting it perfected takes time..

Chuck S
June 20th, 2008, 11:37 AM
This is what you want. ;)

http://www.photopost.com/forum/photopost-pro-mods/122207-photopost-featured-block-plugin-vbulletin-3-5-a.html

skidpics
June 22nd, 2008, 09:21 AM
got that running - that thread you posted is split in 2 parts - one, the plugin, the other link, the instructions. ;-)

Okay. I am using the $photopostfeature in my forumhome template until I get it squared away..

I have thumbs on my forum page, but they are blank. They are NOT blank in the gallery, but when clicked upon, they go to the correct photo..

This is my code. My PP install is NOT within the forum directory. it is off the root.

<?xml version="1.0" encoding="ISO-8859-1"?>

<plugins>
<plugin active="1" product="vbulletin">
<title>Photopost Feature Block</title>
<hookname>forumhome_complete</hookname>
<phpcode><![CDATA[include('../galleries/inc_features.php');]]></phpcode>
</plugin>
</plugins>

So now it shows below the forum navbar. but NO thumbs..

skidpics
June 22nd, 2008, 05:13 PM
Think I got it:

In your Photopost Admnin => Edit Integration place a trailing slash on the data path

skidpics
June 22nd, 2008, 07:44 PM
okay.

On the PPvb gallery, there is a feature that allows subcategories to show under the main categories.

Outdoor Photography
Weather, Scenery and Nature, Underwater, Architecture

How does one get PP standalone to do this?

I also love the integrated part with PPvb that shows a gallery menu block that shows this:
Home My Stuff What's New What's Popular Upload Search Moderate New

How does one integrate that with PP Pro??

Chuck S
June 23rd, 2008, 08:57 AM
I would suspect those are vbgallery only features. Our menubar is not the same as vbGalleries and our photo block shows on the main index of the forum.

skidpics
June 23rd, 2008, 09:25 AM
The subcategory listings below the categories would be a very nice feature to the Pro version..

Chuck S
June 23rd, 2008, 09:35 AM
Feel free to post any suggestions in the Pro suggestions forum ;)