PDA

View Full Version : Integrated with vb3, login redirect issue


digidivakathy
April 27th, 2008, 08:13 AM
Hi. I did a reinstall (basically a fresh install using a database they'd tried to use and been unsuccessful at completing the install) of vb/pp for someone and thought it was working fine, but when you try to login via the Gallery URL, you get this when you click the login button:

The requested URL /Gallery/login.php was not found on this server.

It's trying to go here:

http://studiostyledesigns.com/Gallery/login.php?do=login

I have checked and double checked the config-int.php file and all is right there. Can you please help me figure out why it is doing this? If I login via the Forum instead, it's fine. I can then navigate to the gallery and even get to the admin panel.

The forums are turned off now. I wasn't sure if this was a common problem (though I searched here to no avail, tried the thread which suggested changing the header-inc.php file and it didn't help) so I didn't know if you'd have to log in to see it or not. I don't want to leave the forum on all day, but if you need me to turn it on and set up a test account, let me know.

Thanks!

Chuck S
April 27th, 2008, 08:27 AM
I would need to see a functional open gallery to respond further but I would suggest you go to your photopost admin and in forum settings make sure your url to the forum is correct there. You can also check in your vb admin options the url is correct there as well.

digidivakathy
April 27th, 2008, 08:31 AM
I have done both. I'll be back in a sec with a login and pass for you.

digidivakathy
April 27th, 2008, 08:34 AM
Try user: test, pass: help.

Link: http://www.studiostyledesigns.com/Gallery

Thanks, Chuck!

Chuck S
April 27th, 2008, 12:05 PM
Interesting I have no issues logging in from the vb navbar when viewing that url

Is there something I am missing?

digidivakathy
April 27th, 2008, 02:11 PM
Really? When I and the store owner try to login from there, we get the message I posted above. Wonder why you didn't?

Chuck S
April 27th, 2008, 02:27 PM
Not sure if I login from the gallery I get logged in although you have not set any permissions for that user

digidivakathy
April 27th, 2008, 02:30 PM
I didn't set any for the test user, I didn't know if you needed them or not. This is the worst installation I've ever done, I came in behind someone else and what a mess. Anyways, it did work for me just now, too, so maybe my changes just took a bit to kick in (makes no sense, but I'm just glad it works). Now I seem to have some sort of permissions error on uploads, but the permissions on the files/folders show to be correct. I'm getting more gray hair by the minute, LOL. New problem (if you want a different post for it, I'll do that)...

Warning: fopen(http://studiostyledesigns.com/Gallery/uploads/1/index.htm) [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections. in /home/studi99/public_html/Gallery/pp-inc.php on line 3034

Warning: fclose(): supplied argument is not a valid stream resource in /home/studi99/public_html/Gallery/pp-inc.php on line 3035

/data and all subdirectories as well as /uploads and all subdirectories are at 777. No idea what else to check. Any ideas?

digidivakathy
April 27th, 2008, 02:54 PM
Never mind. I think she was in there at the same time as me and somehow we got it to work. Maybe she unchanged something I changed or vice versa, I dunno, but for the moment, it's working... (knocking on wood).

Chuck S
April 27th, 2008, 04:16 PM
yeah you need to enter a server path to the uploads directory not a url.

Not good to have multiple changes to settings at the same time sure its hard to know where your at ;)