PDA

View Full Version : New PhotoPost Owner - No Photos After Upload?


MktgWiz
February 24th, 2008, 09:09 PM
Hello Everyone

Just installed the latest PhotoPost at http://www.virginiaphotographer.net when you upload (Takes awhile for the upload 2.8 meg file) the progress rotation doesn't spin then finally comes up and says Successful Upload yet nothing appears?

I am sure its something simple. Thanks in advance for any insight!

Successfully yours,

George Marsh
Marketing Wiz
george@mktgwiz.com

Chuck S
February 24th, 2008, 09:31 PM
PHP is set to a file limit on uploaded files to 2mb so if you upload larger files the server drops them. You would need to edit the php settings on your server to allow large file uploads. Do you have this ability?

MktgWiz
February 24th, 2008, 09:54 PM
Hello Chuck

Thanks for the quick response. I currently have deluxe hosting option on Godaddy.com. I have looked around but see no file size setting that I can change? If I do not hear back from you shortly I will call them to find out how I can change it. Thanks!

Successfully yours,

George


PHP is set to a file limit on uploaded files to 2mb so if you upload larger files the server drops them. You would need to edit the php settings on your server to allow large file uploads. Do you have this ability?

MktgWiz
February 25th, 2008, 12:15 AM
Hello Chuck

OK I contacted Godaddy.com they instructed me to modify the php.ini file in my host root directory and I added these lines:

memory_limit = 50M
post_max_size = 10M
upload_max_filesize = 5M

so the entire php.ini file looks like this:

register_globals = off
allow_url_fopen = off

expose_php = Off
max_input_time = 60
variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
SMTP = relay-hosting.secureserver.net
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

memory_limit = 50M
post_max_size = 10M
upload_max_filesize = 5M

[Zend]
zend_extension=/usr/local/zo/ZendExtensionManager.so
zend_extension=/usr/local/zo/4_3/ZendOptimizer.so

Now when I go to upload a photo when I choose the catagory I am automatically sent back to the maine PhotoPost page or my home page of the site? If I simply say choose file when my file window pops up I can see behind it that the page resorts back to the home page of the site. Not allowing me to upload anything at all?

Before I was at least able to upload the file and it say successful but not uploading the actual photo, now this?

I was hoping to have this done tonight, but appears you have signed out for awhile..hopefully this is a easy fix?

Successfully yours,

George



PHP is set to a file limit on uploaded files to 2mb so if you upload larger files the server drops them. You would need to edit the php settings on your server to allow large file uploads. Do you have this ability?

MktgWiz
February 25th, 2008, 03:54 AM
Hello Chuck

After pulling most of my hair out. I decided on a whim to jump on one of my PC's to see if the same thing happened and it worked fine? I work primarily on a MacBook Pro laptop and when my sweetheart was helping earlier testing it she was using her MacBook Dual Core Laptop and it was hanging up and not showing the photo and she was using Safari as well, the only difference is she was using Tiger and I am on Leopard? It also works on my MacBook Pro using the latest FireFox.

You will see everything seems to working fine now if you visit
http://www.virginiaphotographer.net

Just would like to know if it is in fact an issue with Safari on the new Leopard operating system causing it to jump back to the main page and now allowing me to upload, so I can inform my users who maybe using Macs before it becomes an issue.

Thanks again!

George

Chuck S
February 25th, 2008, 11:09 AM
The error you had was on the server itself not the computer end. Your server dropped the file as it was larger than the server allows. Now what do you mean she cant view it?

MktgWiz
February 25th, 2008, 03:21 PM
Hello Chuck

Your absolutely correct that the actual fix to not seeing the photo and it showing successful upload was in fact a line that needed to be added to my host root account called php.ini which I described above.

However that fixxed the problem and now allows you to upload photos nicely, only if you are on a Windows (IE) PC, or a Mac Running the older Tiger OS, however when I use my Safari on my MacBook Pro which has the newest OS Leopard when you go to upload it takes you back to the main page from the upload screen, if you try to comment on a photo it doesn't allow you to do so and sends you back to the main page?

Make sense?


Successfully yours,

George


The error you had was on the server itself not the computer end. Your server dropped the file as it was larger than the server allows. Now what do you mean she cant view it?

Chuck S
February 25th, 2008, 05:20 PM
George that would suggest that somehow your MAC is preventing the file from being uploaded to the server as your server allows that size of a file to upload. I have never personally owned a MAC so you might want to search MAC limits on that new operating system to see if there is anything that prevents certain filesizes to be sent. Maybe an operating system restriction. Off the top of my head only thing I can think of.