PDA

View Full Version : Error after trying to edit photo info


DTSS
February 11th, 2008, 09:04 PM
After trying to edit photo info, I get this error:

/var/www/vhosts/metalartistforum.com/httpdocs/photopost/data/500/medium/cellist1.jpg -> /var/www/vhosts/metalartistforum.com/httpdocs/photopost/data/509/medium/cellist1.jpg
Copy of the file failed. Operation cancelled.

Both those folders are set at 777

Chuck S
February 11th, 2008, 09:06 PM
Have you double checked that medium directory under 509 is 777?

Basically every data directory at every level needs to be 777

DTSS
February 11th, 2008, 09:10 PM
Directory under 509? I dont see a directory there but every folder in data is 777

Chuck S
February 11th, 2008, 09:16 PM
I am referring to the 509 directory under data. The data directory at every level beneath it needs to be 777 permissions. Hense this below every directory under data must be 777. It appears to me that not all your data directories at every level are 777.

data
-- 509
-- medium
-- mini
-- thumbs

DTSS
February 11th, 2008, 09:24 PM
I have 22 folders under data. All are 777. There are no sub-directories under any of these folders.

I looked at the folders on my test forum and all these folders have sub-directories on that server.

For some reason, the sub-folders seem to be missing.

Chuck S
February 11th, 2008, 10:07 PM
That would be strange indeed. Was safe mode on on the server. I dont know any way to create them other than you doing it manually and changing permissions or deleting and recreating the categories so the script can do its job and create and set permissions accordingly.

DTSS
February 11th, 2008, 10:15 PM
Well that worked. I copied the sub-directories from my other server and it worked. Am I going to have to do that for every folder?

DTSS
February 11th, 2008, 10:23 PM
Seem ok now. I have no idea why this is so glitchy

Chuck S
February 11th, 2008, 10:52 PM
Permissions issues I guess on the one server. Or possibly permissions where not correct when you initially made the categories who knows.