PDA

View Full Version : Video Upload Problems


Cajunle
December 10th, 2007, 11:16 AM
Using VB Version 3.6.8
Photopost Version 6.01
Both Fresh Install.

I'm having problems uploading a 6M video. I adjusted my PHP.ini file to take up to 10M and adjusted Maximum multimedia upload size in Kb to 160000000 in Photopost Admin and when I upload, I am just return to the Video Category and no file. Acceptable multimedia file types incluses wmv extentions.


Any other suggestions?

Chuck S
December 10th, 2007, 11:19 AM
What is the error you get?

The php settings one needs to alter for video are this that I can recall.

memory_limit 32M
max_execution_time 0
post_max_sizr 10M
upload_max_filesize 10M

then you make sure upload mulitmedia is set to yes in admin options and you should be able to upload a video. Please post any errors so we may assist further. Some hosts also restrict filesize in the apache setup so if you post your error we can refine our answer here.

Cajunle
December 10th, 2007, 12:19 PM
There is not error code. When you upload it goes through its process but returns you to the catageory you choose to store. No file is uploaded. It may be because I am about 150 in The Gulf of Mexcio and company fire wall may be causing problems, but I have no problems uploading photos.

I set the parameters below also
memory_limit 32M
max_execution_time 0
upload_max_filesize 10M

I did not find this one "post_max_sizr 10M" I also have the yes to upload mulitmedia set.

Cajunle
December 10th, 2007, 12:42 PM
Ok I think I resolve the problem. I put a copy of the php.ini file from the root to the photopost directory and it work. Is this right or should it work across the website if the php.ini is in the root.

Chuck S
December 10th, 2007, 03:11 PM
That could help yes if your host restricts any ini file overrides to only a specific directory. If it works within the photopost directory then just keep this that way. ;)

Strike-Force
December 10th, 2007, 09:48 PM
I actually have a similiar issue. It's a fresh install by you guys today also. I turned on the multimedia option, and put the limit at 100k. It acts like it is uploading, and then after about 4-5 minutes it refreshes to the upload page.

No errors
No videos
Nada

I have no clue how to check/change those PHP settings you mention, unless you give me some detail instructions on it.

Chuck S
December 10th, 2007, 09:55 PM
well 100k is a small file for a video so you might want to remove that. You may not be able to change your php settings which means video's need to be limited to 2mb. You would need to ask your host if you can up those settings noted in this thread.

Strike-Force
December 10th, 2007, 10:00 PM
I have a VPS account with my host, but I'll still ask them about it. Also, if I wanted to upload a 15mb video what should I set the "Maximum multimedia upload size in Kb" to then?

Chuck S
December 10th, 2007, 10:44 PM
15360

You would need to make sure any resulting changes are also made in your php settings on the server and then they need to restart the server.

Strike-Force
December 11th, 2007, 07:01 PM
The php settings one needs to alter for video are this that I can recall.

memory_limit 32M
max_execution_time 0
post_max_sizr 10M
upload_max_filesize 10M




The changes have been done and the server restarted, but I still get the same thing. If I upload the video's to my photopost data folder via my file manager, the videos will show up once I use the ADMIN OPTIONS FOR BULK OR ZIP UPLOADS.

The majority of my video's are between 12-15mb, should those settings be higher?

Chuck S
December 11th, 2007, 07:26 PM
You can email us at support@photopost.com with a url admin login and link to where we can grab a video file that big and try to upload so we can see your error.

without stating your exact error its hard to determine what your issue is.

Strike-Force
December 11th, 2007, 07:29 PM
There's no error coming up. It goes through the uploading process and then refreshes to the upload page screen again.

Cajunle
December 11th, 2007, 07:43 PM
Try coping your php.ini file from your root to the directory you have your photopost located. That work for me.

Chuck S
December 11th, 2007, 08:21 PM
Yeah I would suggest you check under Admin => PHPINFO and see what your current php settings are it definately sounds to me like whatever changes where not made where not made correctly. I would suspect your php is still not set to allow for large file uploads.

Strike-Force
December 11th, 2007, 08:37 PM
Yeah I would suggest you check under Admin => PHPINFO and see what your current php settings are it definately sounds to me like whatever changes where not made where not made correctly. I would suspect your php is still not set to allow for large file uploads.


Here's what the PHP settings are currently at:

memory_limit = 32M
post_max_size = 10M
upload_max_filesize = 10M

The only one not set to the value you posted is the max_execution_time = 30

Chuck S
December 11th, 2007, 08:47 PM
There you go try setting that to 0. Your php process is timing out and thus the script starts over.

Strike-Force
December 12th, 2007, 06:45 AM
All the settings are now where you recommended they should be, but it's still going threw the motion of uploading for about 2-3 minutes and then refreshes back to the upload page. Still no errors either.

Chuck S
December 12th, 2007, 09:48 AM
What is the size file you are trying to upload? The issue your describing tells me you are trying to upload a file larger than your maximum filesize allowed in PHP. Example your setting your max filesize to 10mb your saying. Are you still trying to upload a 15mb file and expect this to work? If you want to upload a 15mb file you must raise your php limits higher to say 16mb not 10mb.

Strike-Force
December 12th, 2007, 10:25 AM
That may be the issue then.

Just so there's no confusion on my end, if I wanted to upload a 15mb video what should these settings be on?

memory_limit 32M
max_execution_time 0
post_max_size 10M
upload_max_filesize 10M

Chuck S
December 12th, 2007, 10:26 AM
Instead of 10M try 16-20M in the settings above.

Strike-Force
December 12th, 2007, 10:29 AM
So then this would work?

memory_limit 32M
max_execution_time 0
post_max_size 20M <----
upload_max_filesize 20M <----

Chuck S
December 12th, 2007, 10:43 AM
Yes that would work if your uploading a video smaller than 20M

Strike-Force
December 12th, 2007, 12:12 PM
It's a little slower than expected, but the video uploading is now working. Thanks for your help Chuck.

Chuck S
December 12th, 2007, 01:04 PM
The slow part is the file being uploaded to your server via the connection to the internet you have and has nothing to do with the software so not much I can help with there. ;)