PDA

View Full Version : Photopost not using members avator in SMF


Cajunle
November 20th, 2007, 07:24 PM
My questions is how do you make it work when members upload their own image?

I read in some of the post that other had problems with avators working using SMF into Photopost. If you use the avator in the system already under the Actors or Musicians it works with photopost. So how do I get it to work with members upload photo's?

Chuck S
November 20th, 2007, 09:50 PM
well I know we supported the avatar system of smf but I think they added a 2nd or 3rd type of avatar cant remember in their newest release and that is not something we support at this time. It is something we will look at supporting in future versions.

Cajunle
November 21st, 2007, 06:47 AM
Hi Chuck

This is what I found out so far.

If I use the Personalized Picture preset avatars that come with SMF it will show in both SMF and Photopost.
If I choose the upload a picture on a specify URL it work in both SMF and Photopost.
If I choose upload my own picture and it is loaded in a designated directory within my SMF folder it will not carry over to Photopost.

No matter if I set permissions to 777 on the disgnated directory it will not work. It works in the first two steps I described above, but why not also work in the 3rd. It’s not a directory or upload directory problem that I can find. I check the smf.php file in Photopost and can not seem to find the cliché there either.

Chuck S
November 21st, 2007, 06:49 AM
Correct as explained they redid their forum and added a 3rd avatar type recently and we do not currently support this.

jeff260z
April 4th, 2008, 05:55 PM
Will you add support for this? It would be nice to get this working.

Chuck S
April 4th, 2008, 06:01 PM
If I choose upload my own picture and it is loaded in a designated directory within my SMF folder it will not carry over to Photopost.

well i guess if we get a change to look at it sure but we would need to know how to investigate this

Chuck S
April 4th, 2008, 06:25 PM
I will try and support this when smf 2.0 goes gold.

jeff260z
April 6th, 2008, 04:30 PM
Thanks Chuck.

Chuck S
April 6th, 2008, 08:01 PM
Yeah not a problem it is not really that hard. The other avatar type is stored in the attachments table of the smf forum so its just adding another conditional that if there is a result then call the avatar like so

http://www.omegatron.net/smf/index.php?action=dlattach;attach=1;type=avatar

Mannie_F
March 20th, 2010, 11:59 AM
I think the avatar won't change in smf 2.0 when it goes gold. Right now we don't have avatars that we upload, really hope that can be done some way in the meantime

Chuck S
March 20th, 2010, 05:25 PM
yeah getting a gold smf 2.0 when it goes gold and they stabilize what they are doing we can look at it

kisii
November 18th, 2011, 12:49 PM
Was this ever resolved? My avatars are still not showing up on the forum ( the ones that users upload) . SMF is now 2.0 gold, please talk to us. Thanks

Chuck S
November 18th, 2011, 02:25 PM
Nothing was ever resolved as we support the type of avatars that where available when we released the integrations. I have no first hand knowledge when betas go gold unless people like you tell me. If I get a chance I will look into the different avatar types or supporting other types etc but this will take some time.

kisii
November 18th, 2011, 07:51 PM
It went gold about 4 months ago. In-fact its at Version 2.01 already. Please keep us posted.

Chuck S
November 18th, 2011, 09:31 PM
I will let you know when I have time to look into it.