PDA

View Full Version : Header on all pages?


Tennespeedy
October 25th, 2007, 04:27 PM
How do I disable the header on all the pages except for the MAIN page? The image only shows up on the MAIN page, the rest it's just a blank box. I saw the option for the sidebar but not the header.

Chuck S
October 25th, 2007, 04:33 PM
You cant say without possibly loading a blank header for each category where you set a header for each cat in edit categories just make a blank header ;)

Tennespeedy
October 25th, 2007, 04:42 PM
Gotcha, thanks. I see the option in the edit cats. Just have to figure it out now. Can I set the path to just an image or do I just type in some jibberish to disable the default header path?

Chuck S
October 25th, 2007, 06:51 PM
No you set it to an html file you make like say catheader.htm and load that file. Just make sure that file you upload to the server is empty and you got what you want. Only a header on the main page

Tennespeedy
October 26th, 2007, 03:08 PM
Thanks Chuck. I just made an empty .txt file and uploaded it to "public" and that worked like a charm. ;)

http://www.fireworksmegagallery.com/showmembers.php/cat/500

EDIT:::Nope that didnt work. When I did that it axed the header on the main page..arggh. When i re-edited the cats, it re-appeared.

Chuck S
October 26th, 2007, 03:34 PM
I see this right in our file


$newheader = $Globals['header'];

if ( isset($CatPerms['headtags'][$thecat]) && file_exists($CatPerms['headtags'][$thecat]) )
{
$headtags = implode( " ", file($CatPerms['headtags'][$thecat]) );
}

if ( isset($CatPerms['footer'][$thecat]) && file_exists($CatPerms['footer'][$thecat]) )
{
$Globals['footer'] = $CatPerms['footer'][$thecat];
}

if ( isset($CatPerms['header'][$thecat]) && file_exists($CatPerms['header'][$thecat]) )
{
$newheader = $CatPerms['header'][$thecat];
}



This tells me as long as you place a proper true server path to some other header file we will load that instead of the global header. So is your path correct in the category? Thats the only thing I can think of is your path is wrong and we dont find the file.

Tennespeedy
October 26th, 2007, 03:43 PM
OK, I deleted the txt file and replaced it with a new htm file and filled it with the default PP Pro html. Then I went to the Member Galleries cat and set the path to it. What happens is......when I set a path to a header in a category, that header shows up on the main index page header. The cats I leave blank use the main header.

....ok...really confused now. :confused:

MAIN http://www.fireworksmegagallery.com/index.php

Member Galleries Cat http://www.fireworksmegagallery.com/showmembers.php/cat/500

Other Categories http://www.fireworksmegagallery.com/showgallery.php/cat/503

SO, for some reason when I set a header path in any category, it makes the MAIN header show up that way. If I leave a cat header path empty, it uses the default (Main) header


The path for Main header is /home/firewor3/public_html/header.htm

The path for the new htm file I just uploaded is

/home/firewor3/public_html/catheader.htm

Tennespeedy
October 26th, 2007, 04:16 PM
Is there a line of code that can be deleted in the Categories template so that the categories use NO HEADER at all?? Just a thought. :o

Chuck S
October 26th, 2007, 05:10 PM
No sorry it doesnt work like this. basically it checks for a header at the path you load and loads it. You can send admin login and ftp info to support@photopost.com along with this thread link so I know who you are and lets see if I can help you.

Tennespeedy
October 28th, 2007, 03:33 PM
OK, what I figured out is that whatever the header is set to for MEMBER GALLERIES or MAIN is what both of them are going to show. Looks like they are tethered to each other. The rest I have set to a different header path and they are all independent and work properly now.

I can live with that, but the header pics show up as empty boxes in member galleries. What can I do to fix this?

Chuck S
October 28th, 2007, 04:19 PM
make your relative image paths in your header full urls to the images so they can be found. You are electing to use spider urls and you can not use relative urls for images.

Tennespeedy
October 29th, 2007, 03:26 PM
make your relative image paths in your header full urls to the images so they can be found. You are electing to use spider urls and you can not use relative urls for images.

I changed it in Admin options. I see what you mean now.

Chuck S
October 29th, 2007, 03:49 PM
Yeah glad that worked if you need anything else let me know.