PDA

View Full Version : New install receiving errors...


Dazz
September 28th, 2007, 03:49 PM
Hey Guys,

I'm doing a new install of Photopost on an existing site running Vb3.6.8 and vbPortal 3.6.4. I receive this error response at step 3 when using the install.php.

Step 3: MySQL error reported: [CREATE TABLE pp_board ( msgid int(12) NOT NULL auto_increment, replyto int(12) NOT NULL default '0', userid int(12) NOT NULL default '0', category int(4) NOT NULL default '0', date int(15) NOT NULL default '0', subject varchar(250) default NULL, message mediumtext, replies int(6) NOT NULL default '0', views int(7) NOT NULL default '0', lastmsg int(12) NOT NULL default '0', lastdate int(15) NOT NULL default '0', lastuser int(12) NOT NULL default '0', lastusername varchar(32) default NULL, ipaddr varchar(15) default NULL, updated int(16) NOT NULL default '0', updateuser int(12) NOT NULL default '0', PRIMARY KEY (msgid), KEY date (date) ) ENGINE=MyISAM]
Result: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ENGINE=MyISAM' at line 19
Database: database name removed..

It allows me to continue installing, but I get the following errors:

Warning: main(mainfile.php): failed to open stream: No such file or directory in /home/dazz/domains/dfwhauntedhouses.com/public_html/photopost/header-inc.php on line 296

Warning: main(mainfile.php): failed to open stream: No such file or directory in /home/dazz/domains/dfwhauntedhouses.com/public_html/photopost/header-inc.php on line 296

Fatal error: main(): Failed opening required 'mainfile.php' (include_path='.:/usr/local/lib/php') in /home/dazz/domains/dfwhauntedhouses.com/public_html/photopost/header-inc.php on line 296

I know that I'm missing something somewhere, but I just can't find it...

Any suggestions?

Chuck S
September 28th, 2007, 07:51 PM
mainfile?? Are you trying to integrate with vbportal 2 or vbulletin 2??

Seems to me on last step of install you are selecting the wrong integration. Try just filling in the paths and urls and turning on the vb3 switches only.

Dazz
September 29th, 2007, 11:16 AM
mainfile?? Are you trying to integrate with vbportal 2 or vbulletin 2??

Seems to me on last step of install you are selecting the wrong integration. Try just filling in the paths and urls and turning on the vb3 switches only.Hmmmm.... Yeah, I had the switch for vbPortal 2 turned on. Is there not vbPortal3 support in Photopost 6?

Chuck S
September 29th, 2007, 11:20 AM
Yes its automatic just use the vb3 boxes ;)

http://www.reeftalk.com/gallery

Dazz
September 29th, 2007, 12:00 PM
Yes its automatic just use the vb3 boxes ;)

http://www.reeftalk.com/galleryThanks for the help. It's working now and I am able to upload and view images. Just a couple more questions...

I'm still trying to figure out what's up with this error. I got it during install, but it allowed me to continue the install.

Step 3: MySQL error reported: [CREATE TABLE pp_board ( msgid int(12) NOT NULL auto_increment, replyto int(12) NOT NULL default '0', userid int(12) NOT NULL default '0', category int(4) NOT NULL default '0', date int(15) NOT NULL default '0', subject varchar(250) default NULL, message mediumtext, replies int(6) NOT NULL default '0', views int(7) NOT NULL default '0', lastmsg int(12) NOT NULL default '0', lastdate int(15) NOT NULL default '0', lastuser int(12) NOT NULL default '0', lastusername varchar(32) default NULL, ipaddr varchar(15) default NULL, updated int(16) NOT NULL default '0', updateuser int(12) NOT NULL default '0', PRIMARY KEY (msgid), KEY date (date) ) ENGINE=MyISAM]
Result: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ENGINE=MyISAM' at line 19
Database: database name removed..

Also, I just noticed that in PP admin if I click on "Manage Albums" the page that appears is blank and just says "PhotoPost Personal Album Editor" at the top. Does the above error have anything to do with that?

Chuck S
September 29th, 2007, 12:14 PM
Your install would appear fine I am glad.

Your manage albums is suppose to be blank until such time as you or users create personal albums.