PDA

View Full Version : Blank page when transfering photospark from one server to another


DesmondSweeney
August 23rd, 2007, 03:28 PM
Hello,

We recently upgraded our server, and are in the process of transferring the data from one server to another.

We have photopost installed at a couple URL's. Our transfer procedure was basically as follows:

1) tar.gz entire directory structure
2) mysqldump appropriate databases and zip
3) transfer directory backup + mysql backup to the new server
4) extract everything, set up virtual servers in apache, etc
5) import mysql data using mysql --user --password database < mysql.sql

2 of our photopost installations came over without issue. The third did not.

If I install photospark from scratch (Clean install), and bring over the database tables one by one, I can see the photos until I bring over the category table. At that point, photopost does not load -- it just dispalys the site header (vbulletin integration), but nothing from photopost at all.

What i've done to debug this further is took a phpmyadmin export of just the categories table, and imported it bit by bit. At first it was working, then the same result. So i cleared the categories table and started the import with the offending records ... and photospark successfully loaded! So I don't think it's just one category problem ... but maybe it is.

Does this spark any ideas with any of the developers? I don't even know where to start debugging this, but i'm willing to try.

Please post any suggestions / comments / questions.

I can provide any files upon request.

Thanks!
Desmond.

Chuck S
August 23rd, 2007, 08:35 PM
I think this thread will help you most likely a path issue in the config files

http://www.photopost.com/forum/showthread.php?t=130048

DesmondSweeney
August 24th, 2007, 09:43 AM
Hello,

I have double-checked my paths in both config-inc.php and config-int.php, they are correct.

A little more info:

1) if I delete all PhotoPost tables from the new server, and then import a mysqldump of all tables from the old server, when I visit our gallery, I get a blank page (page source is 100% blank)

2) If after #1, I empty the pp_cache table, I see our site header, but NOTHING from photopost (you can see that here: http://www.scrapbookmax.com/gallery/)

3) Even with some incorrect paths in the config-inc.php and config-int.php files on our old server, the gallery still works, without styles (Exact same database and files) -- you can see that here: http://207.97.199.221/gallery/

4) I have set the appropriate permissions on the new server in /gallery/

5) Just to reiterate from above, with nothing in the pp_categories table, the gallery on the new server works great. As I bring in a few rows at a time into the category table, the gallery continues to work, and then eventually fails as seein in #2 above. However, if I then import rows starting a few before the problem row, the gallery works again, to a point, then fails in #2.

I'm at a complete loss here -- is there a way to debug this? Any suggestions beyond checking paths? Please help -- i'm pulling my hair out here!

Desmond.

Chuck S
August 24th, 2007, 11:18 AM
You need to check everything in the thread listed.

Database settings in config all the way through paths down the list.

DesmondSweeney
August 24th, 2007, 11:52 AM
Hello,

I have now verified all settings in that whole list are corect -- twice. Cound you please assist me in debugging what's going on, or offer suggestions of things to try beyond initial configuration issues?

I am willing to provide you any information that you need.

Our two servers are set up with the exact same folder structure, so pathing shouldn't be a problem anyways.

Thanks,
Desmond.

Chuck S
August 24th, 2007, 11:59 AM
If you want us to hands on come to your server and fix Photopost so it runs on the new server you would need to purchase an installation. I am prevented from performing installations without a contract purchased.

Installation issues we offer support through email or forum support. We would state what we think the issue is for you to fix this. Does anything work on the moved copy admin? Reason I say is if there is a way I can assist without physically going into your server and performing a service you need to purchase I will assist you.

DesmondSweeney
August 24th, 2007, 12:04 PM
I really appreciate that.

Yes, I can get into the admin panel just fine (After clearing out the pp_cache table -- does that tell you anything?)

As I say, the table pp_categories, when full of our old data, seems to be causing the problem (when i empty that table, photopost displays ... without categories obviously).

I tried to PM you the login details ... is there a way I can get you that info without posting here?

Also -- what does the installation cost? That is an option we may want to explore.

Desmond.

Chuck S
August 24th, 2007, 12:47 PM
59.00 for an install

You can email support@photopost.com admin login

No the cache does not tell me anything

DesmondSweeney
August 24th, 2007, 12:51 PM
Does that $59 include getting our previous server's data up and running (so on the new server the gallery will work as it did on the old server, with all images, etc loaded)?

I've emailed you our login details.

Desmond.

Chuck S
August 24th, 2007, 01:04 PM
it will get the application up and running on the new server. You will have to have transferred the database and files

DesmondSweeney
August 24th, 2007, 01:10 PM
Do you have any type of installation option we could purchase where you would transfer the data?

I can install this from scratch on our server -- that's no problme. I just can't get it up and running wiht our existing data.

Desmond.

DesmondSweeney
August 24th, 2007, 02:06 PM
Hello,

This has been solved. The problem was that our php.ini's allowed memory limit was set to 8MB. I had requested that our host transfer all our PHP settings from our old server to our new server, which they confirmed they had done.

Our host apologized for the mixup, stating they should have caught that in the beginning since it is one of the first things that should be checked when a script fails like this.

Perhaps you could add "check your PHP memory limit" to your list of typical errors, along with the pathing issues you mentioned above.

Thanks for your willingness to help, it is appreciated.

Desmond.

Chuck S
August 24th, 2007, 03:21 PM
Yes memory issues can be an issue but are nowhere near the first thing to check on a server move thats always paths