PDA

View Full Version : Upgrade Advice


benalembick
August 7th, 2007, 09:09 AM
Hi,

Im trying to upgrade my photopost from 4.7 - latest. However i cant find any information on how to go about it.

I have backed up my previous gallery folder and uploaded the new gallery folder and have ammended the config files, also i have run the upgrade.php script (found problems getting past step 1, but fixed it by placing $skip_exheader="yes"; at the top of the file.

After id done this i had none of the old images being displayed

I would appreciate any help,

Thanks in advance

Chuck S
August 7th, 2007, 09:18 AM
The files upgrade.txt and changlog.txt should assist you and have current accurate upgrade instructions

I would suspect you are not running step 4.85 only once but then again one can not be sure unless you place a link here to see what you get

benalembick
August 7th, 2007, 09:25 AM
Cheers, probably being stupid but where are the two files you mention?

Chuck S
August 7th, 2007, 09:28 AM
In the documentations folder of the download. Changelog has up to date file changes etc

benalembick
August 7th, 2007, 09:38 AM
Sorry was stupid, didnt see that folder. Think its all working now i tried again. the upgrade scripts final stage was "Move DATA directory files (you only do this only once successfully)" ive manually copied my old data folder over (replacing the new one, is this ok (where does the script look for my old data folder if i was to do it using the script)??

cheers for your help

Ben

benalembick
August 7th, 2007, 09:47 AM
arghh, sorry just found a problem when viewing a photo

We're sorry, but the system experienced an unrecoverable error. Please try again later.

Script:

Query: SELECT id,user,userid,cat,storecat,storeid,date,title,description,keywords,bigimage,width,height,filesize,views,medwidth,medheight,medsize,approved,rating,extra1,extra2,extra3,extra4,extra5,extra6,disporder,ipaddress,allowprint,allowrate,allowcoms FROM photos WHERE id=65

Result: Unknown column 'allowrate' in 'field list'

Database handle: Resource id #23

Any idea??

Chuck S
August 7th, 2007, 10:22 AM
You have not ran all the required upgrades it looks like to me

benalembick
August 7th, 2007, 10:48 AM
i think your right, ive managed to add the collumns allowrate, allowcoms manually to the db, which seems to have fixed it but like you say i dont think all updates were completed so im concerned there are other things that havent been completed.

I have run the upgrade.php script and have reached the stage that starts by saying "Preparing to update 4.8.5 database..." this page displays each step as an Error: Duplicate column name.

this stage ends by saying "Move DATA directory files (you only do this only once successfully) --> or quit here.
Moving data files can take some time depending on your installation; 10,000 files could take 5 minutes or more. Please be patient."

I havent clicked on this as i have moved the data directory manually. should i click this (also "you only do this only once successfully" doesnt make sense)

What would you recomend i do next?

the upgrade.txt file says

4) When done with upgrades, remove the upgrade.php file.

6) You are done!

so i assume i have done everything?

Thanks for your time and patience

Ben

benalembick
August 7th, 2007, 11:13 AM
ok think i have worked it out i needed to go back to the main upgrade screen and start from the next version.

Now i dont mean to be rude but this is not clearly mentioned anywhere, so i tried just clicking on the "Move DATA directory files (you only do this only once successfully)" link which seemed to attempt to move my data files (not sure where from as it doesnt mention anywhere where it looks) anyway this script seems to now have removed all of my images completly and im back at stage one?

All i have now are NO THUMBNAIL images in place of all my images and no medium images.

Any thoughts as to why this happened?

How can i get them back all my images seem to still be in the data directory?

Chuck S
August 7th, 2007, 11:40 AM
YOU CAN NOT DO THINGS MANUALLY. :(

Please read the upgrade and properly run each upgrade you need otherwise your
just going to break your site

benalembick
August 8th, 2007, 03:43 AM
Ok, re did everything and seems to kinda be working now, however when i try and upload a mpg i get an error saying "The file you uploaded was not an acceptable format" ive checked that the mpg file extension is in the settings and it is, i remember running into this problem on a previous install but cant remember what you recomended and cant find it in the forum.

Any suggestions?

Cheers

Ben

Chuck S
August 8th, 2007, 10:27 AM
Yes the upgrade scripts last update is 5.6 so if your last one was move data your issue is an old upgrade hopefully you solved that by running the right upgrade script all the way through once

As far as uploading mutlimedia just set that to yes in admin options. You have not turned on the ability to upload multimedia or mpg is not in the allowable multimedia extentions