PDA

View Full Version : Sorry but a "Poor Installation Guide for PhotoPost"


Bills
January 28th, 2007, 03:46 AM
Questions which are not answered or discussed in the installation manual.

1) In the "Installation Guide" or say a single page no-one bothered to write a line saying that one must change

config-inc.php.NEW to config-inc.php "FIRST"

2) Installation Guide says:

" If you're using PhotoPost with an existing forum, you can either use the MySQL database that you're presently using for your forum for both PhotoPost and your forum, or you can create a separate database for PhotoPost (in either case, your forum user database will still be used by PhotoPost). ... "

Now nowhere it gives an instruction on the "Step 1: PhotoPost Configuration Verification" Installation page that if one want to use a single database for vBulletin and Photopost what is one supposed to write or do with an example. Like are we supposed to leave :

PhotoPost Database Host
PhotoPost Database Name
PhotoPost Database User
PhotoPost Database Password

** BLANK **

and only feed the information in

User Database Name
User Database User
User Database Password


3) STEP THREE OF INSTALLATION IS GIVING TONS OF ERROR LIKE :--

Step 3: MySQL error reported: [INSERT INTO pp_categories (id,catname,description,catorder,thumbs,parent,children) VALUES (1,'Main','',2,'no',0,'2')]
Result: Duplicate entry '1' for key 1
Database: c4acgp07

Step 3: MySQL error reported: [INSERT INTO pp_categories (id,catname,description,catorder,thumbs,parent,children) VALUES (2,'A Category','Photos of a particular subject',1,'yes',1,'')]
Result: Duplicate entry '2' for key 1
Database: c4acgp07

.........


DUE TO MAYBE SOME SMALL REASON BUT "NOWHERE ONE CAN FIND IT'S REASON OR SOLUTION IN THE INSTALLATION GUIDE.


4) Same is the case with "Step 4" of the installation, there is absolutely NO information "step by step information explainging the things to the user and let him go ahead himself on that.


In all no matter one will be complete with the installation after a couple of days but "if" the "Installation Guide" would have been simple and user friendly the customers or users of PhotoPost will get a reason to smile.

thanks

Bills
January 28th, 2007, 04:21 AM
No taker's for this one from the support or Mod. team ?

Chuck S
January 28th, 2007, 10:26 AM
1) In the "Installation Guide" or say a single page no-one bothered to write a line saying that one must change

config-inc.php.NEW to config-inc.php "FIRST"


I can pass that along to be added


2) Installation Guide says:

" If you're using PhotoPost with an existing forum, you can either use the MySQL database that you're presently using for your forum for both PhotoPost and your forum, or you can create a separate database for PhotoPost (in either case, your forum user database will still be used by PhotoPost). ... "

Now nowhere it gives an instruction on the "Step 1: PhotoPost Configuration Verification" Installation page that if one want to use a single database for vBulletin and Photopost what is one supposed to write or do with an example. Like are we supposed to leave :



Of course it does. I think this is very clear do you not?


If you're using PhotoPost with an existing forum, you can either use the MySQL database that you're presently using for your forum for both PhotoPost and your forum, or you can create a separate database for PhotoPost


on the config screen of install outside of the install doc is this which is pretty specific


User Database Host (enter same info as above if not integrating with a third party forum)



If you have constructive ideas then please post them.


3) STEP THREE OF INSTALLATION IS GIVING TONS OF ERROR LIKE :--


You ran install twice or more and this is why you get DUPLICATE ERRORS cause the database and inserts already exist.


4) Same is the case with "Step 4" of the installation, there is absolutely NO information "step by step information explainging the things to the user and let him go ahead himself on that.


Please explain what you think is unclear on this step as things are very spelled out and explained or straight forward that require no explanation.

Please also give time for someone to post a reply to your thread. You bumped this thread after 30 mins in the middle of the night when everyone is asleep and on a weekend at that.

Bills
January 29th, 2007, 01:54 AM
thanks for your reply Chuck S, no matter I am able to almost install it myself by going from piller to post but I have learnt few things in the process.


MUST TAKE CARE WHEN INSTALLING PHOTOPOST:
================================

1) Change the file extension of

config-inc.php.NEW
config-int.php.NEW

to

config-inc.php
config-int.php

respectively.


2) In "Step 1: PhotoPost Configuration Verification"

Path to PhotoPost Installation (must be set properly for script to work)

While specifying this path one must take care that the "/" "\" makes a lot of difference and result in giving an error something like:

Unable to create/write to c:\****\****\****\gallery/data! Check your data directory permissions before continuing.

Note: "*" indicates the actual path you fed in "Step 1: PhotoPost Configuration Verification" for "Path to PhotoPost Installation (must be set properly for script to work)"

here no matter all the permissions to the directories/files are set right but since "\" was used instead of "/" the said error occured.


THIS WAY I CAN GO ON AND ON MAKING THE THINGS FOR THE INSTALLATION MORE SIMPLE FOR A COMMON MAN.

When hunting for my solution in the forum I found many people struggling for the same/similar small answers.

=========================

Please also give time for someone to post a reply to your thread. You bumped this thread after 30 mins in the middle of the night when everyone is asleep and on a weekend at that.

I bumped because I was hunting for the answer and I have seen you online then (but still sorry, I was not supposed to be in a hurry)

... in the middle of the night when everyone is asleep and on a weekend at that ..

Pl. mind you guys are cetering to the world "aren't you" and no matter it's your sleep time but some one across the world is getting ready for a lunch. (by the way I am travelling)

Chuck S
January 29th, 2007, 11:02 AM
I bumped because I was hunting for the answer and I have seen you online then (but still sorry, I was not supposed to be in a hurry)



I can guarantee I was not online at 420 am ;)' That time of night I am snuggled all up in bed.

Anway the one issue I passed along and the other issue I think I can pass along a code edit to simply replace the path \ with a / so the customer on windows isnt confused about paths.

I think in install.php this will do the trick the line in bold


$Globals['PP_PATH'] = getcwd();
$Globals['PP_PATH'] = str_replace("\", "/", $Globals['PP_PATH']);
$Globals['TMPL_PATH'] = "templates";

Bills
January 29th, 2007, 11:54 AM
Thanks for the reply Chuck S, anyways now the problems are solved and I am all set to use this beautiful piece of software.

Chuck S
January 29th, 2007, 01:05 PM
Okay enjoy