PDA

View Full Version : Problems with Upload after upgrading to IIS 6 and W3K server


dapaw
October 27th, 2006, 10:36 AM
hello,
Can anyone help me with a problem with uploading images to my photopost.
I suspect that this problem occured when I upgraded the operating system to W3k from W2k server. Has anyone encountered this problem before? The error message is shown below:

Warning: Unable to create '/production/photopost/uploads/136/Sample.jpg': Permission denied in W:\production\photopost\image-inc.php on line 34

Warning: Unable to move 'C:\PHP\uploadtemp\php8DE1.tmp' to '/__production/photopost/uploads/136/Sample.jpg' in w:\__production\photopost\image-inc.php on line 34

If the problem is permission issues, where should I go to make changes to fix this problem?:mad:

Chuck S
October 27th, 2006, 11:55 AM
Well usually yes this would be permissions although I see one thing that catch's my attention. What are you uploads path set to in admin global options as your error is looking like the w: is not there. You uploads path should be

W:/production/photopost/uploads

and if so then you need to set permissions on a windows server this is usually done by right clicking the folder and there should be a permissions tab. You need to ensure IWAM anD IUSER accounts are under there and basically everyone needs to be set on your uploads and data folders to READ WRITE EXECUTE

dapaw
October 28th, 2006, 10:26 AM
Thanks for your help Chuck. The suggestions led to newer error messages. I hope I am getting somewhere on this issue.

The error message is below:

Warning: Unable to create 'W:/__production/Photopost/data/500/197davids-thumb.jpg': Permission denied in

w:\__production\photopost\image-inc.php on line 224

Warning: Unable to fork ["w:\ImageMagick-5.5.1-Q16\mogrify.exe" -size 100x67 -quality 70 -geometry 100x67

W:/__production/Photopost/data/500/197davids-thumb.jpg] in w:\__production\photopost\image-inc.php on line 58

the opening Message
Error creating thumbnail! Error code: -1

Command:

"w:\ImageMagick-5.5.1-Q16\mogrify.exe" -size 100x67 -quality 70 -geometry 100x67

W:/__production/Photopost/data/500/197davids-thumb.jpg

dapaw
October 28th, 2006, 11:40 AM
I am down to the error below after resetting permissions on files and folders in the data and upload folders.:

Warning: Unable to fork ["e:\ImageMagick-5.5.1-Q16\mogrify.exe" -size 100x67 -quality 70 -geometry 100x67 E:/__production/Photopost/data/500/197davids-thumb.jpg] in e:\__production\photopost\image-inc.php on line 58

the opening Message
Error creating thumbnail! Error code: -1

Command:

"e:\ImageMagick-5.5.1-Q16\mogrify.exe" -size 100x67 -quality 70 -geometry 100x67 E:/__production/Photopost/data/500/197davids-thumb.jpg

Chuck S
October 29th, 2006, 12:52 AM
Okay well your permissions are easy just recheck those also see if using gd2 solves the permissions issue

One thing concerns me though is what is that __ in your path? Where are you putting that you need to remove that and make sure you have the correct path

dapaw
November 6th, 2006, 12:10 PM
Chuck and others,
We have partial solution to this problem and would like your suggestion on one last issue:

Some users can upload photos after we copied "cmd.exe" from system 32 into the C:\php folder and granted appropriate permissions such as IUsr/IWAM read, execute, and write.

A few still get the original error:

Warning: Unable to create '/production/photopost/uploads/136/Sample.jpg': Permission denied in W:\production\photopost\image-inc.php on line 34

Warning: Unable to move 'C:\PHP\uploadtemp\php8DE1.tmp' to '/__production/photopost/uploads/136/Sample.jpg' in w:\__production\photopost\image-inc.php on line 34

Should we delete their accounts and recreate or try to troubleshoot by another means. We have compared these accounts and the ones that work and we cannot tell the difference.

Note: Another hint is that all the user accounts work on the same photopost program installed on Windows 2000 Server and IIS 5.

The full solution:
If you get an error like:

Warning: exec(): Unable to fork [C:\ImageMagick\convert.exe -size 50x50.....

This is a windows-related issue and has nothing to do with yappa-ng but with the permission settings on your webserver!

There may be an easy way out for you (thanks to Jesper Rudbeck, who sent me this hint):
"We had lotso fun with "unable to fork" errors. It turned out to be a permissions problem. Y ou must give RX permission on "\winnt\system32\cmd.exe" to the user account that your web server runs as (e.g. IUSR_xxx on IIS, LocalSystem on Apache).
Turning on a Win2000 user right called "Bypass traverse checking" also solved a related problem but I forget what or why."

Another solution has been submitted by swbadn (Thanks):
"I copied cmd.exe into the c:\php folder and that seems to work as well. I set the permissions to read and execute only. This keeps from having to give anonymous access to C:\winnt\system32\cmd.exe where all of those nasty IIS scripts always seem to attack and I think is a little more secure than having to give access to the cmd.exe in the C:\winnt\system32 directory."

I personaly copied cmd.exe into my PHP folder and it worked!

Chuck S
November 6th, 2006, 04:29 PM
cmd.exe should always exist in system32 directory as thats a windows file not a php source file so I dont know why yours was in a PHP directory

If you grant IWAM AND IUSER permissions on the uploads and data directories to read write execute that is the equivelent of the instructions on our install that state they need to be 777

arabartrois
November 7th, 2006, 11:25 AM
i am working with dapaw on our photopost installation and wanted to jump into the discussion here.

just to clarify, we copied cmd.exe into the php directory at the suggestion of someone else (why, i have no idea) and it actually fixed the problem we were having with image magick. the "unable to fork" error went away, so we are no longer worried about that problem.

we are now experiencing something very odd: some users can log in and upload images with no problem. others get the following error when they try to upload an image:

Warning: Unable to create 'e:/__production/photopost/uploads/136/OmgWtfRofl.jpg': Permission denied in e:\__production\photopost\image-inc.php on line 34

Warning: Unable to move 'C:\PHP\uploadtemp\php5CA8.tmp' to 'e:/__production/photopost/uploads/136/OmgWtfRofl.jpg' in e:\__production\photopost\image-inc.php on line 34

Unable to move file [C:\PHP\uploadtemp\php5CA8.tmp] [e:/__production/photopost/uploads/136/OmgWtfRofl.jpg]

same client machine, same jpeg image. the only difference is the user who is logged into photopost.

i took your advice and triple checked that the IWAM and IUSR accounts indeed have RWX permissions on the data and uploads folders and all subfolders.

can you think of any reason why a photopost image upload would work for some users and not others? i have compared user records in the DB and have found no discernable differences. any ideas would be greatly appreciated...

thanks!

Chuck S
November 7th, 2006, 12:20 PM
No I have no ideas there one person should work like all others

Basically your file is not being allowed to be moved to the uploads directory so based on that error it says uploads permissions are not correct on all the directories there