PDA

View Full Version : New Server Created Problems


tvcrazyman
September 28th, 2006, 04:44 PM
Moved to another server. New server had php 5.1.6 and MySQL 5.0.24-standard-log. After that only thumbnails could be seen unless I turned off the search engine friendly urls option in photopost.

Best guess it's not compatible with the higher php as even my Drupal script stopped working.

Any ideas on this one?

Chuck S
September 28th, 2006, 05:19 PM
well AcceptPathInfo On is what needs to be added to your apache setup file httpd.conf

tvcrazyman
September 28th, 2006, 06:39 PM
You lost me chuck. Sounds like something that someone would do that has a dedicated server.

I had my webhost move me back to the old server with php 4.

Can you tell me if there will be future upgrades to photopost to make it compatible with the newer servers with php 5, etc? I'm a little worried that I'm going to spend hours upon hours uploading images to my galleries and then come to find out my webhost upgrades everything on me, and I wouldn't be able to figure out how to fix the issues the upgrade would cause.

Chuck S
September 28th, 2006, 07:06 PM
This issue has nothing to do with Photopost

Yes the issue is the server and that in its apache setup it needs to allow the pathinfo to be passed.

In Apache 1 this would need to be in the httpd.conf file

AllowPathInfo On

In Apache 2 this would need to be in the httpd.conf file

AcceptPathInfo On

tvcrazyman
September 28th, 2006, 07:24 PM
So Chuck how would a fellow get hold of this httpd.conf file? If this is a server configuration file I don't think I could get my hands on it since I'm on a shared webhost account. I'm using Bluehost which is pretty decent. I've got a pretty good control panel and what not, but I'm not familiar with this file your talking about.

Please forgive my ignorance of this. I don't consider myself a computer genius , but I'm not a stranger to website development. This is basically all I do. Still always learning new things though.

So could you be a little more specific?

thanks

Chuck S
September 28th, 2006, 08:19 PM
If you do not have a virtual dedicated server or dedicated server all you can do is as and see if your host can add that otherwise you simply can not use spider urls

tvcrazyman
September 29th, 2006, 10:56 AM
Ok so that answers that question, but I had my webhost move my site back to the old server and it started working again.

So here's my next question has photopost been tested on the latest php 5 releases to see if there are any problems?

I feel there might be just due to the fact that even Drupal acts up with php 5. I've got to know because I have to plan for the future.

Also need to point out, You can't just turn off the search engine friendly urls if you've been using them for a while without losing a lot of traffic from Google. That would just really hurt a site bad.

Chuck S
September 29th, 2006, 11:00 AM
I run Photopost on PHP 5 with spider urls no problem

This issue as posted has nothing to do with Photopost but that server setup. To use the spider urls it must allow path info. The new server did not

tvcrazyman
September 29th, 2006, 12:15 PM
Good to know you've got it working on php 5.

Apart from calling the webhost would there be a way to tell if the server has this problem with it's setup?

I called my webhost like 20 times yesterday, and I dread even calling to ask questions. I've got another site with them on one of their newer servers I could test with. I just need to make sure that when the time comes I can get this working with their newer servers one way or the other.

Chuck S
September 29th, 2006, 01:17 PM
I beleive I was clear on how this works it has nothing to do with really PHP or Photopost.

http://www.photopost.com/forum/showpost.php?p=1173436&postcount=4

tvcrazyman
September 29th, 2006, 02:22 PM
I understand that Chuck, I was just asking to see if I could get as much info on this server thing as I could. I plan on using the same webhost in the future so I wanted to get a little more info if possible.

If that's all you know, no problem thanks anyway.

Chuck S
September 29th, 2006, 04:05 PM
My post I keep going back to post 4 has all the information you need to know on this issue