PDA

View Full Version : Fatal error uploading photos.


neoutdoorsman
July 1st, 2006, 05:21 PM
Hi folks. I've done some searching and I can't seem to resolve my problem, so I'm asking for a little help here. When I (and several people using my site as well) try and upload pictures I get a:

"Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 4668 bytes) in /home/neoutdoorsman/photopost/image-inc.php on line 81"

I'm running 4.6.6 . Yes, I know this is an old version, but there is no way I can afford an upgrade right now. I had been running error free for 2 years and now this. I had not changed anything prior to getting this error, so I'm not sure what the problem is. Is there a bug in the original program? What can I do to fix this?

I'm using GD2 for a thumbnail generator. I tried GD1 and it worked for a few photos and then I go the same error. I'd like to keep using GD2 since I like what it does and it worked well for 2 years. I do not want to use ImageMagick.

Any help would be great. If you could "dumb it down" for me I'd appreciate it since I'm not a programmer.

Thanks.

Bob

Chuck S
July 1st, 2006, 07:18 PM
You can edit pp-inc.php and place the ini_set line noted in this thread at the top of the file

http://www.photopost.com/forum/showpost.php?p=1152669&postcount=1

neoutdoorsman
July 1st, 2006, 07:35 PM
Thanks Chuck...It worked like a charm.