PDA

View Full Version : IIS & CGI Errors


hob
May 31st, 2006, 06:24 PM
Anyone else managed to cure the CGI errors during upload on a windows box?
very weired it is only on some of my photos, its documented as a php bug (occurs when redirected to another php page) but no cure, anyone found a soluition?

php thread:

http://bugs.php.net/bug.php?id=9852

Chuck S
May 31st, 2006, 08:48 PM
In Admin => Global Options make sure you do not have the path to jpegtran filled out

hob
June 6th, 2006, 08:37 AM
In Admin => Global Options make sure you do not have the path to jpegtran filled out


I dont :( now I get the error everytime (although the file uploads)

hob
June 6th, 2006, 08:41 AM
oooo may have fixed it had "display exif" function but nothing specified in file location so disabled exif and it appears to work :)

hob
June 6th, 2006, 09:00 AM
ok now found a different cause, when uploading (~2mb) I think its a timeout that causes the error (my default limit is 500kb) I tried uploading a 2mb file (which is too big for the limit) and got the error :(

Chuck S
June 6th, 2006, 09:53 AM
Yep your PHP is limited to 2mb uploads unless you change it and if its limited to 500kb then most likely your host has LimitBodyRequest variable set to 500kb and that would need to be raised too in the php.conf or apache configuration.

hob
June 6th, 2006, 10:00 AM
Yep your PHP is limited to 2mb uploads unless you change it and if its limited to 500kb then most likely your host has LimitBodyRequest variable set to 500kb and that would need to be raised too in the php.conf or apache configuration.

I am now getting these errors:

Warning: getimagesize(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/11.jpg): failed to open stream: No such file or directory in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\image-inc.php on line 214

Warning: copy(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/11.jpg): failed to open stream: No such file or directory in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\image-inc.php on line 241

Warning: getimagesize(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/21.jpg): failed to open stream: No such file or directory in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\image-inc.php on line 214

Warning: copy(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/21.jpg): failed to open stream: No such file or directory in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\image-inc.php on line 241

Warning: unlink(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/3.jpg): Permission denied in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\bulkupload.php on line 512

Warning: unlink(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/360.jpg): Permission denied in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\bulkupload.php on line 512

Warning: unlink(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/4.JPG): Permission denied in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\bulkupload.php on line 512

Warning: getimagesize(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/a11.jpg): failed to open stream: No such file or directory in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\image-inc.php on line 214

Warning: copy(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/a11.jpg): failed to open stream: No such file or directory in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\image-inc.php on line 241

Warning: unlink(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/bonnet.jpg): Permission denied in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\bulkupload.php on line 512

Warning: unlink(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/dolton1.jpg): Permission denied in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\bulkupload.php on line 512

Warning: unlink(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/gt1.jpg): Permission denied in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\bulkupload.php on line 512

Warning: unlink(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/psu.jpg): Permission denied in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\bulkupload.php on line 518

Warning: unlink(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/vw1.jpg): Permission denied in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\bulkupload.php on line 518

Warning: unlink(D:/Inetpub/vhosts/themgzr.co.uk/httpdocs/gallery/uploads/8/woosh.jpg): Permission denied in D:\Inetpub\vhosts\themgzr.co.uk\httpdocs\gallery\bulkupload.php on line 518

Chuck S
June 6th, 2006, 10:10 AM
Make sure that the uploads and data paths on your photopost install are set to READ WRITE EXECUTE.

hob
June 6th, 2006, 10:16 AM
hahaha I fixed it.... it all (i ticked modify option under IIS6) and it fixed it all :D

hob
June 6th, 2006, 10:17 AM
p.s chuck I have heard nothing via email about the extra stuff I wanted doing, did you get my last email?