PDA

View Full Version : Getting logged out going from PP to VBulletin


priapis
May 24th, 2006, 01:38 PM
I'll put all the issues here in one place I guess.
I'm using integrated approach, with login from vB. For now I'm getting this problem when I log into PP admin panel -> back to user index -> user index -> user CP (from the vB menu bar carried tru)

when I get to vB, I get the "you are not logged in" scree.

settings:

cookie path /

cookie prefix bb

cookie domain .yyy.com

same problem.

also, the domain.com is one of several paths to my forum, if that makes any difference.

so
www.xxx.com same as
www.yyy.com/forums same as
www.zzz.com/forums

the photopost folder would be at:
--not applicale -- www.xxx.com =
www.yyy.com/photopost =
www.zzz.com/photopost


Does the PP folder need to be a subfolder within the same forums directory that vB is at perhaps ??


thoughts?

priapis
May 24th, 2006, 03:29 PM
edit............

priapis
May 24th, 2006, 04:17 PM
made some changes to original post

Chuck S
May 24th, 2006, 05:30 PM
Photopost only runs on one domain name.

Therefore your only going to have an integrated login going from

http://www.com/forum

http://www.com/gallery

going to say

http://xxx.com/forum

is not going to work as cookies are only carried by domain name.

priapis
May 24th, 2006, 06:48 PM
so if I have www.mysite.com pointing directly to the forums directory where vB is located, where should the photopost folder be?

assuming above, can the photopost folder be a subdirectory of the forums directory above where vB lives?

iow, can photopost be at www.mysite.com/photopost if my vB site is at www.mysite.com?

here's how it is now, and everything I've tried I still get logged out going to vB links.

http://img.villagephotos.com/p/2005-7/1042828/PPstruct.jpg

Chuck S
May 24th, 2006, 08:46 PM
Yes you can not install on two different domains and have cookies work. Cookies work on one domain so you need to reinstall the photopost application on your forum domain and your login will work.