View Full Version : file names only

April 8th, 2006, 12:25 PM
for aome unknown reason, my gallery now only shows the file names of the pictures. has anyone experienced this before?




April 8th, 2006, 01:23 PM
question. does filepath in the pp_photos need to have something in it? i am running 5.3

Chuck S
April 8th, 2006, 02:00 PM
You need to have the data path filled out correctly in the Admin => Global Options and then save and in Storage Options make sure it picks up the right path

April 8th, 2006, 07:33 PM
here is the latest ...

All paths are valid. No question about it!
I have done a chmod -R 777 on the data and upload dirs
When you load the gallery, it loads the filename as described instead of the photo. However, if you right click on the file name you get the properties and it shows the valid path to the file.

here is where it gets tricky.
If you cut and paste the url from the image properties you get an apache forbiden message.

here is a sample:


I go into the dirs and the file is there. Any suggestions?



April 8th, 2006, 09:21 PM
in case anyone has the same problem, here was my solution.


Options Indexes Includes FollowSymLinks

my data dir are symbolic links.

Chuck S
April 9th, 2006, 09:44 AM
So your path was incorrect.

Symbolic link is just that a symbolic link it is not the true path.

April 10th, 2006, 10:34 AM
Actually the path and symbolic link were correct and working before . The problem was that apache directive to allow symbolic links was turned off. However the real question is how did that directive get changed? I didnt do it.