PDA

View Full Version : Navbar problem


poongamer
March 22nd, 2006, 11:36 PM
I just bought PhotoPost and integrated with vb 3.5.4 - when Im not logged in all is fine but if i log in then most of my navigation bar disappears.

anyone have any suggestions?

Chuck S
March 23rd, 2006, 05:26 AM
How about a url and test user login to your site so we can see what your talking about here.

Your vb navbar disappearing would have nothing to do with Photopost so let's be sure what your talking about here.

poongamer
March 23rd, 2006, 09:04 AM
http://www.rustysoaptraders.com/Photopost/?styleid=22

testuser/testuser

You will notice when you go as guest the whole navbar is there - when you login it is gone - this is the only page this happens on...I just noticed that all variables are missing in the navbar - May because I installed this outside the forums directory - maybe I should have installed it under /forums/Photopost instead of /Photopost.....but again problems are only there with the Photopost pages.

Chuck S
March 23rd, 2006, 09:30 AM
Okay this issue is one with some hack you have installed with VB and not Photopost itself. Photopost is not going to pick up variables of a hack by default unless the hack is modified to work with photopost and notice when you are logged out the information is not present in photopost it is all blank.

Some hacks will only display information present on the vbulletin forum thus there are probally parts of this hack that only work anywhere else. Case in point this hack only displays on the vbulletin forumhome page as it is designed to which is why you get an empty bar.

poongamer
March 23rd, 2006, 09:52 AM
So this program integrates with vbulletin but the main gallery page wont even show a nav bar (variables aside)? Maybe im confused on how this works but I see all these other sites that have the navbar working just fine with the gallery - am i missing something?

this site seems to work fine..

http://www.viperalley.com/gallery/index.php

Chuck S
March 23rd, 2006, 10:00 AM
The gallery definately shows a navbar if there is one to show for the particular style

Your specific style your calling has no navbar info

http://www.rustysoaptraders.com/forums/f172-upcoming-rst-events-amp-product-releases.html

poongamer
March 23rd, 2006, 10:10 AM
since I have added the sidebar for site navigation I have decided I can do without the navbar with the gallery...I there a way to remove the navbar on all the gallery pages in the style im using? It does show up in the link i provided (those buttons are part of the nav bar - just as the ticket text ad is) but i would rather just remove it.

Chuck S
March 23rd, 2006, 11:11 AM
That would all depends on the conditonal code in your navbar for that hack.

You can always remove this in the photopost header-inc.php file to remove the navbar totally


eval('$navbar = "' . fetch_template('navbar') . '";');

poongamer
March 24th, 2006, 03:58 PM
I found a link somewhere that solved my problem and now the full navbar is fully functioning...thanks chuck.