View Full Version : cannot connect to the Users databas

February 27th, 2006, 05:08 PM
I keep getting the following error. Any suggestions?

Warning: mysql_connect(): Access denied for user: 'mysqlfile_phpb1@localhost' (Using password: YES) in /home/mypath/public_html/pictures/install.php on line 1245
I cannot connect to the Users database.

Thank You,

Chuck S
February 27th, 2006, 05:12 PM
Make sure on the initial config you input the proper host user password and database name to connect to the phpbb database.

February 27th, 2006, 05:21 PM
I couldn't remember my password so I added a new user to my MySQL database. Now I'm getting the following error. Thanks, sorry I'm not usually this thick.

Error: Are you certain that your database prefix is set properly?

I cannot see your phpBB2 "groups" table.

The prefix setting adds characters to the front of phpBB2 table names - please doublecheck this.

February 27th, 2006, 05:31 PM
As some additional information that may or may not be helpful.

I have PhotoPost Database Prefix set at pp_ but am using a different MySQL database from my phpbb database.

Chuck S
February 27th, 2006, 05:34 PM
When you install you must put the proper user database info in the user database part on config settings. Then on step 4 you must put the proper mysql table prefix and cookie prefix for phpbb2 after selecting phpbb2 as the one you want to integrate with

normal table prefix for phpbb is phpbb_

normal cookie prefix is phpbb2mysql

February 27th, 2006, 05:48 PM
OK. Crossed that hurdle. Hopefully this will be the last question :)

When I view my main page it has a MySQL error along with the page that looks right, and it will not allow me to log into my admin panel. I just get a blank page with the warning on it.

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/mypath/public_html/pictures/forums/phpbb2.php on line 72

Chuck S
February 27th, 2006, 08:45 PM
You must be running phpbb 2.018 or above so you can upgrade your forum and you'll be fine.

February 27th, 2006, 10:41 PM
Thank you