View Full Version : Photopost & Vbulletin

February 11th, 2006, 03:36 AM
Hey guys.....haven't been on this forum for awhile and I'm a bit confused.

I'm running VBulletin v3.0.6 and PhotoPost PHP 4.8.2. Link to my gallery. (http://www.ozhonda.com/gallery/index.php)

I recently changed servers and ever since them am having problems with on the fly watermarks not working (i just get a red X where the image should be).

So not sure where to make my new thread as things look quite different with people talking about Photopost Pro and Photopost VBGallery!?


Chuck S
February 11th, 2006, 08:27 AM
Open up your watermark.php and place the proper server path to the files as that would have changed on server move.

February 11th, 2006, 08:37 AM
Photopost Pro

Welcome back, come on in and take off ya shoes.


February 11th, 2006, 07:24 PM
Could a moderator please move this thread for me please :)

I've gone through and checked the watermark.php file and confirmed with the host that $srcfilename and $watermark point to the correct locations on the server.

I've also checked teh config-inc.php file and $onthefly is set to '1'.

I've clicked on the PNG file and that loads up fine too (i've been using it before as the watermark with no problems.

Could it be a problem with GD? Soon as I disable on the fly watermarks the image loads up fine. However with watermarks enabled it seems to load up the image placehold in my browser....and then just a red "X"

Chuck S
February 11th, 2006, 07:29 PM
$srcfilename needs to be a path and $watermark a url to the image if I am not mistaken on that old version.

I would suggest upgrading with all the security aspects Photopost 5.x series brings into play.

February 11th, 2006, 07:40 PM
Well my main issue is that I have images in DIY articles that users have done that point to the 'old' watermarked pictures. Will I have to update these links or will they still work?

Chuck S
February 11th, 2006, 11:14 PM
How are your links?

The direct file links definately change between 4 and 5 versions.

February 17th, 2006, 04:03 AM
Just thought i'd update you guys. The host changed the 'register_global' value in php.ini back to 'on' and all is well :)