PDA

View Full Version : photos uploaded but not able to process


hendi
December 12th, 2005, 01:47 PM
i have a user that has uploaded about 10 pictures but he cannot process them. it just sits there with an hour glasss for ten minutes before page finishes, but nothing has happened. i've looked in the admin tool, but i don't know where i, as an admin, can process these for him, or even see what is not processed.

1- can i do this for him

or

2- how can i clear these "uploaded" pictures so we can start with an empty queue?

thanks

allan

rolfw
December 19th, 2005, 11:41 AM
If it is the same problem I had, it is because either the first file is corrupt and preventing the others from loading, or he uploaded an invalid format.

I had to go into the server control panel normally "www.domain.com/cpanel", then file manager find folder with his user number in public_html\photopost\uploads and manually delete one or all of the files. Deleteing the first one may do it.

Not guaranteeing that this is the correct solution, but if he is the only one who is having the problem, then it probably is. You can always download the first file and see if you can upload it to the photopost forum and see if the file is OK.

Chuck S
December 19th, 2005, 11:45 AM
Well later Photopost's delete a file that can not be processed but if your using an older Photopost yes you can go in and manually remove a corrupt file from his uploads directory for him to be able to process again.

However if your allowing alot of uploads make sure the issue he is not having is one of a PHP memory timeout or exhaustion.

I would only recommend allowing that many uploads at once on systems where you have modified your php.ini file to increase the memory_limit from the default 8mb and max_execution_time to 0

If your php is only set to 8mb memory surely trying to process 10 files is going to result in PHP memory exhaustion and script shutdown. Especially when using GD

Soulsuit
May 5th, 2006, 11:23 AM
First let me say hello all. I am a member at many forums and lately I've noticed a small trend going on and it effects me personally so I just wanted to pop in here and see if I can find out what the prob is. I go to several sites where I can UL pictures just fine, no problems at all. Then at other sites I get the same problem. I'll UL pictures to the gallery and when it goes to take me to the process pictures page I get either a page not found or it takes me to a page with the sites header and maybe a few other items on the page but the area where my pictures should be displayed for processing is just blank. If I attach images to a post on some of the sites it will show them in my gallery just fine and on some other sites it will not, will only show them in the post. Any ideas what might be causing this?

Chuck S
May 5th, 2006, 11:53 AM
Hello

You would need to work with the site owner on this issue as it is nothing you can fix. The Photopost customer directly would need to work with us as the direct answer to help that site owner is going to be different depending on the issue they report.

Tracker
May 13th, 2006, 12:01 PM
Well later Photopost's delete a file that can not be processed but if your using an older Photopost yes you can go in and manually remove a corrupt file from his uploads directory for him to be able to process again.

However if your allowing alot of uploads make sure the issue he is not having is one of a PHP memory timeout or exhaustion.

I would only recommend allowing that many uploads at once on systems where you have modified your php.ini file to increase the memory_limit from the default 8mb and max_execution_time to 0

If your php is only set to 8mb memory surely trying to process 10 files is going to result in PHP memory exhaustion and script shutdown. Especially when using GD

I am also having issues uploading video files, if I try anything bigger than 5Mb the system just seems to time out and display's a page unavailable error message. Do you think this would be an issue with the php.ini file settings. If so how would I get my web hosting company to change them:confused:

Chuck S
May 13th, 2006, 12:29 PM
Yes it would be a php.ini issue. You can ask your host to increase the php memory, max execution time and max uploaded filesize.

Tracker
May 14th, 2006, 08:56 AM
Yes it would be a php.ini issue. You can ask your host to increase the php memory, max execution time and max uploaded filesize.

Thanks again Chuck, I'll give my host a try. Do you know of anyway around this issue if they are unwilling to make the changes for me. As this is going to be a real show stopper otherwise...:(

Chuck S
May 14th, 2006, 05:14 PM
If your host will not change the PHP settings there is no way around the max file upload size. You are limited by the PHP settings of the server.

Tracker
May 16th, 2006, 12:01 PM
If your host will not change the PHP settings there is no way around the max file upload size. You are limited by the PHP settings of the server.

Chuck, This is the reply I received from my Host-

"You may create a php.ini file with different values and place it in all directories where you have PHP scripts. Use SSH to gain access to your webspace directories.

upload_max_filesize: 20M
max_execution_time: 30
memory_limit: 40M
post_max_size: 8M
SMTP: localhost

Will this work by just dropping the ini file into the PhotoPost directories..:confused:

Chuck S
May 16th, 2006, 12:07 PM
yes it should if your host allows you to override variables like that.

Tracker
May 16th, 2006, 12:18 PM
Great, sounds like I may be able to make some progress.

Do I have to follow any special rules when creating the php.ini file or is it just a pure text file with the lines listed above.

Thanks for all your help with this Chuck, it's appreciated.

Chuck S
May 16th, 2006, 12:30 PM
just a text file make sure to save as all files and type php.ini you dont want to save as a text

Make the contents of the file the variables you want to override like above.

Tracker
May 17th, 2006, 02:03 PM
All sorted now Chuck it works great, thanks for your help.

Chuck S
May 17th, 2006, 04:15 PM
Enjoy! No problem