PDA

View Full Version : Vb 3.5.0


hunterscentral
June 11th, 2005, 09:20 PM
Will this software still work when vbulletin changes to vb 3.5.0

has anyone tested the beta with PP?

b6gm6n
June 12th, 2005, 09:14 AM
Hi..

I Dont think the beta & final version of vb 3.5 will be that different for photopost integration purposes, saying that i haven't got the beta... although i'll try some tests tonight and see how she runs.

Micheal would make sure integration is perfect for the final of vb

-T

Rik Brown
June 14th, 2005, 03:16 PM
Its my understanding that the 3.5 beta should fix the login problem with those of us who have our forums and photo galleries on different subdomains (even though they have a shared mySQL database on the same server).

I'm a newbie with only about 2 weeks usage of both programs. So if someone more daring is willing to attempt the beta upgrade and report back about whether this fixes the "post requests from foreign hosts not allowed" problem when using differing subdomains, I'd sure appreciate hearing from them here.

Eager to hear! Thanks. -- Rik

Rik Brown
June 15th, 2005, 06:06 PM
I upgraded vb 3.0.7 to the 3.5 beta today. However, I get the following error message from the main photopost page and when I attempt to use the admin gateway:

Warning: main(./includes/functions_showthread.php): failed to open stream: No such file or directory in /var/www/html/subs/photos/header-inc.php on line 82

Fatal error: main(): Failed opening required './includes/functions_showthread.php' (include_path='.:/usr/share/pear') in /var/www/html/subs/photos/header-inc.php on line 82

Any suggestions on what might be wrong?

FYI, vb 3.5 beta installed flawlessly and is working flawlessly so far. But I had to take down Photopost. I'm going to revert to vb 3.0.7 so that I can put Photopost back online.

Any help would be appreciated so that I can attempt it again tomorrow.

Thanks and regards. -- Rik

Chuck S
June 15th, 2005, 07:57 PM
Please take note VB 3.50 beta is not supported yet but you can try this

in header-inc.php find this

require_once('./includes/functions_showthread.php');

replace with

require_once('./includes/class_postbit.php');

Rik Brown
June 16th, 2005, 01:50 PM
Please take note VB 3.50 beta is not supported yet but you can try this

in header-inc.php find this

require_once('./includes/functions_showthread.php');

replace with

require_once('./includes/class_postbit.php');

I got essentially the same error message: "No such file or directory in var/www/html/subs/photos/header-inc.php on line 82."

I guess I'll have to wait for an update of Photopost. Our problem is that no-one can log onto Photopost due to it being on a different subdomain than vBulletin. I'll see about turning off integration with vB until both vb3.5 and the next version of Photopost allow this.

Thanks. -- Rik

Chuck S
June 16th, 2005, 02:21 PM
Your vbpath in config settings has to be incorrect them as I downloaded 3.5 and there is most definately a class_postbit.php file in the includes directory and I beleive thats the file it looks like that replaces the functions we use to grab in functions_showthread.php

Rik Brown
June 16th, 2005, 03:30 PM
Your vbpath in config settings has to be incorrect them as I downloaded 3.5 and there is most definately a class_postbit.php file in the includes directory and I beleive thats the file it looks like that replaces the functions we use to grab in functions_showthread.php

Chuck:

My path was correct. I just forgot to bring vB 3.5 beta back online to apply the change. :o With your advice above, Photopost indeed works with vb 3.5 beta. Thanks!!!

However, I still have the a problem I had with 3.0.7. vB is at Forums.Domain.com and Photopost is at Photos.Domain.com. Both subdomains are on the same server and sharing the same mySQL database. Photopost uses the "pp_" prefix in the database.

The new setup using vb 3.5 (beta 1) gets rid of the "Unable to accept post requests from foreign hosts" problem I was previously experiencing. So, I'm very grateful and will continue with the beta as that's a step forward.

However, no one can logon to Photopost. It appears to be a cookie problem as if a cookie isn't being set. What happens is that there is no error message when one logs on, but the system doesn't recognize the user (i.e. Welcome, UserName) . That applies to me. However, if I enter the PPP admin program and exit it a cookie is set and I'm recognized. Obviously, that isn't an option for my users.

Is there a way to fix that? (Should I open a new thread?). I feel I'm so close to getting this subdomain issue solved once and for all by using vB 3.5.

Thanks. -- Rik

ps: I also visited our Forums site and the cookie set by the PPP adm-index.php wasn't recognized anymore. Does that help?

Michael P
June 16th, 2005, 03:36 PM
Did you set your PP cookie and your vB cookie to use the .domain.com format?

Rik Brown
June 16th, 2005, 04:57 PM
Did you set your PP cookie and your vB cookie to use the .domain.com format?

Yes, its been set that way from the beginning. But don't worry. I'm going to revert to the production version of each product and give up keeping vB and Photopost on separate subdomains for the time being. I just hope that once Photopost is adjusted to the changes in vB 3.5, that the dual subdomain issue is fully resolved.

Thanks again. -- Rik

Chuck S
June 16th, 2005, 06:47 PM
There is no subdomain issue in regards to our product. Many customers run subdomains.

From my testing so far with Photopost and VB 3.5 the only change needed is the one I noted above.

Rik Brown
June 16th, 2005, 07:31 PM
There is no subdomain issue in regards to our product. Many customers run subdomains.

From my testing so far with Photopost and VB 3.5 the only change needed is the one I noted above.

Are you saying I can run both off two differing subdomains:

vB: forums.domain.com
Photopost: photos.domain.com

I couldn't get that going due to cookie issues [getting the "Unable to accept posts from foreign hosts" when I tried] so I've since reverted to running the photos off of the forums subdomain (forums.domain.com/photos).

In any case, since I'm a newbie to both programs, I'll wait for more experienced users to pave the way on this one or I understand things better.

Thanks again. -- Rik

Chuck S
June 16th, 2005, 09:06 PM
You already said VB 3.5 gets rid of the foreign host thing so its just a matter of cookie settings being right.

I have made note of the one change that will be needed from what I see we need to change when vb 3.5 goes gold.

Chuck S
June 16th, 2005, 10:41 PM
Okay here is my take so far

There are no issues running in subdomains

http://photos.omegatron.net/index.php

http://forums.omegatron.net/index.php

Have found a couple minor things I am tweaking here and there.

kall
June 17th, 2005, 06:16 AM
Call to undefined function: parse_bbcode() in /home/nzboards/public_html/gallery/forums/vb3.php on line 622

Any idea what that should be?

Chuck S
June 17th, 2005, 09:01 AM
Please realize we do not support VB 3.5 until it goes gold. My posts here are merely informational on my dealings with the new product in a discussion manner.

Michael P
June 18th, 2005, 11:04 AM
nN the meantime, we'll load up the BETA and see what needs to be done.

Chuck S
June 18th, 2005, 04:15 PM
I will send ya the header-inc.php I am using on my beta site michael so you can see what changes I have made on my test site to get it working with 3.
5. Not many changes are needed really that I see. I noted one above here in this thread the one file change to replace the function_showthread.php There is one more require needed for the comments and wysiwyg.

There is one last issue I see and thats getting the smiley boxes to work on comments as somethings coded a little different.

MediaHound
July 12th, 2005, 01:45 AM
/clicks install
another 3.5.0 Beta 3 success story
thank you

Michael P
July 18th, 2005, 09:25 AM
Call to undefined function: parse_bbcode() in /home/nzboards/public_html/gallery/forums/vb3.php on line 622

In forums/vb3.php, you'll need to change:

line 617:
global $Globals, $vboptions;
to:
global $Globals, $vboptions, $bbcode_parser;

line 623:
$newmarkup = parse_bbcode($markup);
to:
$newmarkup = $bbcode_parser->do_parse($markup);
I believe that will fix it.

Rids
July 27th, 2005, 10:08 AM
vB3.5 is now up to RC1 so its unlikely to be long before it goes gold as they seem to be in turbo mode this time, I've never seen releases from Jelsoft come so thick and fast. I'm setting up a site that uses vB3.5, vBA CMPS, vBA Gallery (public gallery) and Photopost (private gallery) so I'm wondering how close PP is to being ready to support it? Also, can the current version of PP be modded to run with vB3 and if so what needs to be done? With vB3.5 hitting the release candidate stage I imagine a lot more people are going be thinking of upgrading.

Michael P
July 27th, 2005, 10:37 AM
Now that vB3.5 is in RC, I'll be installing/upgrading PhotoPostDev soon to do integration testing.

Chuck S
July 27th, 2005, 10:47 AM
Using the header include I posted here and Michael's little tweak to vb3.php 3.5 works fine so the major thing is just to figure out the best way to support it.

Rids
July 27th, 2005, 12:53 PM
Thats great news guys, the vB / PP combo just gets better and better :)

Steve_C
August 3rd, 2005, 10:06 PM
Now that vB3.5 is in RC, I'll be installing/upgrading PhotoPostDev soon to do integration testing.

So how did this go? Can we install vb RC1 and it work with PP?

Chuck S
August 3rd, 2005, 10:10 PM
Nothing has been released yet on this although I beleive Michael's testing is going good.

Michael P
August 4th, 2005, 09:54 AM
I believe most of the changes have been outlined here, but you'll need to make the changes yourself; we'll be updating PP with a version that works with both version soon.

Rids
August 4th, 2005, 01:53 PM
thats good timing then as RC2 has just been released :D

Michael P
August 4th, 2005, 02:17 PM
Ugh, really? Okay, time to upgrade. lol

Rids
August 4th, 2005, 03:45 PM
Mostly bug fixes I believe

Michael P
August 4th, 2005, 04:06 PM
Okay, I'm going to try and get it upgraded and post a release with the changes. There aren't many, so should be able to do it without requiring a new forums file - just an updated header-inc.php and vb3.php.

accyroy
August 5th, 2005, 10:55 AM
I've just upgraded from vb 3.03 to rc2 and have done the edits as outlined above, but I am getting this error:
Fatal error: Call to a member function on a non-object in /home/landyzon/public_html/photopost/forums/vb3.php on line 623
Michael, I have noticed you have photopostdev on rc2, did you have to change anything else in vb3.php?

Michael P
August 5th, 2005, 01:26 PM
RC2 changed alot of things in how messages are processed. I'm working through the issues as quickly as I can, but a few still remain.

I have just about everything working except editing a post with WYSIWYG interface. It also seems that the interface templates have changed, so am trying to see how this effects us overall.

Rids
August 5th, 2005, 08:54 PM
guess I was wrong then :D

Rhyze
August 16th, 2005, 05:27 PM
Any news Michael as I see you got it running on the Dev site?

Chuck S
August 16th, 2005, 06:46 PM
The builds support everything VB except the WYSIWYG features as there are tons of changes we need to look into

Rhyze
September 1st, 2005, 10:38 PM
I got a few steps further, but got the following error(s):

Warning: mysql_fetch_row(): supplied argument is not a valid MySQL result resource in /gallery/pp-inc.php on line 2885

L2885:

while ( $row = mysql_fetch_row($resultb) ) {

and

Warning: mysql_fetch_row(): supplied argument is not a valid MySQL result resource in /gallery/pp-inc.php on line 771

L771:

while ( $categories = mysql_fetch_row($boards) ) {

See:

http://www.xboxusersgroup.com/gallery

I run vB 3.5 RC2, I also run PP 5.1.3 but the template does show different.

Michael P
September 2nd, 2005, 01:29 PM
I've just posted the 5.14 update for PhotoPost which includes full 3.5RC2 compatibility. Check out the update announcement for complete details.

Mathiau
September 14th, 2005, 04:07 PM
RC3 is out and i tried toinstall 514 and i get these errors


Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/mathiau/www/dapics/forums/vb3.php on line 25



Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/mathiau/www/dapics/forums/vb3.php on line 54


any thoughts ?

board is at


http://fuzzy.phpwebhosting.com/~mathiau/dapics/index.php

Chuck S
September 14th, 2005, 04:10 PM
Have you specified the correct table prefix for vb3 in the install of photopost? This means we cant get the user info which means wrong database info or table install

Mathiau
September 14th, 2005, 04:16 PM
shall chekc it out - much appreciated - i left that field as blank for default.

Chuck S
September 14th, 2005, 04:17 PM
Yep no problem run Vb3 RC3 and photopost here

http://www.reeftalk.com/gallery

Mathiau
September 14th, 2005, 04:21 PM
it worked :) on Vb 3.0.9 i didnt put in anything and it picked up the tables - i guess 3.5 works a little differently....

Chuck S
September 14th, 2005, 04:39 PM
Well 3.09 is the same way you still need to have the proper table prefix entered. More than likely you changed the table prefix on vb35 which I know you can do

Mathiau
September 14th, 2005, 07:27 PM
is possible :d but it works now and if it doesnt again i know how to fix it and what to watch for.

Rik Brown
November 17th, 2005, 09:04 PM
I've just upgraded from vb 3.03 to rc2 and have done the edits as outlined above, but I am getting this error:
Fatal error: Call to a member function on a non-object in /home/landyzon/public_html/photopost/forums/vb3.php on line 623
Michael, I have noticed you have photopostdev on rc2, did you have to change anything else in vb3.php?

I just upgraded today to vBulletin 3.5.1. It looked like I got everything working fine in Photopost 5.1. Then when clicking on thumbnails in order to see the larger image, I get the same error message as indicated in a prior message above in this thread. However, I don't see the fix for this error message.

Anyone know what's going on and needs to be changed?

Thanks. -- Rik