PDA

View Full Version : PhotoPost 5.03 and PHP 4.3.11


WB
April 15th, 2005, 02:13 PM
Our server was upgraded to PHP 4.3.11 for security reasons and we now have an odd issue with bulk uploads that didn't exist with the prior PHP version.

We checked the php.ini settings, etc. and the settings for .11 are the same that were in use for the prior version.

A description of the problem:

The image files are already on the server and we are using the 'Skip upload and process the files in your upload directory' with the uploads folder being set to the default full path of the uploads/1 directory. Thumbnails are set to show during processing.

After clicking Upload/Submit, the first set of thumbnails (however many we chose with 'Number of thumbnails to process next') comes up fine.

On that page however, when we click 'process' instead of the normal 'process wait' when it goes to bulkupload.php, bulkupload.php returns a blank page.

Looking at the command line, the thumbnails got written but the images are still in the uploads/1 directory.

Looking at what PHP reports in its error log, there's only:

PHP Warning: File Upload Mime headers garbled in Unknown on line 0

Since the last point of interaction is the submission of the form, it would seem that there is an issue with .11 and the submitted form.

This happens with multiple image sets. We also tried a set that already had a preexisting gallery (JIC the issue was with the newer files) since we know those files are okay and got the same results.

Thoughts about how to fix?

Thank you.

Chuck S
April 15th, 2005, 02:57 PM
Something would have to be different in the php settings for sure.

Do single uploads work? The bulkupload script is called for single uploads as well

WB
April 15th, 2005, 03:57 PM
PHP configure statement is the same and a comparison of the current ini file with a backup of the prior ini file shows that they have the same settings.

Haven't tried single uploads since we don't use that function. All of our galleries are created with multiple files on the server.

Other suggestions?

Chuck S
April 15th, 2005, 06:42 PM
I would try a single upload just to see.

How about a link to phpinfo?

Link to gallery?

Test login to try upload?

WB
April 16th, 2005, 10:00 AM
omegatron:

Thanks.

We think we've narrowed down the issue.

Since the blank page came back right after the form submit, that's where we started. Looking in the bulkupload template, there's:

<form action="{$Globals['maindir']}/bulkupload.php" method="POST" enctype="multipart/form-data" onSubmit="submitonce(this)">

If we remove the enctype="multipart/form-data" bulkupload goes through fine.

Questions:

We double checked our ini file, etc. and all is set up the same so not really understanding why the issue with the form type. Any thoughts about other PHP settings to check that might impact forms?

Secondly, will removing the enctype have any negative impact?

Lastly, a question for you and Michael, have you run into any form issues on anyone else's install that might point to what to check?

Thanks.

Chuck S
April 16th, 2005, 11:03 AM
This would be the first time I have heard of any form type issue with bulkupload.