PDA

View Full Version : Search Function Configuration


DomainMastersNET
December 10th, 2004, 11:32 AM
Does anyone know why a search from within the catagories of the gallery will not produce any results but a search from the main gallery index will? I can't figure this one out.

Let's say, for instance, I am looking for a specific photo and I know what the photo is called and I know what catagory it's in. So, I go to that catagory but there are so many photos that I would be able to find it much quicker if I just searched for the name of the photo. I type the name of the photo in the search box located in the catagory I know the photo is located in, whether it's the main catagory or a sub catagory it doesn't matter, and click the search button but I get no results. No error messages are produced either.

But, if I go to the main Gallery index, http://prismphotos.com/gallery/ and either click on the search link in the navagation bar and search from the main search page, or just type in the name of the photo in the search box in the main gallery window, the photo shows up in the search results.

Anyone can do this by going to the web site http://www.prismphotos.com/gallery and then go into any of the many catagories and navigate to any photo. Copy the name of the photo and perform the searches as described above.

Any ideas would be greatly appreciated.

Thank you for your time and help.

Sincerely, Richard Williams
DomainMasters.NET Support

Chuck S
December 10th, 2004, 11:37 AM
If your doing a search in the searchbox not the search page its like this

On the index page the cat variable is empty so it is set to all on the search so its pulls entries everywhere

when you are in a category the cat that is searched is the cat your viewing so if that cat specifically for matching entries.

IT DOES MATTER IF ITS A MAIN CAT OR SUBCAT. If you are in a main cat that contains no pictures you will not get a search result. The searchbox only pulls entries from the cat it is in