PDA

View Full Version : Error code: 1 - Windows 2003 Server


flumpydog
August 4th, 2004, 02:36 PM
I know, my first problem is that this install is on a Windows server :eek:
Secondly, I am running V4.0.1, have not had time to upgrade and hopefully this version is not part of the problem.

Moved things over from a Win2K box to a newer box with Windows 2003 with IIS 6 . ImageMagick Version 5.5.6-Q16.

When trying to upload an image from my local PC or process one from the uploads directory, I keep getting the error message:

Error creating thumbnail! Error code: 1

Command: "D:\ImageMagick-5.5.6-Q16\mogrify.exe" -size 100x75 -quality 70 -geometry 100x75 D:/inetpub/AACA Site/photopost/data/500/9133TestModelA-thumb.jpg

Permissions on directories are all set for full access for both the IUSR & IWAM accounts. They also have execute rights on cmd.exe .

When attempting to do it from the uploads directory, I get a slightly different error printed out at the top of the page:

Processing chucktest.jpg... (D:/inetpub/AACA Site/photopost/data/500/9133chucktest.jpg) (500)
D:\ImageMagick-5.5.6-Q16\mogrify.exe: Unable to open file (Site/photopost/data/500/9133chucktest-thumb.jpg) [No such file or directory]

**Note the path in brackets appears incorrect, as it only starts out with "Site" and should start with "D:/inetpub/AACA Site" .

In the config settings, all paths are ok, not sure if ImageMagick does not like the space in the path?

Any ideas on what I should try next would be greatly appreciated. I have scoured the lists and the only thing I found that I have not tried was to modify image.inc.php and replace fs_exec commands to SHELL_EXEC, EXCEPT the FIRST command ???

Thanks,
Chuck

Michael P
August 4th, 2004, 02:43 PM
You have a space in your path name - use short path names as the space is being treated as a parameter seperation in the DOS command.

flumpydog
August 4th, 2004, 07:00 PM
fixed with removing the space from the directory name :)
Thanks!